zfyseu
Posts: 29
Joined: Fri Jun 10, 2016 12:31 pm

How to enable Apparmor on Raspbian?

Tue Jul 05, 2016 7:07 am

Hello, everyone!

I have runned the command "sudo apt-get install apparmor apparmor-profiles apparmor-utils" and "/etc/init.d/apparmor start"

And when do "aa-status" it still returns "apparmoris not loaded".

Is there anynoe know how to solve the problem?

Proxin
Posts: 9
Joined: Thu Jul 25, 2013 9:32 am

Re: How to enable Apparmor on Raspbian?

Fri Apr 07, 2017 10:23 pm

I know this is an old post, but I'm having the exact same problem and wanted to bump it instead of post my own thread because there were no responses to this one.

Has anyone found a fix for enabling AppArmor on Raspbian? I am using Raspbian Jessie.

redauser
Posts: 1
Joined: Fri Jul 21, 2017 12:50 pm

Re: How to enable Apparmor on Raspbian?

Fri Jul 21, 2017 1:02 pm

Hello,
AppArmor is a Linux Security Module, it has to be enabled in the Kernel, the package you are downloading from apt will not work if it is not enabled.
I successfully managed to enable it by recompiling the Kernel with the module enabled.

To recompile the kernel it is possible to follow the official guide https://www.raspberrypi.org/documentati ... uilding.md

During the configuration of the Kernel you have to enable the module, these options have to be enabled:

Code: Select all

CONFIG_SECURITY_APPARMOR=y
CONFIG_SECURITY_APPARMOR_BOOTPARAM_VALUE=1
CONFIG_DEFAULT_SECURITY_APPARMOR=y
CONFIG_AUDIT=y
According to https://wiki.archlinux.org/index.php/AppArmor

Tadaaaaa:
Image

I hope it was clear, if not, just ask :)

Return to “General discussion”