lucaspeed
Posts: 5
Joined: Tue Oct 20, 2015 4:02 pm

Natural scrolling with Jessie

Thu Feb 16, 2017 1:33 pm

Hi, I tried almost everything to solve this problem.
I can't enable natural scrolling.
I tried using Xmodmap, I tried modifying /usr/share/X11/xorg.conf.d/10-evdev.conf, tried even dconf editor to no avail.
Anyone can help me?

ktb
Posts: 1447
Joined: Fri Dec 26, 2014 7:53 pm

Re: Natural scrolling with Jessie

Thu Feb 16, 2017 2:31 pm

You probably need to configure it using libinput -- https://wiki.archlinux.org/index.php/Li ... on_options

nu-bo
Posts: 4
Joined: Sat Apr 01, 2017 11:07 am

Re: Natural scrolling with Jessie

Sat Apr 01, 2017 4:24 pm

I have this same question. Have you solved it? Could you please explain how to "configure it using libinput"?

nu-bo
Posts: 4
Joined: Sat Apr 01, 2017 11:07 am

Re: Natural scrolling with Jessie

Sat Apr 01, 2017 5:49 pm

lucaspeed wrote:Hi, I tried almost everything to solve this problem.
I can't enable natural scrolling.
I tried using Xmodmap, I tried modifying /usr/share/X11/xorg.conf.d/10-evdev.conf, tried even dconf editor to no avail.
Anyone can help me?
I had this same question. Thankfully other people have solved this! There are a couple of ways to enable natural scrolling:

1) Via a Terminal command - described here: http://www.cheesed-off.com/137_reverse-scrolling/
This is easy but has to be run after every reboot.

2) By changing the file /usr/share/X11/xorg.conf.d/10-evdev.conf https://jamesmcdonald.com/2011/07/inver ... in-debian/
Remember to go into the root directory (with cd /..) and use sudo nano /usr/share/X11/xorg.conf.d/10-evdev.conf to open the file editor. Add the line of code as described and press <ctrl>O to save changes before exiting.

Hope that helps! Works for me on RPi 3B running Debian Jessie.

Return to “Beginners”