p4tm4n
Posts: 8
Joined: Fri Jul 01, 2016 2:13 pm

Brand new Raspberry Pi, apt-get upgrade error

Wed Jan 11, 2017 3:38 pm

Hello,

A while ago i tried to setup a Raspberry Pi and got stuck. So now i tried it again, but a similar issue appears. I have a model B+ btw.

I have downloaded today the latest Raspian release and wrote the Image on an 8GB SD-Card (via Win32DiskImager previously formatted by SDFormatter 4.0). I inserted the card and turned on the Pi, it booted and showed the Desktop. First thing to do was `sudo apt-get update` and `sudo apt-get upgrade` which ran into an error.

The error was some `dkpg` Error concering `rpi-chromium-mods`. I did not knew if i could go on, however i tried to install `samba` resulting in an `dkpg` error for `samba` and `rpi-chromium-mods`. Well i decided to reboot the raspberry but it got stuck in the "Welcome to PIXEL" screen with some kind of terminal overlay. I don't think that's normal and i don't know where to go from here.

So i really like to get started using my raspberry pi but i am stuck.

- How can a fresh installation run into an Error? Is my Hardware corrupt?
- If not how can i troubleshoot the reasons of the failure?
- How to get the Pi up and running again?

Thanks for any kind of help

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6072
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Brand new Raspberry Pi, apt-get upgrade error

Wed Jan 11, 2017 3:41 pm

Sounds like a corrupted SD card. Would you happen to know the make and model?

p4tm4n
Posts: 8
Joined: Fri Jul 01, 2016 2:13 pm

Re: Brand new Raspberry Pi, apt-get upgrade error

Wed Jan 11, 2017 4:00 pm

Yes, it is a "Intenso Micro SDHC 8GB Class 10". Can you tell me why do you think that the SD-Card is corrupted? Can i test that in some way?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6072
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Brand new Raspberry Pi, apt-get upgrade error

Wed Jan 11, 2017 4:22 pm

p4tm4n wrote:Yes, it is a "Intenso Micro SDHC 8GB Class 10". Can you tell me why do you think that the SD-Card is corrupted? Can i test that in some way?
Without the full error message, it's only a suspicion. The output of dmesg may show that it's an sd card issue, but you'd need to run it shortly after you start seeing problems like that.

Also see this topic viewtopic.php?f=91&t=170410

smokingwheels
Posts: 34
Joined: Sun Dec 25, 2016 3:11 am

Re: Brand new Raspberry Pi, apt-get upgrade error

Wed Jan 11, 2017 4:41 pm

If you are running Win10 try with Rufus https://rufus.akeo.ie/
You may need to switch to DD burn mode but first try the defaults.

It also has a check for bad blocks!

Image

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6072
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Brand new Raspberry Pi, apt-get upgrade error

Wed Jan 11, 2017 5:34 pm

smokingwheels wrote:If you are running Win10 try with Rufus https://rufus.akeo.ie/
You may need to switch to DD burn mode but first try the defaults.

It also has a check for bad blocks!

Image
If the problem is what I think it is, that's not going to help.

p4tm4n
Posts: 8
Joined: Fri Jul 01, 2016 2:13 pm

Re: Brand new Raspberry Pi, apt-get upgrade error

Wed Jan 11, 2017 10:43 pm

ShiftOnePlus i think you were right. Actually i tried with another SD-Card and now it works :D Yeah! So i think the card is defintely to blame.

Probably the issue was when formatting the previous SD-Card i had not used "FORMAT SIZE ADJUSTMENT". I have not seen or overread this in the guides i have looked into and found this mentioned somewhere this time. So i tried it, i don't know if it could have caused the trouble, I will try again with this option and the old SD-Card tomorrow.

Return to “Troubleshooting”