_Mark_
Posts: 99
Joined: Sun Jun 02, 2013 8:04 am

Release the framebuffer

Thu Nov 24, 2016 8:33 pm

Hi!
Some years ago I ran a buildroot environment on RPi(2) with Qt5 (eglfs) without X. I was launching omxplayer and it worked flawlessly on the "top" of my QML application (I know there is no a "top" with framebuffer...).

Now I'm doing the same thing with Rasbian Jessie Lite and it doesn't work. When I launch omxplayer I hear the sound but no video. It works only if I start my application without any GUI.

Is there something to do in Rasbian to "release" the fb, or to temporary set it to another application?

User avatar
dividuum
Posts: 189
Joined: Sun Jun 16, 2013 1:18 pm
Location: Germany
Contact: Website

Re: Release the framebuffer

Thu Nov 24, 2016 10:35 pm

You can probably just force omxplayer to use a more foregroundy layer. I don't have a Pi nearby, but I think it's the --layer argument for omxplayer. Use something like 200 and you'll probably see the video layer again. If you're interested in what's going on behind the scenes, you might have a look at a blog post I wrote about the hardware video scaleer. Another option would probably be to acutally release the framebuffer, but the first option seems more sensible to me.
info-beamer hosted - A user and programmer friendly digital signage platform for the Pi: https://info-beamer.com/hosted

_Mark_
Posts: 99
Joined: Sun Jun 02, 2013 8:04 am

Re: Release the framebuffer

Fri Nov 25, 2016 8:35 am

Great! It works. I learned somthing new thankful to your answer.

Return to “Advanced users”