akshep
Posts: 4
Joined: Sat Oct 29, 2016 2:18 pm

Lightning bolt icon

Sat Oct 29, 2016 2:27 pm

I just got my pi 3 yesterday and I keep getting the lightning bolt symbol popping up at random times. With some reading I found that this is caused by undervoltage, and if the posts I was reading are correct then It should only pop up at 4.65V or lower. I hooked up my multimeter to the 5v and ground on my gpio and hooked up all my peripherals and its reading a steady 4.72V to 4.83V but the symbol keeps popping up. Does this sound like a defective pi? I have tried 3 different power supplies and usb cables.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12357
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Lightning bolt icon

Sat Oct 29, 2016 2:36 pm

akshep wrote:I just got my pi 3 yesterday and I keep getting the lightning bolt symbol popping up at random times. With some reading I found that this is caused by undervoltage, and if the posts I was reading are correct then It should only pop up at 4.65V or lower. I hooked up my multimeter to the 5v and ground on my gpio and hooked up all my peripherals and its reading a steady 4.72V to 4.83V but the symbol keeps popping up. Does this sound like a defective pi? I have tried 3 different power supplies and usb cables.
very unlikely its a defective PI, but simply a multimeter is not the right tool to catch a dropout, you will need an oscilloscope to catch a drop. Note that even a few milliseconds drop can crash a computer, or in case of the PI a connected USB device, as that is what the under voltage is actually protecting mostly.

in all probability you are using an microUSB cable that has too high an internal resistance.

akshep
Posts: 4
Joined: Sat Oct 29, 2016 2:18 pm

Re: Lightning bolt icon

Sat Oct 29, 2016 2:46 pm

Thanks for the reply. Funny thing is this is the same cable and power supply that I used with my pi 2 and had no issues. I guess I'll try another cable and go from there.

User avatar
rpdom
Posts: 15451
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Lightning bolt icon

Sat Oct 29, 2016 2:49 pm

akshep wrote:Thanks for the reply. Funny thing is this is the same cable and power supply that I used with my pi 2 and had no issues. I guess I'll try another cable and go from there.
The Pi 3 needs more power than a Pi 2.

akshep
Posts: 4
Joined: Sat Oct 29, 2016 2:18 pm

Re: Lightning bolt icon

Sat Oct 29, 2016 4:56 pm

I'm using an iPad charger. 5.1v 2amp

wh7qq
Posts: 1343
Joined: Thu Oct 09, 2014 2:50 am

Re: Lightning bolt icon

Sat Oct 29, 2016 8:07 pm

The charger is likely fine but the cable may well be at fault. Depending on what the Pi3 is doing, the lightning bolt may come on and off and it really is not too much of a problem if it is only once in a while and does not linger. Mine shows up only during boot now but I used to see the "rainbow" fairly often. Get a large gauge uUSB cable, like 20 G, with no switch and no longer than a meter.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5129
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Lightning bolt icon

Sat Oct 29, 2016 8:15 pm

akshep wrote:I'm using an iPad charger. 5.1v 2amp
Unfortunately a label marked "5.1V 2A" does not mean that it will supply 5.1V at the same time as 2A is being drawn ie. 2A is just the maximum current it can supply at some other (lower) voltage (especially as it's a charger).
Whilst I haven't had access to one of those you may find these measurements of two iPhone chargers of interest:
http://www.cpmspectrepi.uk/raspberry_pi ... DC_PSU.27s
(more so the "purple clone" shown afterwards)
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, A+ and a B2) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

akshep
Posts: 4
Joined: Sat Oct 29, 2016 2:18 pm

Re: Lightning bolt icon

Sat Oct 29, 2016 8:44 pm

Any recommendations on a good power supply?

wh7qq
Posts: 1343
Joined: Thu Oct 09, 2014 2:50 am

Re: Lightning bolt icon

Sat Oct 29, 2016 8:56 pm

Check http://www.adafruit.com but also look at their USB cables for a large gauge cord. The voltage drop in the cable can be enough to cause a low voltage signal during power hungry activities. You might not see these when you check with the DVM or multimeter. 2 amps should be plenty but the cord used to charge your iGoodies may not be up to the Pi3 peak demands.

Also, if you have something pluged into a USB port like a hard disk or just a lot of stuff, that can pull too much current. If so, use a USB port expander with a separate power supply.

Julianw12321
Posts: 9
Joined: Sat Oct 29, 2016 9:09 pm

Re: Lightning bolt icon

Sat Oct 29, 2016 11:18 pm

Try a different cable. I had a very good power supply, and I kept on getting the lightning bolt icon every thirty seconds. I replaced the cable with something much higher quality and I never saw that lightning bolt again.
If at first you don’t succeed, call it version 1.0

User avatar
davidcoton
Posts: 4206
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: Lightning bolt icon

Sun Oct 30, 2016 5:34 pm

akshep wrote:Any recommendations on a good power supply?
The "official" 5V1 2A5 supply works in most cases, and has a good cable permanently attached. Note that the recommended current capability for a Pi3 is 2A5, not 2A0 which is sufficient for other models.
Signature retired

stderr
Posts: 2178
Joined: Sat Dec 01, 2012 11:29 pm

Re: Lightning bolt icon

Sun Oct 30, 2016 6:00 pm

FTrevorGowen wrote:
akshep wrote:I'm using an iPad charger. 5.1v 2amp
Unfortunately a label marked "5.1V 2A" does not mean that it will supply 5.1V at the same time as 2A is being drawn
It should mean that, especially if it claims to be able to put out 10 watts. Even though some people insist that it would make things worse, somehow, these problems are due to the pies requiring 5v. If they could accept more than 5v, say they could accept power between 5v and 15v, then people would simply use a little higher voltage power supply and these problems, even most of them due to lame USB cables, would just vanish.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5129
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Lightning bolt icon

Sun Oct 30, 2016 6:23 pm

stderr wrote:
FTrevorGowen wrote:
akshep wrote:I'm using an iPad charger. 5.1v 2amp
Unfortunately a label marked "5.1V 2A" does not mean that it will supply 5.1V at the same time as 2A is being drawn
It should mean that, especially if it claims to be able to put out 10 watts. Even though some people insist that it would make things worse, somehow, these problems are due to the pies requiring 5v. If they could accept more than 5v, say they could accept power between 5v and 15v, then people would simply use a little higher voltage power supply and these problems, even most of them due to lame USB cables, would just vanish.
1) Whilst, I agree, "It should mean that ..." , on the basis of the loading measurements I've performed upon the various brands, models, types of power supplies/chargers (along with other observations reported in this forum), unfortunately this isn't always the case.
2) A charger may supply 5W of (charging) power but, not necessarily as 5V at 1A. Given that many heavily discharged batteries "prefer" to be charged at a lower voltage at the higher charge currents (presumably to reduce internal heating) this should not be unexpected.
3) The "5V" (or rather 4.75V) "lower limit" is not required by the Pi itself, but may be needed by USB devices plugged into a Pi.
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, A+ and a B2) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

User avatar
davidcoton
Posts: 4206
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: Lightning bolt icon

Sun Oct 30, 2016 9:44 pm

stderr wrote: If they could accept more than 5v, say they could accept power between 5v and 15v, then people would simply use a little higher voltage power supply and these problems, even most of them due to lame USB cables, would just vanish.
Well, of course the USB cable problems would disappear, because you can't put more than 5.25V onto a USB connector and stay within the USB spec.
You would need an extra regulator on every Pi, (to generate up to 2A5 @ 5V0) so the cost and possibly board size would go up.
And that is without allowing for problems associated with any other power connector and its (non-)standards.
Signature retired

doveoscar
Posts: 7
Joined: Wed Mar 09, 2016 10:50 pm

Re: Lightning bolt icon

Mon Oct 31, 2016 12:13 pm

I've found some reasonable value decent power cables for my Pi, so in case it helps anybody else...

I had a rack with a couple of Model Bs, a USB powered ethernet switch and an Ankher 60W 6 outlet USB charger, one of the Bs runs a website. When I swapped out the B to a 3, the website started crashing. The symptom was the lightning bolt icon and the red power light flashing. I swapped power cables and it just about hung in, but the light flashed every time I accessed the site and the lightning bolt flashed on and off during boot; it crashed daily rather than constantly. (It worked fine on a official PI psu).

The fix was decent cables. I tried a number and the ones that work are "Anker-6-Pack-PowerLine-Micro-USB" - very good value at 6 for £10, although I'd rather 6 short ones, and "CSL - 0.5m Premium Micro USB to USB Cable" - both from Amazon.

Tinderbox (UK)
Posts: 53
Joined: Sat Oct 08, 2016 8:56 pm
Location: England, United Kingdom

Re: Lightning bolt icon

Mon Oct 31, 2016 2:21 pm

Also have a look at the Tronsmart cables they come in mixed 5 or 6 packs and in black or white, and they are very good, I bought a second pack, I got mine from Amazon UK.

John.
Raspberry Pi 3 Model B

Mixxi
Posts: 1
Joined: Mon Nov 07, 2016 12:35 am

Re: Lightning bolt icon

Mon Nov 07, 2016 12:37 am

Changing the cable worked for me, and since upgrading the cable, I can now stream 1080p 60fps games with no noticeable lag at all, thanks so much for the help
Raspberry Pi 3 model B

ibnux
Posts: 1
Joined: Sat Nov 12, 2016 1:29 pm

myFix Re: Lightning bolt icon

Sat Nov 12, 2016 1:33 pm

i have same problem with RPi 2, it make slow KODI, i try any Adapter still same problem.
then i remember, i always use Overclock at raspi-config.
i change it to none, and reboot, it fix my lightning bolt problem, 5 minutes ago before i post this :D

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12357
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: myFix Re: Lightning bolt icon

Sat Nov 12, 2016 2:21 pm

ibnux wrote:i have same problem with RPi 2, it make slow KODI, i try any Adapter still same problem.
then i remember, i always use Overclock at raspi-config.
i change it to none, and reboot, it fix my lightning bolt problem, 5 minutes ago before i post this :D
yes, overclocking increases the power used, thus increases the current though the (bad) cable, thus increases the voltage drop by the cable.

Tinderbox (UK)
Posts: 53
Joined: Sat Oct 08, 2016 8:56 pm
Location: England, United Kingdom

Re: Lightning bolt icon

Sat Nov 12, 2016 2:25 pm

If you are overclocking your Pi2 cpu check the cpu temp in Kodi while you are playing a video, goto to system/system info/hardware then check the cpu temperature, on the Pi3 if the cpu temp is over 80c the cpu will reduce it`s speed to stay cool, this will give you jerky video it is called throttling.

John.
Raspberry Pi 3 Model B

orionsune
Posts: 1
Joined: Tue Apr 11, 2017 7:13 pm

Re: Lightning bolt icon

Tue Apr 11, 2017 7:15 pm

This thread helped me solve my issue, thanks everyone.

My problem must have been the internal resistance of the USB cable I was using because I tried 5 different chargers before doing a board search on my random lightning bolt.

I tried another (heftier/thicker) cable and viola, no more lightning bolts.

TRT1968
Posts: 1
Joined: Tue Sep 12, 2017 1:58 pm

Re: Lightning bolt icon

Tue Sep 12, 2017 2:03 pm

Yes, this is a bit annoying. I'm using mine for a screen display in a corridor and a lobby. This is new and unexpected after an upgrade to the Pi3 in the hope of smoothing out the animated slide effects and allowing PDFs to be used. I can't have the lightning bolt on the screen interfering with the clock display.
Is there no way to suppress this? It seems to have no ill effects and it generally comes on when the CPU is working just a tiny bit harder during a screen wipe. There's nothing else being powered by the Pi, it's just a tiny Chromium browser running full screen and showing a set webpage. I've tried two lots of cables now and no joy, but I can't make the cables any shorter due to the location of the power socket. It's only 0.75m away as it is! The signal seems very sensitive.

User avatar
rpiMike
Posts: 966
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: Lightning bolt icon

Tue Sep 12, 2017 3:03 pm

Buy the official 5.1Volt 2.5Amp power supply :

http://www.mcmelectronics.com/product/28-21442

Return to “Troubleshooting”