miburge
Posts: 2
Joined: Thu Oct 13, 2016 8:51 pm

VNC not working when disconnected from hdmi.

Thu Oct 13, 2016 9:13 pm

Hi I'm a complete newcomer to the Pi i'm using a type B and having problems with VNC. I can run the pi fine connected to the tv and access the pi via VNC. When I disconnect the pi from the TV and try to access I get a refused access message. Can anybody cast any light as to what i'm doing wrong.

Thanks in Advance.

klricks
Posts: 7025
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: VNC not working when disconnected from hdmi.

Fri Oct 14, 2016 12:32 am

miburge wrote:Hi I'm a complete newcomer to the Pi i'm using a type B and having problems with VNC. I can run the pi fine connected to the tv and access the pi via VNC. When I disconnect the pi from the TV and try to access I get a refused access message. Can anybody cast any light as to what i'm doing wrong.

Thanks in Advance.
Have you done an update recently?
There was an update to VNC:

Code: Select all

sudo apt-get update
sudo apt-get upgrade
You may need to force HDMI to stay on when unplugged.
Edit /boot/config.txt and remove the # from the line that has hdmi_force_hotplug=1

Code: Select all

sudo nano /boot/config.txt
You may also need to enable and adjust these settings:
#hdmi_group=1
#hdmi_mode=1
See this for details: viewtopic.php?f=28&t=5851
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

miburge
Posts: 2
Joined: Thu Oct 13, 2016 8:51 pm

Re: VNC not working when disconnected from hdmi.

Fri Oct 14, 2016 8:32 pm

Hi, Thanks for that worked a treat.
#hdmi_force_hotplug=1
edited to
hdmi_force_hotplug=1
Now to play with output settings to try and get a better screen thanks for that. :D

Return to “Troubleshooting”