Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Can't login after switching monitors

Fri Sep 16, 2016 9:18 am

I have two different Visio monitors that accept HDMI connections. I've shutdown and rebooted repeatedly while connected to the smaller one and never had a problem. I'd planned to sometimes take my Rpi 3 to the living room and hook it to the larger screen, which I thought would be dead simple, but instead it has me all screwed up.

When booting up after connecting to the larger screen, LXDE doesn't come up; instead all I see is the desktop with the raspberry. I discovered I could bring up the terminal, and using that I enter "startx" (also tried "sudo startx") but that leads to an error dialog box with the following:

Code: Select all

GDBus.Error:org.freedesktop. Policy Kit 1. Error. Failed:
An authentication agent already exists for the given
My next step was to issue a "sudo shutdown -r" and see if rebooting helped but no such luck. Next was to do a "sudo shutdown -h" and see what happened. After powering up again, I didn't even get to the normal desktop. Instead, there's a white screen with a taskbar across the top. At the left it says "raspberrypi" and on the right it says "en_US.utf8" (which is good) and a tool symbol with a dropdown selector for Default Xsession, LXDE and Openbox. There's also a power icon at the far right with options to Suspend, Hibernate, Restart or Shutdown.

Clicking LXDE (or anything else does me no good, because there's an "Enter your password" dialog in the middle of the screen. And it won't accept my password. The first time I ran into this was the day after I'd received the pi, and I had already changed my password. The dialog wouldn't take the new one, and I was cussing myself as an idiot thinking I'd somehow mis-remembered it. I ended up using Noobs to resinstall my operating system and started over.

After that fresh start, I got involved in trying to solve a problem connecting to wifi (self inflicted wound) and decided not to change my password this time until after I'd gotten that settled. So tonight, after finally getting hooked up with my wireless, I decided to celebrate by taking the pi in and hooking up to the big TV. The same exact thing happened as before, including the dialog box not taking my password. This time around I HAVE NOT CHANGED MY PASSWORD. I'm user pi, and should have password raspberry, but the dialog will not accept it. I can't even get to terminal now; basically all I can do is keep entering my password or use the shutdown option.

I should note that before doing the reboot I used my windows laptop to dig up a thread where somebody was getting the same Policy Kit error - see here: viewtopic.php?p=774355#p774355. I took the suggestion in this post: viewtopic.php?p=735697#p735697 to add 'LXDE' to the "NotShownIn" line in /etc/xdg/autostart/lxpolkit.desktop. (I was hoping to avoid the very situation I'm in with that, but no luck.)

I should also mention that once I'm in this loop, returning to the original monitor does me no good - I've still got a password dialog that won't accept the default password, and no way out so far as I can see. I'm very much hoping I won't have to use Noobs to wipe everything and start over again, but that's the way it's looking. I'm headed for bed now, hoping against hope I'll find a solution (or at least some suggestions) in the morning.

The thing that really bugs me is that I know people take their pi's to schools and other places to give demos. I can't imagine they always take their monitors along, so it must be possible to switch to a different monitor. I can't see why that matters anyway, when the pi is just sending out an hdmi signal...

Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Can't login after switching monitors

Fri Sep 16, 2016 7:35 pm

I've used Noobs to reinstall my OS - on the plus side it goes quicker once you gain experience. For the benefit of anyone reading this because they are experiencing a similar problem, I should mention that the first time I got into that deadly embrace, I did some research on my Win7 laptop and found several threads where the suggestion was made to create a 2nd user account (using Terminal), then reboot and login with that. I did so, but could never get back to using my super user permissions. That time around I was thinking (hoping?) that not having an internet connection when I booted with the other monitor might be the issue, and that the OS could find what it needed and I'd be fine.

I didn't bother with creating a second account last night. I still had internet via wifi, and my bluetooth keyboard was working just fine. The one and only difference was that I had my hdmi cable (the same cable) connected to a different Visio monitor. No matter, I was in the dance of death and seeing no way out I decided to just start fresh.

At this point my intentions are to create a second user account and login repeatedly into both accounts so that there can't be a shred of doubt about having the passwords straight. I also plan to create a backup disk image, so I can get back to functioning with the 'good' monitor should I be foolish enough to try to boot again with the 'bad' monitor.

(Actually I'm wondering whether I could have reinstalled my OS while using the other monitor, and if that would have resulted in it becoming the 'good' one, and the one I'm using now creating the problem if I switched. Trouble is, I'd have to be prepared to reinstall my OS another time or two to test the theory, and I'm not.)

Actually at this point I'm very wary of trying to use any other monitor for display, and that bugs me. I'm still hoping somebody with knowledge/experience in such matters will weigh in and explain why connecting to a different monitor can cause such problems, and how to deal with it (short of brain wiping my pi) should it happen. I look forward to hearing from you.

Return to “Troubleshooting”