jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1688
Joined: Thu Jul 11, 2013 2:37 pm

STICKY: Compute Module Dev Kit Camera IO Adapters - README

Fri Jun 27, 2014 11:34 am

There is an issue with the camera (and display) adapters bundled with the Compute Module Development Kit.

An incorrect flat cable connector has been fitted to the initial production run of CMIO-CAMERA and CMIO-DISPLAY interposing boards. If a camera is plugged in using the cable supplied with the camera (15-way, type D) then pins 1-15 on the CMIO adapter will be connected to pins 15-1 on the camera.

Do not use the original CMIO-DISPLAY or CMIO-CAMERA interposing boards. Replacements are available free-issued from distributors that you bought the CM development kit from.

Update 13/9/14: this issue should now be resolved. Distributors should have gotten in contact with you about replacement IO Adapter boards. If they haven't, send them an email.
Rockets are loud.
https://astro-pi.org

andy33
Posts: 41
Joined: Fri Jul 06, 2012 12:42 pm

Re: Compute Module IO Camera Adapters - DO NOT USE

Fri Jun 27, 2014 12:29 pm

I had already tried the camera with a CM module yesterday and it never worked. Today I tried that camera on a raspberry pi and it will not work at all. So it looks like by connecting my camera to the I/O board I have fried my camera :(

paulsohier
Posts: 12
Joined: Mon Jun 04, 2012 9:24 am

Re: Compute Module IO Camera Adapters - DO NOT USE

Tue Jul 01, 2014 7:39 am

Maybe it is a good idea to inform buyers of the module directly not to use the adapters, in case they dont read the forums here?

jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1688
Joined: Thu Jul 11, 2013 2:37 pm

Re: Compute Module IO Camera Adapters - DO NOT USE

Tue Jul 01, 2014 9:51 am

paulsohier wrote:Maybe it is a good idea to inform buyers of the module directly not to use the adapters, in case they dont read the forums here?
RS and Farnell are already contacting buyers of the CMIO development kit directly.
Rockets are loud.
https://astro-pi.org

paulsohier
Posts: 12
Joined: Mon Jun 04, 2012 9:24 am

Re: Compute Module IO Camera Adapters - DO NOT USE

Tue Jul 01, 2014 10:05 am

Ok, sounds good (However, I haven't received anything yet?)

MarkDaniels
Posts: 59
Joined: Sun Oct 28, 2012 2:01 pm

Re: Compute Module IO Camera Adapters - DO NOT USE

Tue Jul 01, 2014 2:57 pm

Farnell have just sent me an email about this problem, so it looks like they are on the case.

andy33
Posts: 41
Joined: Fri Jul 06, 2012 12:42 pm

Re: Compute Module IO Camera Adapters - DO NOT USE

Tue Jul 01, 2014 3:03 pm

MarkDaniels wrote:Farnell have just sent me an email about this problem, so it looks like they are on the case.
And what is there advice please ? I ordered mine from Farnell but no email yet.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 17896
Joined: Sat Jul 30, 2011 7:41 pm

Re: Compute Module IO Camera Adapters - DO NOT USE

Tue Jul 01, 2014 3:04 pm

andy33 wrote:
MarkDaniels wrote:Farnell have just sent me an email about this problem, so it looks like they are on the case.
And what is there advice please ? I ordered mine from Farnell but no email yet.
See first post in this thread...
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Please direct all questions to the forum, I do not do support via PM.


rotwang
Posts: 221
Joined: Sat Dec 07, 2013 1:12 pm

Re: Compute Module IO Camera Adapters - DO NOT USE

Wed Jul 23, 2014 10:44 am

Could somebody post pictures and details of "bad" boards and "good" boards so we can know when to start using them. My originals (from Farnell) were silk-screened "V1.1". Second devkit arrived yesterday from RS, boards are still silk-screened "V1.1". I assume these are all "bad" boards, how will I positively identify a "good" board if these ever arrive?
P.S. RS delivery may be slow, but they ship the correct micr-usb cable.

EDIT - forgot to add - no note in the packaging or the parcel about using/not using the camera/display adapters.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4632
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Compute Module IO Camera Adapters - DO NOT USE

Wed Jul 23, 2014 10:47 am

On the bad board, the bigger connector opens and flips up. On the fixed board, the same flap opens down towards the board.

paulsohier
Posts: 12
Joined: Mon Jun 04, 2012 9:24 am

Re: Compute Module IO Camera Adapters - DO NOT USE

Wed Jul 23, 2014 10:50 am

Are there other that havent received a email from farnell yet? I ordered from Farnell netherlands, with a private non business account, but haven;t had any mail or a replacement PCB.

andy33
Posts: 41
Joined: Fri Jul 06, 2012 12:42 pm

Re: Compute Module IO Camera Adapters - DO NOT USE

Wed Jul 23, 2014 11:29 am

paulsohier wrote:Are there other that havent received a email from farnell yet? I ordered from Farnell netherlands, with a private non business account, but haven;t had any mail or a replacement PCB.
Yeah I also ordered fron Farnell netherlands the same way as you. I also still haven't received an email yet. I have tried to contact them by email, first 2 emails to the sales team who processed my order and once to an support email I found on there website but no reply yet.

Does anyone have a contact email for the support team at Farnell netherlands please?

Andy.

rotwang
Posts: 221
Joined: Sat Dec 07, 2013 1:12 pm

Re: Compute Module IO Camera Adapters - DO NOT USE

Wed Jul 23, 2014 1:28 pm

ShiftPlusOne wrote:On the bad board, the bigger connector opens and flips up. On the fixed board, the same flap opens down towards the board.
Still confusing, on both sets of boards the black frame on the free connector just slides forward parallel to the pcb. However, on the RS boards, the solid part of the black frame is adjacent to the pcb, whereas on the first set from Farnell the solid part of the black frame is at the top of the body. To put it another way with the pcb down and the connectors up, new RS set camera cable goes OVER black locking bar, old Farnell set camera cable goes UNDER black locking bar, so is it OVER=good, UNDER=bad?

Could someone post a photo of a known good.

Edit - got webcam to stop sulking so attached photo of new RS board showing what I mean by OVER.
Attachments
CMCONN.jpg
new CM adaptor boards
CMCONN.jpg (20.34 KiB) Viewed 9856 times

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4632
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Compute Module IO Camera Adapters - DO NOT USE

Wed Jul 23, 2014 1:48 pm

rotwang wrote:To put it another way with the pcb down and the connectors up, new RS set camera cable goes OVER black locking bar, old Farnell set camera cable goes UNDER black locking bar, so is it OVER=good, UNDER=bad?
Yes, exactly

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: Compute Module IO Camera Adapters - DO NOT USE

Wed Jul 23, 2014 11:01 pm

Ah! So the "fixed" boards are available now? Does anyone know if replacements are being sent out yet?
(yes, I did get the notification email from Farnell saying they were working on replacements at the beginning of the month, but not heard anything since then...)

User avatar
paulcaseyjr
Posts: 28
Joined: Wed Jun 04, 2014 1:23 pm
Location: New Hampshire
Contact: Website

Re: Compute Module IO Camera Adapters - DO NOT USE

Thu Jul 24, 2014 7:17 pm

I just had notification from Newark Element 14, saying replacements will be sent "in the near future"

User avatar
masafumi_ohta
Forum Moderator
Forum Moderator
Posts: 327
Joined: Sun Sep 09, 2012 12:07 am
Location: Tokyo
Contact: Website

Re: Compute Module IO Camera Adapters - DO NOT USE

Sun Jul 27, 2014 3:32 pm

paulcaseyjr wrote:I just had notification from Newark Element 14, saying replacements will be sent "in the near future"
Yes..now both RS and Farnell have some CM stocks...how about fixing this issue..? CPC Farnell has NOT noticed any update informations to me at all...
---
Masafumi Ohta
https://groups.google.com/d/forum/japanese-raspberry-pi-users-group

User avatar
masafumi_ohta
Forum Moderator
Forum Moderator
Posts: 327
Joined: Sun Sep 09, 2012 12:07 am
Location: Tokyo
Contact: Website

Re: Compute Module IO Camera Adapters - DO NOT USE

Tue Jul 29, 2014 12:03 am

masafumi_ohta wrote:
paulcaseyjr wrote:I just had notification from Newark Element 14, saying replacements will be sent "in the near future"
Yes..now both RS and Farnell have some CM stocks...how about fixing this issue..? CPC Farnell has NOT noticed any update informations to me at all...
Farnell told me yesterday the problem has been fixed (asked again and again... :( )
---
Masafumi Ohta
https://groups.google.com/d/forum/japanese-raspberry-pi-users-group

tsaG
Posts: 80
Joined: Thu Jun 26, 2014 1:30 pm

Re: Compute Module IO Camera Adapters - DO NOT USE

Wed Jul 30, 2014 7:25 pm

Farnell told me they will ship my board in the 39th week of the year :D I cancelled my order and bought it from RS which shipped immediately

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: Compute Module IO Camera Adapters - DO NOT USE

Fri Aug 15, 2014 4:36 pm

I received my replacement CSI & DSI IO adapters today :)
And after following the instructions at http://www.raspberrypi.org/documentatio ... -camera.md I can confirm that the camera (well at least one of them!) now works on the CM 8-)

User avatar
mikronauts
Posts: 2621
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Compute Module IO Camera Adapters - DO NOT USE

Thu Sep 11, 2014 12:14 am

YEY!

I got the new camera/display adapters! (I just received my Compute Module dev kit yesterday)
rotwang wrote:
ShiftPlusOne wrote:On the bad board, the bigger connector opens and flips up. On the fixed board, the same flap opens down towards the board.
Still confusing, on both sets of boards the black frame on the free connector just slides forward parallel to the pcb. However, on the RS boards, the solid part of the black frame is adjacent to the pcb, whereas on the first set from Farnell the solid part of the black frame is at the top of the body. To put it another way with the pcb down and the connectors up, new RS set camera cable goes OVER black locking bar, old Farnell set camera cable goes UNDER black locking bar, so is it OVER=good, UNDER=bad?

Could someone post a photo of a known good.

Edit - got webcam to stop sulking so attached photo of new RS board showing what I mean by OVER.
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

Return to “Compute Module”

Who is online

Users browsing this forum: No registered users and 2 guests