jbaker
Posts: 1
Joined: Tue Apr 21, 2020 4:52 am

Re: SDIO1 CM3+ WILC1000

Tue Apr 21, 2020 5:15 am

Scprt wrote:
Fri Apr 17, 2020 11:17 am
pkar wrote:
Wed Feb 19, 2020 9:34 am


Hi Scprt,

I'm getting the same output as you, were you able to figure out what was going wrong?

I am use the WILC100-SD board. I have shortened the wires as much as a I can and have even tried to reduce the clock below 5MHz, but nothing seems to help.

I tried the driver direct from Atmel as well as the one in the RPi repo (not sure what the difference or even if there is one), but they both produce the same result.

I'm going to see if I can get a scope on the signals see if there is something to learn there.

Hi pkar ,


I found a few problems.
First, the atwilc1000 in the RPi repo does not work. I'm using Atmel driver. Unfortunately, low speeds are not a solution. I tried lowering the first speeds, but I get errors at low speeds, so I chose speeds between 12.5k and 25k.

The second problem is the RESET_N pin. The problem arises if there is power in the pin at the system startup. I do the HIGH output for the pin when the system is turned on. Datasheet writes that there should be at least 5 ms difference with system power.But driver need more than 5.

If even one of the cables is not transmitting fully, there is a problem. There was a problem in the area where I connected CM3 + module on the PCB so one of the pins was non-contact. When I checked it all seemed to be running smoothly. When I soldered again, 1 of the problems was solved.
I'm working on a CM3+ (non-lite) carrier with this module right now as well. What trouble was the kernel driver giving you? I haven't fired it up yet.

I've got prototypes of the carrier board with the module that I haven't fully tested yet. I also have the previous revision of the board with no wireless module, but the SDIO1 interface goes to an SD card socket so I'm using that for testing right now with the ATWILC3000 dev board. The newer prototypes don't have a USB port so I need to get the driver working on the dev kit first. My new boards have the reset, enable, and IRQ pins routed to GPIOs, but I don't have them (or Bluetooth) attached to the dev kit setup. I'm trying to at least get the WiFi working on the dev kit and then SSHing into the new boards to get Bluetooth running. The new boards don't have USB so it's tricky to test.

Return to “Compute Module”