rego21
Posts: 26
Joined: Fri Feb 16, 2018 4:09 pm

ENC28J60 on others SPIs

Thu Oct 18, 2018 1:46 pm

Hello all!

Yesterday i successful connected the ENC28J60 trough the SPI0 on Compute Module. However when i try it with SPI2 everything seems fines but doesn't assign an IP to the Compute Module. Im runing an DHCP server on my laptop and worked before with SPI0. Any clue what this problem can be?

Thanks!

PhilE
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2279
Joined: Mon Sep 29, 2014 1:07 pm
Location: Cambridge

Re: ENC28J60 on others SPIs

Thu Oct 18, 2018 2:00 pm

When you create a post like this, try and anticipate what the first questions might be and provide the information upfront. Anyone hoping to help you will need to know how you configured the device - hardware and software - on spi0, and what you changed to try to use spi2 instead.

rego21
Posts: 26
Joined: Fri Feb 16, 2018 4:09 pm

Re: ENC28J60 on others SPIs

Thu Oct 18, 2018 2:12 pm

PhilE wrote:
Thu Oct 18, 2018 2:00 pm
When you create a post like this, try and anticipate what the first questions might be and provide the information upfront. Anyone hoping to help you will need to know how you configured the device - hardware and software - on spi0, and what you changed to try to use spi2 instead.
You are rigth sorry! For SPI0 i just edited the config.txt file on boot folder by adding:

Code: Select all

dtoverlay=enc28j60
At the moment for SPI1 the config.txt is:

Code: Select all

dtoverlay=enc28j60-spi1 //One custom overlay to work on SPI1
dtoverlay=spi1_cs1,cs0_spidev=off

fruitoftheloom
Posts: 20139
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: ENC28J60 on others SPIs

Thu Oct 18, 2018 2:13 pm

rego21 wrote:
Thu Oct 18, 2018 1:46 pm
Hello all!

Yesterday i successful connected the ENC28J60 trough the SPI0 on Compute Module. However when i try it with SPI2 everything seems fines but doesn't assign an IP to the Compute Module. Im runing an DHCP server on my laptop and worked before with SPI0. Any clue what this problem can be?

Thanks!

This was original SPI0 post:

viewtopic.php?f=98&t=224915
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

PhilE
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2279
Joined: Mon Sep 29, 2014 1:07 pm
Location: Cambridge

Re: ENC28J60 on others SPIs

Thu Oct 18, 2018 2:15 pm

Since this is attached hardware people also need to know about the wiring used in each case.

You really didn't make it easier by starting a new topic, and it is in no way specific to the Compute Module.

Return to “Compute Module”