jsl12345
Posts: 1
Joined: Mon Oct 01, 2018 1:18 pm

cm3 boot problem eMMC

Mon Oct 01, 2018 1:31 pm

Hi All!

I've got cm3L and cm3 booting my images from SD flawless.
I once had an original raspbian image booting from my cm3' eMMC.
But if I now try to boot "my" image from eMMC nothing happens.
Few facts/tests done:
  • * With nothing I mean notihng! :-) Both LEDs stay on and I also tried the "BOOT_UART=1" with the newest bootcode.bin to no avail... :-(
    * Tried with my kernel and boot stuff *and* with the original raspbian kernel and boot files
    * About the boot partition:
    * Tried both mkfs.msdos and mkfs.vfat creations. Nothing
    BTW: Everything done on a debian host...
    * Aligned the first (FAT32) partition *exactly* like that from the raspbian image (i.e. start at sector 8192) -> Nope
All the MSD bootloading via "rpiboot" works like a charm. So I won't blame the MSD mode or any cable or that.
I can see all filesystem changes permanently after clean umounting and switch between "boot try" and MSD mode.
Another thing: Of course I change the "USB slave boot" jumper everytime I switch modes... :-)

What makes me wonder the most is that I made a small MSDOS part. on a SD, patched BOOT_UART=1 into it, booted it on a cm3 lite and iit gave me (early) boot messages. Took this same part. (with MBR) from the card flashed it onto cm3 and..... Nothing! (on the serial console)
On the other hand only two hours ago I had a complete booting and working raspbian from the onboard eMMC...

How might this be gone South? Any tips appreciated! ;-)

Salut, Joerg

gsh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1331
Joined: Sat Sep 10, 2011 11:43 am

Re: cm3 boot problem eMMC

Tue Oct 02, 2018 11:57 am

Does it still work if you use a Raspbian image on there?

i.e. just dd a Raspbian Lite image to the CM3
--
Gordon Hollingworth PhD
Raspberry Pi - Director of Software Engineering

Return to “Compute Module”