Wsr3
Posts: 6
Joined: Tue Feb 14, 2017 12:48 am

Setting up compute 3

Tue Jun 26, 2018 10:24 pm

Im trying to set up a compute 3 module and am not having any luck.
Compute 3 with on board storage (not the light)
Current io board
Windows 10 and 7
Following the published instructions, I downloaded the windows boot program and installed it, insralled the module in the io board, set the jumper and connected as instructed. I powered the io board, both leds on steady, and, well nothing happened,. The windows machine did not see anyrhing connected. I tried three different compute modules, two io boards, different power supplies, usb cables, two windows 10 machine and also a 7. With the same result.
Any help would be great.
Thanks,
Bill

gsh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1317
Joined: Sat Sep 10, 2011 11:43 am

Re: Setting up compute 3

Wed Jun 27, 2018 12:54 pm

1) The jumper must be in the EN position
2) Connect the PC through micro USB to to J15 (USB SLAVE connector)
3) Connect micro USB power supply to USB POWER socket (you cannot both power and connect USB with a single connector)
4) Run rpiboot from the menu, it should sit saying "Waiting for BCM2835/6/7" then start programming the device
--
Gordon Hollingworth PhD
Raspberry Pi - Director of Software Engineering

Wsr3
Posts: 6
Joined: Tue Feb 14, 2017 12:48 am

Re: Setting up compute 3

Wed Jun 27, 2018 2:53 pm

I followed those instructions, but the windows machine never recognizes an attached storage device. I tried running the rpiboot and get the "waiting for BCM2835/6/7 message, but that's as far as it goes, the windows machine still doesn't see it.

gsh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1317
Joined: Sat Sep 10, 2011 11:43 am

Re: Setting up compute 3

Wed Jun 27, 2018 5:41 pm

Only other thing to check is the quality of USB cable, there are often issues with poor quality cables...

Other thing to do is plug into a Raspberry Pi and see what dmesg gives you
--
Gordon Hollingworth PhD
Raspberry Pi - Director of Software Engineering

Wsr3
Posts: 6
Joined: Tue Feb 14, 2017 12:48 am

Re: Setting up compute 3

Wed Jun 27, 2018 7:42 pm

I will try using the pi and see if that works.
I have tried several known good cables with no luck.
I have installed the rpiboot on my windows machines( win7 and 10 64bit) it just never appears to load the usb drivers. Is there a way to do that manually instead of just connecting the module and powering it up?

gsh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1317
Joined: Sat Sep 10, 2011 11:43 am

Re: Setting up compute 3

Thu Jun 28, 2018 7:42 am

Does the device appear in the device manager?
--
Gordon Hollingworth PhD
Raspberry Pi - Director of Software Engineering

Wsr3
Posts: 6
Joined: Tue Feb 14, 2017 12:48 am

Re: Setting up compute 3

Thu Jun 28, 2018 12:08 pm

No, the windows machines don't see it at all.

Wsr3
Posts: 6
Joined: Tue Feb 14, 2017 12:48 am

Re: Setting up compute 3

Fri Jun 29, 2018 10:20 pm

OK lesson learned. When someone assures you the the usb cables are kown good, check them yourself on a known good device, and not just for charging! I tried a fourth one today and it worked
perfectly.
Thanks for the help.

Return to “Compute Module”

Who is online

Users browsing this forum: No registered users and 4 guests