Posts: 6
Joined: Mon Aug 28, 2017 8:23 am

Issue in Flashing CM3 eMMC

Wed Aug 30, 2017 7:35 am

I am using Windows 7 for the development and I am follow the instruction (https://www.raspberrypi.org/documentati ... lashing.md) to flash the CM3 board eMMC, i tried the "WINDOWS INSTALLER" section, but when the CM3 board plug into the computer USB port, the board is recognized as "Microsoft XBox Controller Type S" device. Hence, i uninstall the device from the "Device Manager".

After uninstall it, i see the CM3 board recognized as "BCM2710 Boot" in the "Device Manager". Then i manually select "Let me pick from a list of device drivers on my computer", if i select "Universal Serial Bus devices", then i see a list of "Microsoft Xbox Controller Type S" for me to choose from. If i select "libusb (WinUSB) devices", then i can select "BCM270x Boot". I think "BCM270x Boot" is the device that i should select.

After all the installation, when i launch the program "rpiboot.exe". this is what i see,

waiting for BCM2835/6/7
sending bootcode.bin
Failed control transfer
Failed to write correct length, returned -7

Then this 4 sentences are keep repeating.

Since i have the issue of using the window installer method, I have tried the "MANUAL CYGWIN INSTALL" method run in windows 7 in the instruction also but same issue happened to me. Can anyone help to support to solve the eMMC flashing issue?

BTw, anyone know why when the device first plug in to the computer, it shows "BCM2710", but when i do the driver installation, the driver can be selected is "BCM270x"? is the issue caused by the driver provided not compatible to the CM3 hardware? The microcontroller used in this board is BCM2837, what is the meaning of the above mentioned BCM2710 and BCM270x?

Posts: 6
Joined: Mon Aug 28, 2017 8:23 am

Re: Issue in Flashing CM3 eMMC

Wed Aug 30, 2017 11:02 am

no more issue when run the rpiboot as "Run as Administrator".
reference: http://www.embeddedpi.com/documentation ... ute-module.
Everytime power cycle the board, the USB cable communication cable to the computer need to plug and unplug as well.
issue close.

Posts: 6
Joined: Mon Aug 28, 2017 8:23 am

Re: Issue in Flashing CM3 eMMC

Sat Sep 02, 2017 11:44 am

if transfer failed, (no need to close the running executable, just leave it there) then need to unplug the usb cable and then plug in the usb cable again (without unplug the power supply cable). according to the test, this can help to solve the problem.

Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1186
Joined: Sat Sep 10, 2011 11:43 am

Re: Issue in Flashing CM3 eMMC

Mon Sep 04, 2017 10:17 am

If you are using that documentation then you are using an old version of the installer that does not support CM3 properly.

This has recently been updated, you'll know whether you have the right version because:

1) The installer is named rpiboot_setup.exe
2) The driver does not come up as "Microsoft Xbox Controller Type S"

If you're still having trouble, I can only assume this is a problem with uninstalling a previous version of the driver... I'd suggest downloading and running usbdeview from NirSoft and right clicking on the device (when you've plugged it in) and uninstalling the driver using that. Then install using rpiboot_setup.exe

Gordon Hollingworth PhD
Raspberry Pi - Director of Software Engineering

Return to “Compute Module”

Who is online

Users browsing this forum: No registered users and 3 guests