sgx
Posts: 3
Joined: Sun May 14, 2017 10:40 am

How to enable boot messages over UART

Sat May 27, 2017 12:26 pm

Hello,

I have a CM3L and its dev kit.

The system boots, I have a shell over UART (on pins 14 and 15), I can login and type commands.

I would like to see the boot messages, i.e. what I see when I type dmesg.

The only thing that looks like a kernel message that I can see now is when I reboot :
$ sudo reboot
[366.163397] reboot: Restarting system
My current and default cmdline.txt is:
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=c45d042d-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
I have already tried:
- put "dtparam=uart0=on" in /boot/config.txt
- change "console=serial0,115200" to "console=ttyAMA0,115200" in cmdline.txt
- remove the first console occurence in cmdline.txt, leave console=tty1

What should I do in order to see log messages ?

When looking around on internet, it seems like it should be default.

Thank you

FrozenNick
Posts: 24
Joined: Tue Apr 18, 2017 3:51 am

Re: How to enable boot messages over UART

Fri Jul 28, 2017 7:57 am

Code: Select all

console=serial0,115200 console=ttyAMA0
remember to add a few lines to /boot/config.txt too!

Code: Select all

dtoverlay=pi3-miniuart-bt
core_freq=250
This works for me!

You should also use

Code: Select all

sudo raspi-gpio get
to check TX RX is really on GPIO 14 15 or not

mkirk
Posts: 25
Joined: Tue Mar 06, 2018 4:21 pm

Re: How to enable boot messages over UART

Tue Feb 12, 2019 10:21 pm

in the cmdline.txt file, remove the word "quiet" to allow display of boot activity.

Return to “Compute Module”