thatchunkylad198966
Posts: 576
Joined: Thu Jul 04, 2019 10:21 am
Location: UK, Birmingham

[SOLVED]Can't get NVMe working, it worked until a reboot and now says I need updated software!

Sun Jun 20, 2021 5:42 pm

Can't get NVMe working, it worked until a reboot and now says I need updated software!
I followed the sticky here, sdcard copied over and ran rpi-update. it booted, I ran apt update and then upgraded to Sid and now it refuses to boot from the NVMe and defaults to the eMMC.

I try and run rpi-eeprom-update and it says it's not enabled.

Yes, I've read the docs 100 times and still can't figure it out.
Last edited by thatchunkylad198966 on Sun Jun 20, 2021 8:46 pm, edited 1 time in total.
[NEW] Ubuntu - CM4/RPi4B custom image(s)! XFCE4, LXQt, i3-WM, WireGuard, Samba, Kodi, Latest MESA graphics drivers!

Code: Select all

https://www.raspberrypi.org/forums/viewtopic.php?f=131&t=314419

User avatar
thagrol
Posts: 5221
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: Can't get NVMe working, it worked until a reboot and now says I need updated software!

Sun Jun 20, 2021 6:02 pm

thatchunkylad198966 wrote:
Sun Jun 20, 2021 5:42 pm
then upgraded to Sid
I expect that's the problem right there. Stick with Buster.
I'm a volunteer. Take me for granted or abuse my support and I will walk away

All advice given is based on my experience. it worked for me, it may not work for you.
Need help? https://github.com/thagrol/Guides

thatchunkylad198966
Posts: 576
Joined: Thu Jul 04, 2019 10:21 am
Location: UK, Birmingham

Re: Can't get NVMe working, it worked until a reboot and now says I need updated software!

Sun Jun 20, 2021 6:18 pm

thagrol wrote:
Sun Jun 20, 2021 6:02 pm
thatchunkylad198966 wrote:
Sun Jun 20, 2021 5:42 pm
then upgraded to Sid
I expect that's the problem right there. Stick with Buster.
If you can't help, don't reply. :? :roll:
[NEW] Ubuntu - CM4/RPi4B custom image(s)! XFCE4, LXQt, i3-WM, WireGuard, Samba, Kodi, Latest MESA graphics drivers!

Code: Select all

https://www.raspberrypi.org/forums/viewtopic.php?f=131&t=314419

aBUGSworstnightmare
Posts: 3182
Joined: Tue Jun 30, 2015 1:35 pm

Re: Can't get NVMe working, it worked until a reboot and now says I need updated software!

Sun Jun 20, 2021 6:33 pm

thatchunkylad198966 wrote:
Sun Jun 20, 2021 6:18 pm
thagrol wrote:
Sun Jun 20, 2021 6:02 pm
thatchunkylad198966 wrote:
Sun Jun 20, 2021 5:42 pm
then upgraded to Sid
I expect that's the problem right there. Stick with Buster.
If you can't help, don't reply. :? :roll:
sorry, bit what is Sid? Maybe that's not supporting booting from NVMe (yet) as this has been added to Raspbian just a few weeks ago.
Maybe a later kernel (5.11 or 5.12) will help.

User avatar
rpdom
Posts: 18863
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Can't get NVMe working, it worked until a reboot and now says I need updated software!

Sun Jun 20, 2021 6:35 pm

thatchunkylad198966 wrote:
Sun Jun 20, 2021 6:18 pm
thagrol wrote:
Sun Jun 20, 2021 6:02 pm
thatchunkylad198966 wrote:
Sun Jun 20, 2021 5:42 pm
then upgraded to Sid
I expect that's the problem right there. Stick with Buster.
If you can't help, don't reply. :? :roll:
If you won't listen to advice, don't post. :roll:
Unreadable squiggle

thatchunkylad198966
Posts: 576
Joined: Thu Jul 04, 2019 10:21 am
Location: UK, Birmingham

Re: Can't get NVMe working, it worked until a reboot and now says I need updated software!

Sun Jun 20, 2021 6:46 pm

aBUGSworstnightmare wrote:
Sun Jun 20, 2021 6:33 pm
thatchunkylad198966 wrote:
Sun Jun 20, 2021 6:18 pm
thagrol wrote:
Sun Jun 20, 2021 6:02 pm


I expect that's the problem right there. Stick with Buster.
If you can't help, don't reply. :? :roll:
sorry, bit what is Sid? Maybe that's not supporting booting from NVMe (yet) as this has been added to Raspbian just a few weeks ago.
Maybe a later kernel (5.11 or 5.12) will help.
Sid = unstable version of Debian; though I think you know this.
rpdom wrote:
thatchunkylad198966 wrote:
Sun Jun 20, 2021 6:18 pm
thagrol wrote:
Sun Jun 20, 2021 6:02 pm
I expect that's the problem right there. Stick with Buster.
If you can't help, don't reply. :? :roll:
If you won't listen to advice, don't post. :roll:
The bootloader is stuck on March the 17th, upgrading to Sid didn't intervene with it.
Thanks.
[NEW] Ubuntu - CM4/RPi4B custom image(s)! XFCE4, LXQt, i3-WM, WireGuard, Samba, Kodi, Latest MESA graphics drivers!

Code: Select all

https://www.raspberrypi.org/forums/viewtopic.php?f=131&t=314419

thatchunkylad198966
Posts: 576
Joined: Thu Jul 04, 2019 10:21 am
Location: UK, Birmingham

Re: Can't get NVMe working, it worked until a reboot and now says I need updated software!

Sun Jun 20, 2021 7:09 pm

K so the bootloader is updated to June 17th instead of March but it's saying when it's booting from the eMMC that pci-e link is down???
and lsblk isn't showing the NVMe and I reboot then lsblk shows it???
[NEW] Ubuntu - CM4/RPi4B custom image(s)! XFCE4, LXQt, i3-WM, WireGuard, Samba, Kodi, Latest MESA graphics drivers!

Code: Select all

https://www.raspberrypi.org/forums/viewtopic.php?f=131&t=314419

User avatar
thagrol
Posts: 5221
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: Can't get NVMe working, it worked until a reboot and now says I need updated software!

Sun Jun 20, 2021 7:14 pm

thatchunkylad198966 wrote:
Sun Jun 20, 2021 6:18 pm
thagrol wrote:
Sun Jun 20, 2021 6:02 pm
thatchunkylad198966 wrote:
Sun Jun 20, 2021 5:42 pm
then upgraded to Sid
I expect that's the problem right there. Stick with Buster.
If you can't help, don't reply. :? :roll:
Well that was uncalled for. And offensive.

You didn't ask for help running Sid. In fact yopu didn't actualy ask for help at all. You just stated what you'd done and that "I've read the docs 100 times and still can't figure it out.". Without saying which docs either.

AFAIK Debain Sid isn't supported. Not even by Debian as it's unstable. But you should have know that and expected problems.

If you don't have the skills and knowledge to cope with that, the best advice anyone can give is to switch back to the latest stable release. I.E. Buster.

Edit: and fregardless of the stable vs unstable thing. In place upgrades between major releases has never been recommended or supported.
I'm a volunteer. Take me for granted or abuse my support and I will walk away

All advice given is based on my experience. it worked for me, it may not work for you.
Need help? https://github.com/thagrol/Guides

thatchunkylad198966
Posts: 576
Joined: Thu Jul 04, 2019 10:21 am
Location: UK, Birmingham

Re: Can't get NVMe working, it worked until a reboot and now says I need updated software!

Sun Jun 20, 2021 8:05 pm

thagrol wrote:
Sun Jun 20, 2021 7:14 pm
thatchunkylad198966 wrote:
Sun Jun 20, 2021 6:18 pm
thagrol wrote:
Sun Jun 20, 2021 6:02 pm


I expect that's the problem right there. Stick with Buster.
If you can't help, don't reply. :? :roll:
Well that was uncalled for. And offensive.
So was your reply... /shrug

I finally updated the eeprom. was hard but I managed it. :oops:
[NEW] Ubuntu - CM4/RPi4B custom image(s)! XFCE4, LXQt, i3-WM, WireGuard, Samba, Kodi, Latest MESA graphics drivers!

Code: Select all

https://www.raspberrypi.org/forums/viewtopic.php?f=131&t=314419

User avatar
Gavinmc42
Posts: 5834
Joined: Wed Aug 28, 2013 3:31 am

Re: [SOLVED]Can't get NVMe working, it worked until a reboot and now says I need updated software!

Mon Jun 21, 2021 1:55 am

Lots of moving parts.
That NVMe boot support is in rapid change mode.
While the EEPROM updates might allow booting it does not mean an unstable OS can use it.

RPT can test Raspberry Pi OS but not every other distribution and they will not bother much with Sid which is always unstable. Wonder who they named it after?
sid is subject to massive changes and in-place library updates. This can result in a very unstable system which contains packages that cannot be installed due to missing libraries, dependencies that cannot be fulfilled etc. Use it at your own risk!
Jeff Geerling has merch shirt "It has been 0 days since a kernel compile".
Sid is bleeding edge and so is NVMe, pack bandaids.
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

User avatar
rpdom
Posts: 18863
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: [SOLVED]Can't get NVMe working, it worked until a reboot and now says I need updated software!

Mon Jun 21, 2021 8:42 am

Gavinmc42 wrote:
Mon Jun 21, 2021 1:55 am
RPT can test Raspberry Pi OS but not every other distribution and they will not bother much with Sid which is always unstable. Wonder who they named it after?
In Toy Story, Sid was the boy next door who broke all the toys.
Unreadable squiggle

PhilE
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 3962
Joined: Mon Sep 29, 2014 1:07 pm
Location: Cambridge

Re: [SOLVED]Can't get NVMe working, it worked until a reboot and now says I need updated software!

Mon Jun 21, 2021 10:20 am

Users of Compute Modules are expected to be a bit more resourceful than the average user. That goes doubly so for users of beta features like NVME. Using unsupported software as well is asking for trouble.

User avatar
Gavinmc42
Posts: 5834
Joined: Wed Aug 28, 2013 3:31 am

Re: [SOLVED]Can't get NVMe working, it worked until a reboot and now says I need updated software!

Tue Jun 22, 2021 12:17 am

Users of Compute Modules are expected to be a bit more resourceful than the average user.
Document the path so others can follow the trail through the jungle.
Using unsupported software as well is asking for trouble.
Parachuting with one you didn't pack yourself?

If it was easy there would be no learning experience ;)
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

Return to “Compute Module”