Xenoshell
Posts: 27
Joined: Wed Nov 29, 2017 12:56 pm

CM3+ wont boot from eMMC anymore

Mon Jun 29, 2020 11:32 am

Hello everyone,

my main goal is to boot from USB-Stick using the CM3+

In another post here, i managed to do this using the CM3L module.
Here are the steps i took:
1. Flash SD/eMMC with Raspberry Pi OS
2. Start the Raspberry Pi and open command line and type: echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt
3. Check if OTP bit is set correctly with: vcgencmd otp_dump | grep 17:
If output is 17:3020000a everything is ok, otherwise reboot and try again
4. Now flash an empty USB-Stick with Raspberry Pi OS and add the line
Program_usb_boot_mode=1
To the config.txt file
5. Don’t forget to delete the files on the eMMC or remove the SD-card
6. Connect the USB_OTGID Pin to GND (If you removed the R12 Resistor)
7. Plug in the USB-Stick and connect a micro-USB cable with enough Ampere to POWER IN

Now i removed the R12 from my IO Board and the OTP bit is set using the CM3L (i dont know if that only counts now for the CM3L or both)

Then i tried to flash the eMMC to recreate the steps using the CM3+ i took with the CM3L.

The problem i'm having is that it just wont boot anymore from the eMMC. I flashed it using balenaEtcher and it finished without Errors. Then when i connect it to power and my screen with hdmi i get no signal. Just the ACT and PWR LED flashing.

Does anyone have a suggestion? Any help is appreciated.
Last edited by Xenoshell on Wed Jul 01, 2020 8:33 am, edited 1 time in total.

Xenoshell
Posts: 27
Joined: Wed Nov 29, 2017 12:56 pm

Re: CM3+ wont boot anymore

Tue Jun 30, 2020 10:08 am

Oh i also forgot to mention.

It also wont boot if i plug a bootable USB-Stick into the IO Board. :?

I already think again that i destroyed my board, but i had that thought already a couple times :roll:

Return to “Compute Module”