neilld
Posts: 40
Joined: Mon Dec 22, 2014 3:03 pm

Desktop startup with VNC

Thu Jan 15, 2015 6:02 pm

I have configured my B+ to boot on startup to the Desktop with tightvnc enabled. I am getting the following error message
"GDBus Error:org freedesktop.PolicyKit1 Error.Failed; An Authentication agent already exixts for the given subject"
On OK the message disappears and everything seems to work so this is really just an irritation but I would like to find out what the issue is.
Any input appreciated

DFN

wcashman
Posts: 2
Joined: Sun Jan 04, 2015 8:40 pm

Re: Desktop startup with VNC

Sat Jan 17, 2015 6:46 am

I receive this error the moment I connect from my client with VNC. Have you found anything out yet?

PeterB2
Posts: 3
Joined: Sat Jan 17, 2015 3:39 pm

Re: Desktop startup with VNC

Sat Jan 17, 2015 4:34 pm

The same question is answered at http://www.blackmoreops.com/2013/11/19/ ... ian-linux/ and at https://sites.google.com/site/mbbackus/ ... /raspberry BUT -

The recommendation is to go "Preferences->Desktop Session Settings" and un-check "PolicyKit Authentication Agent" - but I can't can't find 'Desktop Session Settings' as a menu item in the current version of Raspbian. Maybe it used to appear in earlier versions.

However a Desktop Session Settings window can be opened if you go to the terminal and run

Code: Select all

lxsession-edit
This shows an 'LXPolKit' item that can be unticked. You probably need to reboot to find out if that solves the problem.

Warning - I'm a Linux/RPi newbie, so try this at your own risk.

Peter

neilld
Posts: 40
Joined: Mon Dec 22, 2014 3:03 pm

Re: Desktop startup with VNC

Sun Jan 25, 2015 4:29 pm

Thanks, your method works. Don't understand why the desktop environment has changed for no apparent reason. Has Raspberry pi been taken over by Microsoft?

lorf79
Posts: 1
Joined: Sun Oct 11, 2015 10:18 am

Re: Desktop startup with VNC

Sun Oct 11, 2015 10:29 am

Hi, I also had this issue and the method above worked, but not the first time. I had to run the command: lxsession-edit and untick 'LXPolKit' two times with a restart between the two times. I donut know why (I'm a rookie RPi user).

Mats

tom_rey
Posts: 1
Joined: Sun Jan 03, 2016 2:51 pm

Re: Desktop startup with VNC

Sun Jan 03, 2016 2:55 pm

Hello,

I just downloaded the actual Jessie image, installed tightvncsevrer and finally tried "lxsession-edit" to disable LXPolKit but still: don't see "PolicyKit Authentication Agent", just:

- tightVNC
- lxkeymap

Any suggestions?

Eddydude
Posts: 1
Joined: Tue Mar 01, 2016 8:23 am

Re: Desktop startup with VNC

Tue Mar 01, 2016 8:26 am

@ Peter you can find the desktop session this way: preferences -> main menu editor -> preferences -> check the desktop session settings box.

Dylan144GT
Posts: 4
Joined: Mon Mar 07, 2016 10:08 pm

Re: Desktop startup with VNC

Mon Mar 07, 2016 10:15 pm

Hi Guys,

I'm new to the Pi, got a Pi 2 about a month before the release of the Pi 3. Bummer! Anyway, still thrilled to finally have a Pi in the arsenal! Very cool little board, loving it!

I am having a problem though in that I am getting this same error, but I cannot get your solution to work! I have unchecked the LXPolKit and the error still comes up at startup.

Any ideas? If you need any additional info, just let me know and I'll post it.

Thanks,

Dylan

qsevers23
Posts: 2
Joined: Sat Nov 08, 2014 5:57 pm

Re: Desktop startup with VNC

Thu Mar 10, 2016 3:03 am

I have also been having this problem, whenever I login through an automatic VNC it shows a pop-up window with the same error as listed above.

I also have another question, I realize that this is probably not the place to post this (PI noobie and Forum noobie), I setup my VNC startup under:

/home/pi/.config/autostart/tightvnc.desktop

To edit the file I enter: nano tighvnc.desktop

It has the following code:

[Desktop Entry]
Type=Application
Name=TightVNC
Exec=vncserver :1
StartupNotify=false

I was wondering if there was a way to open this up in 1920x1080. When I connect to it via this VNC it has a very low resolution, that's not even large enough for standard window.

If you open the VNC through terminal via:

vncserver :1 -geometry 1920x1080 -depth 24

It works perfectly, in 1920x1080.

Any ideas?

Thanks

DirkS
Posts: 9620
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Desktop startup with VNC

Thu Mar 10, 2016 8:43 am

qsevers23 wrote:I was wondering if there was a way to open this up in 1920x1080. When I connect to it via this VNC it has a very low resolution, that's not even large enough for standard window.

If you open the VNC through terminal via:

Code: Select all

vncserver :1 -geometry 1920x1080 -depth 24
Put that command in the Exec line?

Dylan144GT
Posts: 4
Joined: Mon Mar 07, 2016 10:08 pm

Re: Desktop startup with VNC

Thu Mar 10, 2016 9:10 am

Yes, this is exactly what you do. Mine works, I just still have this annoying error that keeps popping up on start up. I even tried to remove the package, but something tells me this was a bad idea! :D

qsevers23
Posts: 2
Joined: Sat Nov 08, 2014 5:57 pm

Re: Desktop startup with VNC

Thu Mar 10, 2016 2:30 pm

DirkS wrote:
qsevers23 wrote:I was wondering if there was a way to open this up in 1920x1080. When I connect to it via this VNC it has a very low resolution, that's not even large enough for standard window.

If you open the VNC through terminal via:

Code: Select all

vncserver :1 -geometry 1920x1080 -depth 24
Put that command in the Exec line?
I have tried that, it doesn't even boot a VNC on boot

DirkS
Posts: 9620
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Desktop startup with VNC

Thu Mar 10, 2016 10:39 pm

See viewtopic.php?t=123457 for auto-starting vncserver on Raspbian Jessie.

neilld
Posts: 40
Joined: Mon Dec 22, 2014 3:03 pm

Re: Desktop startup with VNC

Tue May 03, 2016 1:05 pm

Eddydude wrote:@ Peter you can find the desktop session this way: preferences -> main menu editor -> preferences -> check the desktop session settings box.
Just tried this but can't see any reference to lxpolkit etc.
Any further clues?

adrianmcli
Posts: 2
Joined: Sun May 15, 2016 5:00 pm

Re: Desktop startup with VNC

Sun May 15, 2016 5:04 pm

I think I've found a clue, but not yet a complete solution.

1) First go to: Menu > Preferences > Main Menu Editor
2) Check the box for "Default applications for LXSession"
3) Go to: Menu > Preferences > Default applications for LXSession
4) Under the Core Applications tab, notice that Polkit agent is set to lxpolkit.

That's all I've got so far, but it seems like this might be the "new" way to disable the lxpolkit for the session. I haven't tried it yet because the info warned me I shouldn't make that field blank, but if someone braver than me wants to give it a shot, this might just be it.

Dylan144GT
Posts: 4
Joined: Mon Mar 07, 2016 10:08 pm

Re: Desktop startup with VNC

Tue May 17, 2016 7:51 am

DirkS wrote:See viewtopic.php?t=123457 for auto-starting vncserver on Raspbian Jessie.
This worked perfectly for me, thanks DirkS!

Kind regards,

Dylan

Oxize
Posts: 13
Joined: Sat May 28, 2016 6:48 pm

Re: Desktop startup with VNC

Sat May 28, 2016 8:41 pm

adrianmcli wrote:I think I've found a clue, but not yet a complete solution.

1) First go to: Menu > Preferences > Main Menu Editor
2) Check the box for "Default applications for LXSession"
3) Go to: Menu > Preferences > Default applications for LXSession
4) Under the Core Applications tab, notice that Polkit agent is set to lxpolkit.

That's all I've got so far, but it seems like this might be the "new" way to disable the lxpolkit for the session. I haven't tried it yet because the info warned me I shouldn't make that field blank, but if someone braver than me wants to give it a shot, this might just be it.
I just made it blank. It didnt show up anymore.

User avatar
ashish5679
Posts: 1
Joined: Thu Dec 22, 2016 11:13 pm

Re: Desktop startup with VNC

Thu Dec 22, 2016 11:27 pm

adrianmcli wrote:I think I've found a clue, but not yet a complete solution.

1) First go to: Menu > Preferences > Main Menu Editor
2) Check the box for "Default applications for LXSession"
3) Go to: Menu > Preferences > Default applications for LXSession
4) Under the Core Applications tab, notice that Polkit agent is set to lxpolkit.

That's all I've got so far, but it seems like this might be the "new" way to disable the lxpolkit for the session. I haven't tried it yet because the info warned me I shouldn't make that field blank, but if someone braver than me wants to give it a shot, this might just be it.
This comment saved my day. I tried a lot of things but finally by this method I could get rid of after-boot-warning. Thanks for insight :)
Hi,

Warm regards

handleyman
Posts: 1
Joined: Fri Mar 17, 2017 12:51 pm

Re: Desktop startup with VNC

Fri Mar 17, 2017 12:57 pm

This was a great suggestion and thanks for all the advice here. The problem is, that after leaving that field blank, an external USB drive failed to start. This is also set to load at start-up,along with VNC. As soon as I put lxpolkit back in, everything started up OK again. So...., any other suggestions??!

Return to “Beginners”