Posts: 2
Joined: Sun Oct 26, 2014 11:04 am

logon screen when starting pi after using it as a terminal

Sun Oct 26, 2014 5:27 pm


Raspberrypi B+ using Raspbian

I have been playing with a B+ pi for a few weeks and have managed to set it up on my network and as a terminal. Twice now when I switched the pi on instead of going to the desktop it goes to a small window with a picture of a monitor with raspberrypi underneath asking for a login when I enter the pi name and the password when asked it accepts it gives me a plank screen then goes back to the login screen. The first time this happened I reloaded the software from the recovery disk but this time I do not want to loose all my work. Help!

Posts: 2
Joined: Sun Oct 26, 2014 11:04 am

Re: logon screen when starting pi after using it as a termin

Tue Oct 28, 2014 6:19 pm

This problem is now solved. At the login screen Ctrl-Alt-F1 which takes you to the login, login as pi and if when you run startx you get this error

xauth: timeout in locking authority file /home/pi/.Xauthority

type sudo chown -R pi:pi /home/pi and then try startx again. Then set your boot preference and reboot.

This problem is caused by using a vnc server so the problem might come back but at least this is a quick fix.

Posts: 6
Joined: Tue Mar 04, 2014 1:13 am

Re: logon screen when starting pi after using it as a termin

Tue Feb 10, 2015 1:51 am

RaspberryPi B using Raspian 12/24/14, and old NOOBS

I've been having the same problem as vmorley. I am unable to get past a newly appearing logon screen. I have the problem on 3 different sd cards, 2 with Raspian 12/24 and one with the old NOOBS.

One of these Raspian cards was generated with Bill Wilson's rpi-clone, and the NOOBS card copied with win32 diskimager. I still have two old NOOBS cards that boot into the desktop ok. I have no Idea how these 3 cards got changed.

As a 74 year old Linux Noob, I've become nearly convinced that I don't have enough time or neurons left, to keep screwing with this moving got'cha. Its' been a steep learning curve thus far. I had succeeded in installing CUPS, to printing a test page on my Cannon All-in-one.

On those logon screens I was unable to login to pi, but could get into a "practice user" that I had established. It went to the desktop. Unfortunately, I had not yet learned to assign it any privilege, so it was useless.

After browsing these forums for many hours, tried to reset the pi password by appending "init=/bin/sh" and then trying "init=/bin/boot" in cmdline.txt. No help, deleted these appendages.

Update: Problem solved.

I had read vmorley's posts several times before realizing that my problem was identical. The topic title did not initially connect with me, as I had not setup a terminal, and little idea of a VNC server.

In summary; his fix worked for me. I would add only one thing: To his sentence "Then set boot preferences", I would insert "(in raspi-config)" for the Noob like me.

I'm wondering at this point as to whether my problem may have resulted from not specifying boot options in Bill Wilson's excellent raspi-clone.

Return to “Beginners”