User avatar
RDK
Posts: 309
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

Powered USB Hub Issues

Tue Oct 14, 2014 6:07 am

Folks....I recently bought a powered USB 3.0 hub from Darty in France (IT WORKS brand). When I booted up my Pi, I noticed several messages something like "USB Port 2 over powered...". Unfortunately they went by too fast to get the whole wording.

Of course that scared me a bit. So I shutdown and disconnected the hub. On reboot all seemed ok, but later (several days and several reboots later) I noticed that the Pi was now complaining that some of the file systems did not mount correctly and I should run fdsk.

When I tried to umount /boot before running the fdsk procedure, it completely corrupted my SD card and I had to restore from the last backup, which worked, but now it is complaining about my USB memory stick.

I'm running a B+ Pi with Raspbian OS.

Question 1. What is going on with my powered hub and the Pi? And what should I do about it? I eventually want to attach a external hard drive which is powered via the USB connection.

Question 2. Is/was the SD card corruption related to trying out the powered hub or just a "random act of violence"?

Thanks.....RDK

User avatar
Burngate
Posts: 6309
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK Tralfamadore
Contact: Website

Re: Powered USB Hub Issues

Tue Oct 14, 2014 10:10 am

If I'm correct in my diagnosis, there's a thread on a similar problem that might be of interest. http://www.raspberrypi.org/forums/viewt ... 28&t=87297

On the B+ there's a chip that does USB power switching / current limiting, etc. It has a fault-flag output connected to the LAN/USB chip port-2 control.
So if the first chip detects any problem, then the LAN/USB chip flags it up to the SoC, and Linux interprets it as an over-current problem on port 2

The SD card corruption problem is likely to be unrelated

User avatar
RDK
Posts: 309
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

Re: Powered USB Hub Issues

Tue Oct 14, 2014 1:45 pm

Thanks for the reference. I've read through that thread and basically it does not seem to apply to my issue. In my case the Pi's USB ports are all working.

I have a 16GB USB memory stick, a USB keyboard and a USB wireless mouse. All are working fine.

And, since I fdisk-ed the USB stick via my PC, it is no longer giving a "dirty bit" warning during the Pi's boot-up.

Thanks again....RDK

User avatar
RDK
Posts: 309
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

Re: Powered USB Hub Issues

Wed Oct 15, 2014 7:03 am

Folks...Having pondered my issue with my powered USB hub and my B+ Pi, I'm wondering if:
  • 1. Are there issues with USB 3 devices and the Pi?
    2. Are there issues with USB 3 hubs and the Pi, or more importantly for me, the B+ Pi?
    3. Is there a list of known good powered USB hubs
Thanks....RDK

User avatar
DougieLawson
Posts: 39204
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Powered USB Hub Issues

Wed Oct 15, 2014 7:09 am

Your Raspberry Pi has NO SUPPORT for USB 3.0 unless things are running in USB 2.0 compatibility mode.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

User avatar
RDK
Posts: 309
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

Re: Powered USB Hub Issues

Fri Oct 17, 2014 4:45 am

Folks.....I bought a D-Link USB 2 powered hub and it seems to be ok with my B+ Pi, ie no messages during boot up. I will now add another USB memory stick. If there are no follow-up messages on this thread then you can assume it is all working fine,,,,,RDK

Return to “Beginners”