mcgyver83
Posts: 361
Joined: Fri Oct 05, 2012 11:49 am

After reboot always desktop environment

Sat Jul 26, 2014 12:40 pm

Hi all,
I'm using the raspberry with the tv but I only for XBMC, otherwise I'm using ssh connection and headless stuff.
I usually do dist-upgrade and rpi-update each week.
I saw a couple of days ago that there is a new entry in the raspi-config "boot menù".
I choose "Console Text console, requiring login (default)" but each time I reboot it still go to "Scratch Start the Scratch programming environment upon boot" i think, because is something like a desktop environment but not the standard LXDE one.

I'm using jessie raspbian.

klricks
Posts: 7129
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: After reboot always desktop environment

Sat Jul 26, 2014 1:29 pm

Quit scratch and watch the text messages on the screen.
You will see a message something like...... Type [CTRL] C within 5 seconds.
After you type [CTRL] C you will have terminal prompt where you can run...... sudo raspi-config ...... and choose the boot to console or desktop.
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

mcgyver83
Posts: 361
Joined: Fri Oct 05, 2012 11:49 am

Re: After reboot always desktop environment

Sat Jul 26, 2014 5:10 pm

I don't have a keyboard attached to the raspberry,
I run from ssh connection "sudo raspi-config" and choose to boot directly to the console.
Why it still go to the "desktop environment"?

mcgyver83
Posts: 361
Joined: Fri Oct 05, 2012 11:49 am

Re: After reboot always desktop environment

Sat Aug 23, 2014 9:38 am

Any others hints?

mcgyver83
Posts: 361
Joined: Fri Oct 05, 2012 11:49 am

Re: After reboot always desktop environment

Mon Sep 08, 2014 9:46 pm

I still have this strange behaviour.
No suggstions?

User avatar
socialdefect
Posts: 110
Joined: Mon Jun 25, 2012 9:02 pm
Location: Tilburg, the Netherlands
Contact: Website

Re: After reboot always desktop environment

Mon Sep 08, 2014 11:04 pm

I use a minimal custom build of raspbian so I have to guess the display manager used (I guess slim) but here's how to disable it manually:

If you know which display manager is used on your Pi it's a piece of Pi, if you don't list the contents of /etc/init.d/ like this:

Code: Select all

ls /etc/init.d
Now look for any of these: lightdm, xdm, gdm, slim

Next you can use update-rc.d to disable the dm like this:

Code: Select all

sudo update-rc.d slim -f remove
Or you can save yourself the hassle and automate the task like this:

Code: Select all

DM="lightdm xdm gdm slim"
for i in $DM ; do
if [ -f /etc/init.d/$i ] ; then
sudo update-rc.d $i -f remove
fi
done
== If it's not broke... I'm not done fixing it! ==

mcgyver83
Posts: 361
Joined: Fri Oct 05, 2012 11:49 am

Re: After reboot always desktop environment

Sun Oct 12, 2014 7:56 am

I have lightdm but with

Code: Select all

pi@raspberrypi ~ $ sudo update-rc.d lightdm -f remove
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> disable|enable [S|2|3|4|5]
                -n: not really
                -f: force

The disable|enable API is not stable and might change in the future.
without -f

Code: Select all

pi@raspberrypi ~ $ sudo update-rc.d lightdm remove                         pi@raspberrypi ~ $

but at reboot I still see the desktop env :(

Return to “Beginners”