Page 1 of 1

RPi with Debian and Gnome - Mouse/Keyb. not working

Posted: Sat Jun 02, 2012 9:43 am
by Hoax
Hi there!

I would describe myself as a linux beginner, so please be patient with me ;)

I'm running a RPi with Debian squeeze (19.04.12) + new firmware updates and a 32GB SDHC with wireless mouse and keyboard. The keyboard works fine with the usual debian shell. I don't had to install any driver or so. It worked out of the box. It's a cherry wireless keyboard/mouse combi. (Cherry JG-0100DE (keyboard) + JF-0100 (mouse)). There is a little USB device which connects the input devices with the RPi. As said the KB works fine with the debian shell.

Now I installed GNOME3 which now starts automatically after boot. Sadly I cannot use both of the devices. Do I have to configure something for Gnome to work correct with these devices? I'm not very experienced with linux so I don't know where to start now. I can clearly say that the system isn't freezed as I'm able to connect remotely via ssh.

Maybe somebody can give me a clue?

Thank you and regards from germany
Florian

Re: RPi with Debian and Gnome - Mouse/Keyb. not working

Posted: Sat Jun 02, 2012 11:04 am
by Hoax
Btw: This is what dmesg shows me:

input: MLK Wireless Desktop as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3:1.0/input/input0
generic-usb 0003:046A:010A.0001: input: USB HID v1.00 Keyboard [MLK Wireless Desktop] on usb-bcm2708_usb-1.3/input0
input: MLK Wireless Desktop as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3:1.1/input/input1
generic-usb 0003:046A:010A.0002: input,hiddev0: USB HID v1.00 Mouse [MLK Wireless Desktop] on usb-bcm2708_usb-1.3/input1

Re: RPi with Debian and Gnome - Mouse/Keyb. not working

Posted: Sat Jun 02, 2012 12:45 pm
by Larry_Adlard
I'm not a Linux expert either but I've been using it as an alternative to MS Windows for a few years now.

Linux is structured like the early versions of MS. There is the kernel which gets updated now and then like MSDos 5,6, etc. Then XWindows is built on top of that as was Windows 95/98/XP.

Quite a bit of work goes into the seperate Desktop Versions, XFCE, KDE, GNOME. I suspect the version of Gnome you have is not compatible with the XWindows implementation on RPi. It think the reason Gnome wasn't chosen is it takes more resources than the RPi is designed to deliver.

I'd really like the RPi to replace a laptop by running Gnome and OpenOffice but realistically there would need to be a few changes. On the other hand I have a HP Notebook with a 1GHz VIA processor that happily runs Mint Debian with Gnome and runs the full suite of programmes. The main difference is the amount of memory available. Another point. There has been almost 20 years to optimise Linux for Intel processors. The implementation for ARM processors is new and may not be optimal yet.

I'm sorry but I can't tell you how to fix it. Not very helpful but maybe someone knows more than me. It might help if you say where you downloaded the Gnome3 from.

Greetings to Germany :)

Re: RPi with Debian and Gnome - Mouse/Keyb. not working

Posted: Sun Jun 03, 2012 2:45 pm
by AndrewS
I strongly doubt it's anything specific to do with Gnome3 (although it may indeed be a bit too 'resource heavy' to run properly on the Pi?).
Maybe you're also suffering from http://www.raspberrypi.org/phpBB3/viewt ... 902#p86902 ? Does your mouse/keyboard work okay with the LXDE that comes with the debian image by default?

Re: RPi with Debian and Gnome - Mouse/Keyb. not working

Posted: Sun Jun 03, 2012 3:14 pm
by Hoax
Hi there!

LXDE does also not work with mouse/keyb. This is also a problem with Fedora Remix. But openelec has mouse/kb Support within xbmc.

I ve heard that this is a pi issue because of sdhc cards bigger than 8gb

Re: RPi with Debian and Gnome - Mouse/Keyb. not working

Posted: Sun Jun 03, 2012 3:52 pm
by AndrewS
I can't see how the size of the SD card has any bearing on the matter?!
Can you try a better / more powerful PSU? Or a wired (instead of wireless) keyboard & mouse?

Re: RPi with Debian and Gnome - Mouse/Keyb. not working

Posted: Sun Jun 03, 2012 8:46 pm
by Hoax
I've already tested a more powerful one.. no effect. But the KB works within the debian/fedora shell. It's also working with OpenELEC (with mouse support). Only GDM3 and LXDE won't work (others not tested).

A friend told me he had the same issue with bigger cards than 8GB. With 8GB SDHC everythings okay, above it's not. Seems to be a firmware issue. But I know how stupid this sounds.. but it seems it's like this. Too bad I don't have any other cards to try with.

Re: RPi with Debian and Gnome - Mouse/Keyb. not working

Posted: Sun Jun 03, 2012 10:53 pm
by Hoax
Working now. I've made an update with hexxeh's rpi-update tool which fixed the problem.
https://github.com/Hexxeh/rpi-update

Thanks for your help!

Re: RPi with Debian and Gnome - Mouse/Keyb. not working

Posted: Mon Jun 04, 2012 12:39 am
by AndrewS
Thanks for reporting the fix :)