tazd
Posts: 2
Joined: Fri Jun 01, 2012 5:13 pm

Strange Problems

Fri Jun 01, 2012 5:22 pm

Got my Raspberry Pi the other and had my first change to play today.

Strange thing is when trying to enter the username and password it the keyboard is extremely unresponsive and the screen will suddenly start scrolling after entering the password then just take you back to entering the username and pass word again

Tried both the Debian and Fedora images and get the same results, also tried 2 different keyboards ( one was brought today just to check the Pi with ) and same results. Have to say after spending 5 hours messing around so far i am about ready to throw the board unless anyone has any ideas.

User avatar
nick.mccloud
Posts: 804
Joined: Sat Feb 04, 2012 4:18 pm

Re: Strange Problems

Fri Jun 01, 2012 10:05 pm

It may be a power issue getting the keyboard to run properly - have you another power supply you can try?

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12672
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Strange Problems

Fri Jun 01, 2012 10:13 pm

The keyboard and mouse MUST be simple devices that use less than 100mA, or they only will work in combination with a powered hub! Also, if your PSU isn't up to the task of supplying exactly 5.0 Volt at 700mA, then the keyboard is about the first thing that will f**k up!

tazd
Posts: 2
Joined: Fri Jun 01, 2012 5:13 pm

Re: Strange Problems

Sat Jun 02, 2012 12:20 pm

well turns out it's the keyboard drawing to much power, tried my MS Wireless 700 keyboard and all works fine so now i am happily playing with the Pi :)

User avatar
grumpyoldgit
Posts: 1452
Joined: Thu Jan 05, 2012 12:20 pm

Re: Strange Problems

Sat Jun 02, 2012 12:27 pm

tazd wrote:well turns out it's the keyboard drawing to much power, tried my MS Wireless 700 keyboard and all works fine so now i am happily playing with the Pi :)
I am reading about so many problems that are down to the keyboard pulling too much power. The keyboard, the SD card and the power supply seem to be the major contenders for issues.

daviewales
Posts: 19
Joined: Wed Apr 25, 2012 12:22 am

Re: Strange Problems

Tue Jun 05, 2012 4:22 am

I had a similar problem. I think it's fixed now... I tried different power supplies and keyboards, and installed the latest kernel using hexxeh's tool, and now it works... I'm not sure which particular step fixed the problem though... =O

Return to “Beginners”