Page 1 of 1

I can NOT get HDMI output working!

Posted: Fri Feb 28, 2014 5:53 am
by yaconsult
My pi is one of the early models with 256 MB of memory. It is running the latest Wheezy with all raspbian updates and the latest firmware as provided by rpi-update.

I have tried changing all the video related settings in config.txt as well as deleting config.txt. Clearly, the display is being seen by the pi, but I never get anything displayed on the display. I can unplug the cable from the pi and immediately plug it into my old model roku (a very similar device!) and it displays the expected output.

As far as the display is concerned, there is no input signal from the pi like there is from the roku. I have been using the same cable on the same port on the tv to reduce the number of variables. I have also tried config_hdmi_boost=4 with no effect.

I'm starting to wonder if my hdmi port could be defective? I suppose the next step will be to take it to another display somewhere and try it there. So frustrating!

[email protected]:~# tvservice -s
state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60Hz, progressive

[email protected]:~# tvservice -n
device_name=SPT-X325BV-FMDR

[email protected]:/boot# tvservice -modes CEA
Group CEA has 16 modes:
mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
mode 6: 720x480 @ 60Hz 4:3, clock:27MHz x2 interlaced
mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced
(prefer) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive
mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive
mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive
mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive
mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced
mode 21: 720x576 @ 50Hz 4:3, clock:27MHz x2 interlaced
mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced
mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive
mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive

[email protected]:/boot# tvservice --explicit="CEA 16 HDMI"
Powering on HDMI with explicit settings (CEA mode 16)

[email protected]:/boot# tvservice -p
Powering on HDMI with preferred settings

Any clues or tips will be gratefully accepted and tried!

Re: I can NOT get HDMI output working!

Posted: Fri Feb 28, 2014 8:32 am
by DeeJay
As a diagnostic tool - not because you want to actively use it as your installer - have you considered downloading the Network-only 'lite' version of NOOBS? This is only a 20MB download, and only needs a small SD card (for this purpose).

When NOOBS does its initial boot it gives you a one-key option for selecting display mode.
Display Mode Selection: By default, NOOBS will output over HDMI at your display's preferred resolution, even if no HDMI display is connected. If you do not see any output on your HDMI display or are using the composite output, press 1, 2, 3 or 4 on your keyboard to select HDMI preferred mode, HDMI safe mode, composite PAL mode or composite NTSC mode respectively.
That might allow you to test the HDMI port on your RPi and its connection to your monitor.

Re: I can NOT get HDMI output working!

Posted: Fri Feb 28, 2014 10:22 am
by Angelus88
Try to comment everything about HDMI by adding the # at the beginning of each line and leave just

Code: Select all

hdmi_safe=1
(I'm talking about config.txt file obviously)

Re: I can NOT get HDMI output working!

Posted: Fri Feb 28, 2014 11:11 am
by MaxK1
Is your Pi in a case? If so, it may be causing the cable not to fully mate. (either ever so slightly crooked or not fully seated. Also, try pulling the plug back out just a hair (And I do mean just a hair!). The other odd one I have encountered: Switch ends! (turn the cable around)

Re: I can NOT get HDMI output working!

Posted: Fri Feb 28, 2014 8:18 pm
by yaconsult
Thank you for the suggestions!

I have tried booting from the noobs install image on my second sdcard and get the same results - no hdmi display even when trying the number keys 1 through 4 multiple times. The advantage of troubleshooting using the weezy sdcard instead of noobs, of course, is that I can log in and troubleshoot. But it was worth a try - I agree!

I have tried commenting out all hdmi-related lnes in config.txt except for:
hdmi_safe=1
and rebooted with the same result.

The pi is in a bud case - currently with the top off. It is not interfering with the hdmi cable. I have tried re-seating the cable and pulling it out a tiny bit, etc. No change. And I've tried booting both with the tv connected and disconnected.

I have tried swapping ends of the hdmi cable, but it made no difference. I have also tried two different hdmi ports on the tv - no difference.

I have the pi and a roku right next to each other on my desk. Plugged into the roku, I get a great picture. I unplug the cable from the roku and plug it into the pi - no signal.

HDMI definitely no longer works

Posted: Mon Mar 03, 2014 7:14 am
by yaconsult
OK, I have verified that it is the hdmi output on the pi that has stopped working. I confirmed this by digging out the hdmi to dvi cable and hooking it up to the display I have successfully used before on the pi. I tried both a noobs install sdcard and my current up-to-date raspbian sdcard.

There is just no signal coming out of the hdmi port. I will give it a close examination under a magnifying glass. I have plenty of soldering experience, so I'll touch up any connections that aren't too small if they look marginal.

I wonder if I managed to do something to kill it or if it just died? Have there been many reports of hdmi output failure? It's one of the earliest 256 mb boards.

Everything else I've tried on it seems to work fine. I guess I'll have to plan on picking up another one if I want to have hdmi output. I should try the rca video out to see if that's still working, I suppose.

Re: I can NOT get HDMI output working!

Posted: Mon Mar 03, 2014 9:19 am
by MaxK1
Have a look at/near D1/D2 - something may have let the smoke out. I seem to recall there were a few reports with them after
use with un-powered HDMI-VGA adapters and/or HDMI switches.

It was also "fixable" with a replacement diode.

Re: I can NOT get HDMI output working!

Posted: Fri Mar 07, 2014 9:45 pm
by yaconsult
I borrowed a friend's pi - same model, memory, etc. When I switch the pi using the same cables, power supply, and memory card - the hdmi works on my friend's pi but not on mine. So there is clearly a hardware problem on my pi.

I got out my magnifying glass and started examining the components, especially those around the hdmi connector, but nothing has jumped out at me yet.