Wissota
Posts: 1
Joined: Fri Feb 14, 2014 4:22 am

how to set keyboard repeat delay

Fri Feb 14, 2014 4:41 am

I would like to set a longer delay before the keyboard repeats a key.
I tried running kbdrate but get error "cannot open /dev/port".
What am I missing?

Longer story:
My just turned four years old son loves his raspberry pi. I set up command files to let him play his favorite sounds: cow, dog, horn, bell, telephone, etc. He is good at spelling and a careful typist, but too often a key repeats too quickly.

User avatar
jojopi
Posts: 3041
Joined: Tue Oct 11, 2011 8:38 pm

Re: how to set keyboard repeat delay

Fri Feb 14, 2014 8:58 am

"kbdrate -d 750 -r 10" sets the software repeat rate for the system console (text mode). If run outside the console it tries to fall back to setting the hardware repeat rate, but this is an obsolete concept. USB keyboards do not have hardware repeat.

The equivalent command to set the rate in Xorg GUI is "xset r rate 750 10".

To make the console repeat permanent, edit /etc/kbd/config. To make the GUI repeat permanent, add the xset command to /etc/xdg/lxsession/LXDE/autostart.

(You should be able to set the GUI rate with Preferences→Keyboard and Mouse, but this does not seem to work for me. The settings in /etc/xdg/lxsession/LXDE/desktop.conf also appear to be ignored.)

gnuarm
Posts: 5
Joined: Thu Feb 16, 2012 6:22 pm

Re: how to set keyboard repeat delay

Mon May 11, 2015 12:30 am

I tried the kbdrate command and it fails saying the port doesn't exist, /dev/port. I looked at the config file and the two lines setting the delay and rate are commented out.

I tried changing this in the preferences dialog and the settings don't have an effect and are not retained. Every time I open the dialog box the settings are back to 500 delay and 30 repeat.

What am I missing?

Return to “Beginners”