allcardr
Posts: 26
Joined: Sun Feb 26, 2012 8:09 pm

Re: Automatic setup for RTL8188CUS based wifi adapters

Sun Jul 15, 2012 1:37 pm

By the way, I have also tried using a direct shell to install this as well by plugging directly into a monitor, and still get the same.

MrEngman
Posts: 3854
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Sun Jul 15, 2012 6:03 pm

jbracegirdle wrote:Thanks for your very quick reply, and your help by creating the script in the first place. I had always started the process with Ethernet connected and the WiFi adapter out. I ran the script and tried to connect to my router with WPA2 and again (from a new SD image) with an Android phone as an open hotspot.
I've tried it again with a new image on the SD card (debian6-19-04-2012) and only the script on /boot. The WiFi blue light on the Edimax EW-7811Un did come on in perevious installs, but it won't now and it won't connect to the WiFi network. I used ifup to re-create the errors I get when the RPi boots, and the same errors happen before and after I changed/added wpa_supplicant.
I set my router to open security and tried again, it is broadcasting the SSID and has DHCP working. The RPi connects to it ok over Ethernet. My router is a Linksys/Cisco WAG120N.
On my latest run of the script it seems to miss out lines 509 and 525 and ends:

Thanks for all your help so far.
I've just run the script on a new debian6-19-04-2012 image with Edimax EW7811Un and it installed OK. After rebooting the wifi driver started up without problems.

Did you enable hot-plug? Did you let it install the new dhcp code?

What do you see for the result of the command

Code: Select all

lsmod
It should show a line with 8192cu showing the wifi driver module is loaded. Do you see any output for the command

Code: Select all

ifconfig wlan0
When the driver is loaded you should get some output and when connected you should see a line with "inet addr:.....". Check the files /etc/network/interfaces, /etc/modules and /etc/modprobe.d/blacklist.conf to make sure there are no duplicate lines. If there are delete them. There shouldn't be but if you've run the script more than once there may be.

Does your network ssid or password use any non-alphanumeric characters? If so this could be the problem stopping the wifi working. Linux treats several characters as special indicators in scripts.

I tried all 32 characters refered to as special characters and could not get a connection with 19 of them. All work in Windows! The characters I had problems with were "! " # $ ( ) . / : < > ? [ \ ] _ { | }". I couldn't get a connection if any of these were used in the password and I would expect the same if used in the ssid.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

jbracegirdle
Posts: 10
Joined: Sat Jul 14, 2012 7:45 pm

Re: Automatic setup for RTL8188CUS based wifi adapters

Sun Jul 15, 2012 7:22 pm

I did enable hot-plug and DHCP upgrade. The results of the commands are shown below:

Code: Select all

[email protected]:~$ lsmod
Module                  Size  Used by
fuse                   73593  1
ipv6                  290227  20
8192cu                512098  0
evdev                   8922  1
i2c_bcm2708             3818  0
spi_bcm2708             4815  0

[email protected]:~$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 80:1f:02:60:f9:ef
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
I checked /etc/network/interfaces, /etc/modules and /etc/modprobe.d/blacklist.conf and there are no duplicates as I use a fresh image each time. My SSID was The-Cisco and I changed it to cisco my password has no special characters and it still won't work :(
I tried the adapter on my Windows laptop as I was worried that it may be faulty but it works fine. The blue light is on but it still won't log onto the network. The router is now set to WPA2-mixed mode.
Thanks again for your help so far.

Clifford
Posts: 30
Joined: Fri May 04, 2012 3:19 pm

Re: Automatic setup for RTL8188CUS based wifi adapters

Sun Jul 15, 2012 8:00 pm

In response to Paul_L:
MrEngman wrote:apt-get update should not cause a problem as far as I know. Do you mean you updated using rpi-update?
I did:

Code: Select all

sudo apt-get update
sudo apt-get dist-upgrade
today, and the wireless stopped working exactly as Paul_L described. I have not used rpi-update at all on Wheezy Beta. I have previously performed a dist-upgrade without a problem. Something new in the repository perhaps?

Unfortunately Paul has not responded to MrEngman's counter-questions, so we don't know if he found a solution. I have reverted to my previously backed-up image.

MrEngman
Posts: 3854
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Sun Jul 15, 2012 8:07 pm

allcardr wrote:Just retried the script on a fresh install of Debian, using http://dl.dropbox.com/u/80256631/instal ... -latest.sh

and am getting exactly the same.
I'm now going to try Hexxeh's image to see if that sorts it out.


Update,

now getting
- Invalid response, enter U, E or A
/boot/install-rtl8188cus-latest.sh: 145: read: Illegal option -n


Here's how I'm trying to install.
1) set up 8Gb sd card with the latest raspian Hexxeh image (RC3)
2) logged in via ssh
3) performed an rpi-update
4) Downloaded the Latest script , as directed, from http://dl.dropbox.com/u/80256631/instal ... -latest.sh
5) ran script as root.

I then get the aforementioned error.
I've just tried running the script on raspbian hexxeh using SSH and don't see the error.

I cannot say for sure as my knowledge is very limited but I think the script is not running under the bash shell. In bash shell there is a special read command used to get input and this will not give the error you are seeing. There is also a standard linux read command that is used to read file data and I think the shell is interpreting the read as this command and is why you get the error.

Can you run the script using the command

Code: Select all

sudo bash /boot/install-rtl8188cus-latest.sh
I think this should make it run under bash.

Can you run the command

Code: Select all

set
This shows the environment variable and what does "SHELL=..." show. On my Pi it is "SHELL=/bin/bash. If it is different somehow maybe your default shell has been changed.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Paul_L
Posts: 46
Joined: Tue May 29, 2012 2:13 pm
Location: Campina Romania

Re: Automatic setup for RTL8188CUS based wifi adapters

Sun Jul 15, 2012 9:28 pm

MrEngman wrote:
Paul_L wrote:Today I made a apt-get upgrade on my Wheezy on which my Edimax Nano wireless was installed and working ( the upgrade was done on wireless connection ). There are some kernel upgrades and even the kernel has the same version 3.1.9+ I have another modules structure under /lib/modules . I copied my 8192cu.ko module on the correct place, run depmod -a and now the module is complaining on many lines on the version of symbols. Tried even with the module issued on 02.07 and the same . It has to be compiled a new module ?
Sounds like you need an updated driver.

To find the kernel version use the command

Code: Select all

uname -v
What does that report?
My kernel version compile version is #162

Code: Select all

[email protected]:~# uname -v
#162 PREEMPT Thu Jul 12 12:01:22 BST 2012
but under /lib/modules I have a different folder

Code: Select all

[email protected]:~# cd /lib/modules
[email protected]:/lib/modules# ls -al
total 16
drwxr-xr-x  4 root root 4096 Jul 14 05:34 .
drwxr-xr-x 14 root root 4096 Jul 14 05:31 ..
drwxr-xr-x  3 root root 4096 Jul 14 06:21 3.1.9+
drwxr-xr-x  3 root root 4096 Jul 14 05:35 3.1.9-cutdown+
and the module 8192cu is complaining :

Code: Select all

[   18.309375] 8192cu: disagrees about version of symbol skb_clone
[   18.319420] 8192cu: Unknown symbol skb_clone (err -22)
[   18.328686] 8192cu: disagrees about version of symbol dev_get_by_name
[   18.339306] 8192cu: Unknown symbol dev_get_by_name (err -22)
[   18.349074] 8192cu: disagrees about version of symbol netif_carrier_on
[   18.359774] 8192cu: Unknown symbol netif_carrier_on (err -22)
[   18.369695] 8192cu: disagrees about version of symbol register_netdevice
[   18.380591] 8192cu: Unknown symbol register_netdevice (err -22)
[   24.182306] NET: Registered protocol family 10

broo0ose
Posts: 317
Joined: Wed Dec 14, 2011 3:59 pm
Location: Wirral, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Sun Jul 15, 2012 9:45 pm

After trying for ages to get one of these adaptors to work with RaspBMC using the method suggested in the RaspBMC forum. I ran this script not expecting it to work.

It failed to copy the driver to the specified directory, but after the reboot I just copied the driver from the RaspBMC forum manually.

Code: Select all

sudo mv 8192cu.ko /lib/modules/3.1.9-test-12-06/kernel/drivers/net/wireless/
and it works !!!!!!!

T H A N K Y O U !!!!

MrEngman
Posts: 3854
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Sun Jul 15, 2012 10:21 pm

jbracegirdle wrote:I did enable hot-plug and DHCP upgrade. The results of the commands are shown below:

Code: Select all

[email protected]:~$ lsmod
Module                  Size  Used by
fuse                   73593  1
ipv6                  290227  20
8192cu                512098  0
evdev                   8922  1
i2c_bcm2708             3818  0
spi_bcm2708             4815  0

[email protected]:~$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 80:1f:02:60:f9:ef
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
I checked /etc/network/interfaces, /etc/modules and /etc/modprobe.d/blacklist.conf and there are no duplicates as I use a fresh image each time. My SSID was The-Cisco and I changed it to cisco my password has no special characters and it still won't work :(
I tried the adapter on my Windows laptop as I was worried that it may be faulty but it works fine. The blue light is on but it still won't log onto the network. The router is now set to WPA2-mixed mode.
Thanks again for your help so far.
As the module is loaded and ifconfig shows wlan0 data the driver looks to be OK. I'm wondering if there's some issue with dhcp or is it some issue with the security mode or password encryption type.

One access point I use is set for wpa2-psk and uses AES encription and the other is set for WPA2 and doesn't specify any particular encription mode other than WPA2. My dhcp server is a windows 2003 server setup as a domain controller for my own local network.

It might be worth trying a fixed IP for your Pi. You will need to edit the /etc/network/interfaces file. The following shows a typical setup. You would need to set it to suit your own wifi network settings.

Code: Select all

iface eth0 inet static  <--change dhcp to static
address 192.168.1.201
network 192.168.1.0
netmask 255.255.255.0
gateway 192.168.1.1
Not sure what to suggest next if this doesn't work.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

MrEngman
Posts: 3854
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Sun Jul 15, 2012 10:40 pm

Paul_L wrote:
MrEngman wrote:
Paul_L wrote:Today I made a apt-get upgrade on my Wheezy on which my Edimax Nano wireless was installed and working ( the upgrade was done on wireless connection ). There are some kernel upgrades and even the kernel has the same version 3.1.9+ I have another modules structure under /lib/modules . I copied my 8192cu.ko module on the correct place, run depmod -a and now the module is complaining on many lines on the version of symbols. Tried even with the module issued on 02.07 and the same . It has to be compiled a new module ?
Sounds like you need an updated driver.

To find the kernel version use the command

Code: Select all

uname -v
What does that report?
My kernel version compile version is #162

Code: Select all

[email protected]:~# uname -v
#162 PREEMPT Thu Jul 12 12:01:22 BST 2012
but under /lib/modules I have a different folder

Code: Select all

[email protected]:~# cd /lib/modules
[email protected]:/lib/modules# ls -al
total 16
drwxr-xr-x  4 root root 4096 Jul 14 05:34 .
drwxr-xr-x 14 root root 4096 Jul 14 05:31 ..
drwxr-xr-x  3 root root 4096 Jul 14 06:21 3.1.9+
drwxr-xr-x  3 root root 4096 Jul 14 05:35 3.1.9-cutdown+
and the module 8192cu is complaining :

Code: Select all

[   18.309375] 8192cu: disagrees about version of symbol skb_clone
[   18.319420] 8192cu: Unknown symbol skb_clone (err -22)
[   18.328686] 8192cu: disagrees about version of symbol dev_get_by_name
[   18.339306] 8192cu: Unknown symbol dev_get_by_name (err -22)
[   18.349074] 8192cu: disagrees about version of symbol netif_carrier_on
[   18.359774] 8192cu: Unknown symbol netif_carrier_on (err -22)
[   18.369695] 8192cu: disagrees about version of symbol register_netdevice
[   18.380591] 8192cu: Unknown symbol register_netdevice (err -22)
[   24.182306] NET: Registered protocol family 10
OK the driver appears to be out of date. Grab hold of the latest driver and manually install it. As there are two directories you could install it in both and it will use the one in the directory that is used. Or install it in one and see if it works. If it doesn't install it in the other directory.

Code: Select all

sudo wget http://dl.dropbox.com/u/80256631/8192cu-latest.tar.gz
tar -zxf 8192cu-latest.tar.gz
install -p -m 644 /lib/modules/3.1.9+/kernel/drivers/net/wireless/
install -p -m 644 /lib/modules/3.1.9-cutdown+/kernel/drivers/net/wireless/
sudo depmod -a
sudo /etc/init.d/networking restart
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Paul_L
Posts: 46
Joined: Tue May 29, 2012 2:13 pm
Location: Campina Romania

Re: Automatic setup for RTL8188CUS based wifi adapters

Mon Jul 16, 2012 9:42 am

MrEngman wrote: OK the driver appears to be out of date. Grab hold of the latest driver and manually install it. As there are two directories you could install it in both and it will use the one in the directory that is used. Or install it in one and see if it works. If it doesn't install it in the other directory.

Code: Select all

sudo wget http://dl.dropbox.com/u/80256631/8192cu-latest.tar.gz
tar -zxf 8192cu-latest.tar.gz
install -p -m 644 /lib/modules/3.1.9+/kernel/drivers/net/wireless/
install -p -m 644 /lib/modules/3.1.9-cutdown+/kernel/drivers/net/wireless/
sudo depmod -a
sudo /etc/init.d/networking restart
I am already using the last one from 2 of july as you can see:

Code: Select all

 [email protected]:/lib/modules/3.1.9-cutdown+/kernel/net/wireless# ls -al
total 864
drwxr-xr-x  2 root root   4096 Jul 14 06:21 .
drwxr-xr-x 13 root root   4096 Jul 14 05:34 ..
-rw-r--r--  1 root root 616304 Jul  2 01:09 8192cu.ko
-rw-r--r--  1 root root 206273 Jul 13 09:49 cfg80211.ko
-rw-r--r--  1 root root   8884 Jul 13 09:49 lib80211_crypt_ccmp.ko
-rw-r--r--  1 root root  12977 Jul 13 09:49 lib80211_crypt_tkip.ko
-rw-r--r--  1 root root   6745 Jul 13 09:49 lib80211_crypt_wep.ko
-rw-r--r--  1 root root  10638 Jul 13 09:49 lib80211.ko
I don't find another ,

Later edit :

Looks like I changed also in the /lib/modules/3.1.9+/kernel/net/wireless folder it is working

allcardr
Posts: 26
Joined: Sun Feb 26, 2012 8:09 pm

Re: Automatic setup for RTL8188CUS based wifi adapters

Mon Jul 16, 2012 10:45 am

Mr Engman,

OK I've got a little further along now, once I re established my eth connection which, for some reason, didn't restart back up, but that's ok now.
I've tried updating the driver to the new one, with no joy.
Blue light not coming on adapter & network essentially not available on wlan.
Adapter works fine on my Windows box, blue light & everything, but not on my Raspian one.

iwconfig shows
[email protected]:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.


Adiitionally, when I run lsusb I can see the adapter being reported back as
Bus 001 Device 007: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

The driver I have installed is 8192cu.ko

would this make the difference?

MrEngman
Posts: 3854
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Mon Jul 16, 2012 3:35 pm

allcardr wrote:Mr Engman,

OK I've got a little further along now, once I re established my eth connection which, for some reason, didn't restart back up, but that's ok now.
I've tried updating the driver to the new one, with no joy.
Blue light not coming on adapter & network essentially not available on wlan.
Adapter works fine on my Windows box, blue light & everything, but not on my Raspian one.

iwconfig shows
[email protected]:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.


Adiitionally, when I run lsusb I can see the adapter being reported back as
Bus 001 Device 007: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

The driver I have installed is 8192cu.ko

would this make the difference?
8192cu.ko is the correct driver name. All versions have the same name. What version is Linux? Use command

Code: Select all

uname -v
to show the version.

Check files /etc/network/interface, it should have one set of entries like:

Code: Select all

allow-hotplug wlan0

auto wlan0

iface wlan0 inet dhcp
wpa-ssid "NEWORK NAME"
wpa-psk "NETWORK PASSWORD"
It should only have one entry of each line. If there are more delete the extra ones.

Check file /etc/modules. This should have one line showing

Code: Select all

8192cu
If thee are more than one delete the extra lines.

I would be good to check for any errors regarding wlan0 when the Pi boots up.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Clifford
Posts: 30
Joined: Fri May 04, 2012 3:19 pm

Re: Automatic setup for RTL8188CUS based wifi adapters

Mon Jul 16, 2012 6:17 pm

Paul_L wrote: Later edit :

Looks like I changed also in the /lib/modules/3.1.9+/kernel/net/wireless folder it is working
I don't quite follow; are you saying that when you installed the driver in the alternate folder it worked? I'd like to know before I try dist-upgrade again, otherwise I'll leave the dust to settle.

Paul_L
Posts: 46
Joined: Tue May 29, 2012 2:13 pm
Location: Campina Romania

Re: Automatic setup for RTL8188CUS based wifi adapters

Mon Jul 16, 2012 6:44 pm

After upgrade i found a new folder in /lib/modules . In the old one I had an older version of 8192cu.ko . I put the updated in the new folder , run demoed -a and got errors version errors. After replacing the old driver with the new one in the old folder it started tu run. Hope that I have explained what happens.

jbracegirdle
Posts: 10
Joined: Sat Jul 14, 2012 7:45 pm

Re: Automatic setup for RTL8188CUS based wifi adapters

Mon Jul 16, 2012 9:40 pm

I found that my problem was the power supplies I was using!

I tried a USB port on my TV, I tried using a D-Link USB powered hub (DUB-H4), I tried a Powergen Mobile Juice Pack. I tried the WiFi adapter via the USB hub and direct.
The solution was to use an Argos phone charger (http://www.argos.co.uk/static/Product/p ... 468317.htm).
I would have used my multimeter, but I left it at my parents when I went to uni 12 years ago and I've not picked it up since - I'll pick it up next week for future RPi adventures :) .
The other power supplied were ok for the Raspberry Pi on Ethernet but not enough for WiFi.

Thanks again for your help, I hope this post helps others.

MrEngman
Posts: 3854
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Mon Jul 16, 2012 11:06 pm

jbracegirdle wrote:I found that my problem was the power supplies I was using!

I tried a USB port on my TV, I tried using a D-Link USB powered hub (DUB-H4), I tried a Powergen Mobile Juice Pack. I tried the WiFi adapter via the USB hub and direct.
The solution was to use an Argos phone charger (http://www.argos.co.uk/static/Product/p ... 468317.htm).
I would have used my multimeter, but I left it at my parents when I went to uni 12 years ago and I've not picked it up since - I'll pick it up next week for future RPi adventures :) .
The other power supplied were ok for the Raspberry Pi on Ethernet but not enough for WiFi.

Thanks again for your help, I hope this post helps others.
Thanks for the update. Something useful for everyone to take a note of.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

japester36
Posts: 14
Joined: Sun Jun 03, 2012 8:47 am

Re: Automatic setup for RTL8188CUS based wifi adapters

Tue Jul 17, 2012 1:03 pm

More out of curiosity than anything else, I've just used the install-rtl8188cus-latest.sh script on the latest "Raspberry Pi Foundation Raspbian" image now being distributed on the Raspbian forum and it worked first time with no errors.

Code: Select all

Linux raspberrypi 3.1.9+ #168 PREEMPT Sat Jul 14 18:56:31 BST 2012 armv6l
Thanks MrEngman

MrEngman
Posts: 3854
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Tue Jul 17, 2012 3:08 pm

japester36 wrote:More out of curiosity than anything else, I've just used the install-rtl8188cus-latest.sh script on the latest "Raspberry Pi Foundation Raspbian" image now being distributed on the Raspbian forum and it worked first time with no errors.

Code: Select all

Linux raspberrypi 3.1.9+ #168 PREEMPT Sat Jul 14 18:56:31 BST 2012 armv6l
Thanks MrEngman
Thanks for the update. It's good to hear from people who have had some success with the script, thanks.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

pjc123
Posts: 913
Joined: Thu Mar 29, 2012 3:37 pm
Contact: Website

Re: Automatic setup for RTL8188CUS based wifi adapters

Tue Jul 17, 2012 6:23 pm

greatdane wrote:Connectify will allow you to SSH into the Raspi from Win7
I tried Connectify today and it works great....Thanks. I can now vnc into my pi using wifi without a router. The only very minor thing is that I would have preferred to disable the internet connection (not the network connection), but that checkbox is greyed out and only available on the pro version. First I tried MaryFi because it does not have any features disabled, but the gui was all messed up on my screen and my Windows 7 wifi dongle is not supported, so it did not work. Next I am going to see what kind of wifi distance I can get with my RTL8188CUS dongle. On the Windows side I have a more powerful TP-Link TL-WN722N.
My Raspberry Pi Project Page:
https://www.flaminghellmet.com/launch/

allcardr
Posts: 26
Joined: Sun Feb 26, 2012 8:09 pm

Re: Automatic setup for RTL8188CUS based wifi adapters

Tue Jul 17, 2012 6:43 pm

Hi Mr Engman!
many thaks for the help so far, You seem to be the guy that Everyone is asking ! I don't envy you!

A bit further along now, Rebuilt my wheezy install, did an install of the wheezy script, ( I think It may be the alpha so therein maybe lies the issue?)
Now, once I updated the driver, did a reboot then enabled ethernet again, I had a moment of joy, albeit shortlived !

The blue light came on briefly!
..then went out.
OK, not perturbed by this I rechecked the interfaces file, made the amendments to WEP ( my router is set up for a few devices so I decided to leave the router as Wep)
also, I set up a static address for wifi in the interfaces file, as shown below.:-

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

allow-hotplug wlano

auto wlan0

#iface wlan0 inet dhcp
iface wlan0 inet static
address 192.168.0.6
network 192.168.0.0

now I cannot connect to the pui via ssh unless I remove the wifi dongle ( which I expect is due to the static IP being allocated to it) and I still have no connectivity via wifi if the eth is removed, as confirmed by my router connected devices listings.

MrEngman
Posts: 3854
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Wed Jul 18, 2012 12:49 am

allcardr wrote:Hi Mr Engman!
many thaks for the help so far, You seem to be the guy that Everyone is asking ! I don't envy you!

A bit further along now, Rebuilt my wheezy install, did an install of the wheezy script, ( I think It may be the alpha so therein maybe lies the issue?)
Now, once I updated the driver, did a reboot then enabled ethernet again, I had a moment of joy, albeit shortlived !

The blue light came on briefly!
..then went out.
OK, not perturbed by this I rechecked the interfaces file, made the amendments to WEP ( my router is set up for a few devices so I decided to leave the router as Wep)
also, I set up a static address for wifi in the interfaces file, as shown below.:-

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

allow-hotplug wlano

auto wlan0

#iface wlan0 inet dhcp
iface wlan0 inet static
address 192.168.0.6
network 192.168.0.0

now I cannot connect to the pui via ssh unless I remove the wifi dongle ( which I expect is due to the static IP being allocated to it) and I still have no connectivity via wifi if the eth is removed, as confirmed by my router connected devices listings.
Just to see what happens I tried setting my Pi to use a static address. Using just the two lines you show, address & network, I got an error. "Don't seem to have all the variables for wlan0/inet". I had to add an additional line to get the static setup to work

Code: Select all

netmask 255.255.255.0
There is an additional line that may also be needed and that is

Code: Select all

gateway 192.168.0.xxx
essentially the address of your router although mine appears to work without it.

If you set up a static address for the Pi I'm not sure that the router will show it even if it works. I think it will only show devices that are connected using the router's dhcp server.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

allcardr
Posts: 26
Joined: Sun Feb 26, 2012 8:09 pm

Re: Automatic setup for RTL8188CUS based wifi adapters

Wed Jul 18, 2012 5:55 am

Hi Mr Engman,

My bad, I missed out the bottom half of my copy/paste of teh interfaces file,

Yes, I did include the netwmask & Gateway portions as needed, but as explained, it seems that the dongle attempts a connection when on DHCP.
My router does show static entries , as I have this set up for my Windows boxes and these are shown as connected devices.
Am I right in thinking that for wep I would need the following:-
wireless-essid my ssid
wireless-key my wepkey

MrEngman
Posts: 3854
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Automatic setup for RTL8188CUS based wifi adapters

Wed Jul 18, 2012 10:40 am

allcardr wrote:Hi Mr Engman,

My bad, I missed out the bottom half of my copy/paste of teh interfaces file,

Yes, I did include the netwmask & Gateway portions as needed, but as explained, it seems that the dongle attempts a connection when on DHCP.
My router does show static entries , as I have this set up for my Windows boxes and these are shown as connected devices.
Am I right in thinking that for wep I would need the following:-
wireless-essid my ssid
wireless-key my wepkey
Yes, they're correct for WEP. Looking back through your posts I've just noticed you mentioned alpha. Are you using wheezy alpha? If you are have you installed wireless-tools and wpasupplicant?

Code: Select all

sudo apt-get install wireless-tools wpasupplicant
If you see the LED on the wifi adapter flash then I think the driver is OK but it will not connect without wpasupplicant installed.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Paul_L
Posts: 46
Joined: Tue May 29, 2012 2:13 pm
Location: Campina Romania

Re: Automatic setup for RTL8188CUS based wifi adapters

Wed Jul 18, 2012 6:53 pm

Is there a script to install wireless dongle on new raspbian sd image. The one for wheezy is working ?

Nburnes
Posts: 23
Joined: Fri May 25, 2012 7:00 am

Re: Automatic setup for RTL8188CUS based wifi adapters

Wed Jul 18, 2012 8:55 pm

Paul_L wrote:Is there a script to install wireless dongle on new raspbian sd image. The one for wheezy is working ?
Newest one worked fine for me.

Return to “Beginners”