chris232213
Posts: 1
Joined: Fri Oct 04, 2013 5:24 am

SD Corrupt

Mon Oct 07, 2013 11:51 pm

Hi All,

Experiencing a lot of issues with my raspberry pi & the sd card getting corrupt multiple times. The longest the PI was running for was about 3 or 4 weeks. Running the Raspbian OS, tried a sandisk & kingston brand SD cards with 4GB which are a Class 4

I have attached screenshots of the error I receive.

Thanks.
Attachments
3__1381189748_203.23.60.6.jpg
3__1381189748_203.23.60.6.jpg (23.54 KiB) Viewed 1143 times
2__1381189733_203.23.60.6.jpg
2__1381189733_203.23.60.6.jpg (15.11 KiB) Viewed 1142 times
1__1381189687_203.23.60.6.jpg
1__1381189687_203.23.60.6.jpg (13.86 KiB) Viewed 1142 times

lenkf
Posts: 19
Joined: Wed Jul 10, 2013 10:02 pm
Location: S.California

Re: SD Corrupt

Tue Oct 08, 2013 2:18 am

very difficult to actually read your screenshots. the print is too small.

I have also had some problems with sd corruption. I keep generations of copies of images, just in case a bug sneaks in and I have to start again from a known good point. The problem happens most often on a headless rpi when it looses its wireless connection to the local network for some reason. The only way to get it back is to remove and reconnect power, and that means taking a chance on corruption.

Be careful to always do "shutdown -h now" before removing power (that is when possible :)

Fred

Oakham
Posts: 366
Joined: Tue Aug 20, 2013 9:11 pm

Re: SD Corrupt

Tue Oct 08, 2013 5:42 am

One of several previous postings relating to "sd card issues"

http://www.raspberrypi.org/phpBB3/viewt ... rd+corrupt
Searching is easy, most questions have been asked before !

User avatar
DougieLawson
Posts: 36302
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: SD Corrupt

Tue Oct 08, 2013 7:57 am

Oakham wrote:One of several previous postings relating to "sd card issues"

http://www.raspberrypi.org/phpBB3/viewt ... rd+corrupt
I don't think that helps since that thread has been dormant since September and doesn't have any firm conclusions.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
RaTTuS
Posts: 10481
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: SD Corrupt

Tue Oct 08, 2013 8:21 am

I suspect your power supply
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
simonmcc
Posts: 181
Joined: Mon Aug 19, 2013 10:07 pm

Re: SD Corrupt

Tue Oct 08, 2013 10:56 am

It is difficult to read your screenshots, but I had a similar issue when drawing too much power from the USB port, every time it would corrupt the SD card. Re-imaging is the only thing that fixed mine.

I'd advise using a powered USB hub, and also checking your pi is getting the correct voltage from the power supply (you'll need a meter to do that).

Also, as has been suggested, take regular images when developing, so you can get back to where you were.
simonmcc.blogspot.com/search/label/pi

User avatar
Davespice
Forum Moderator
Forum Moderator
Posts: 1662
Joined: Fri Oct 14, 2011 8:06 pm
Location: The Netherlands
Contact: Twitter

Re: SD Corrupt

Tue Oct 08, 2013 1:28 pm

May I also draw your attention to this thread, it was a bit of a wow moment for me.
http://www.raspberrypi.org/phpBB3/viewt ... 28&t=57675

Return to “Beginners”