klricks
Posts: 7121
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Tue Feb 26, 2019 6:16 pm

jamesh wrote:
Tue Feb 26, 2019 3:26 pm
There is some official documentation here.

https://www.raspberrypi.org/documentati ... ensaver.md

If anyone finds that doesn't work, please indicate the problem by posting in this thread.
xscreensaver works but it is a 40MB install and adds a background process.

Simpler to do these commands (For GUI Desktop only):

Code: Select all

xset s off
xset -dpms
To make permanent add those 2 commands to autostart

Code: Select all

/etc/xdg/lxsession/LXDE-pi/autostart
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

jwilson115
Posts: 1
Joined: Fri Mar 15, 2019 6:13 am
Location: Chicago
Contact: Website

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Fri Mar 15, 2019 6:21 am

On the Console
If you are using the Raspberry Pi solely on the console (no desktop GUI), you need to set the console blanking. The current setting, in seconds, can be displayed using

cat /sys/module/kernel/parameters/consoleblank
Here, consoleblank is a kernel parameter. In order to be permanently set, it needs to be defined on the kernel command line.

sudo nano /boot/cmdline.txt
Add consoleblank=0 to turn screen blanking off completely, or edit it to set the number of seconds of inactivity before the console will blank. Note the kernel command line must be a single line of text.

regroers
Posts: 5
Joined: Sat Mar 16, 2019 7:47 am
Location: Illinois, USA

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Sat Mar 16, 2019 7:55 am

Thank you. This is very useful.
It is more fun to drive a slow car fast than to drive a fast car slow.

regroers
Posts: 5
Joined: Sat Mar 16, 2019 7:47 am
Location: Illinois, USA

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Thu Mar 21, 2019 5:51 am

Thanks man! This worked on me. :D
It is more fun to drive a slow car fast than to drive a fast car slow.

Moore253
Posts: 1
Joined: Tue Jun 18, 2019 11:32 am

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Thu Jun 20, 2019 5:08 am

Edit the autostart file

For the standard Pi user:

Code: Select all

sudo nano /home/pi/.config/lxsession/LXDE-pi/autostart
For the root Pi user (if running the GUI with "sudo startx" for instance when running apps that access the IO pins):

Code: Select all

sudo nano /root/.config/lxsession/LXDE-pi/autostart
If the above doesn't work, then there is not a per user file so edit the global one Tellthebell.com:

Code: Select all

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
Last edited by Moore253 on Fri Jun 21, 2019 4:36 am, edited 1 time in total.

klricks
Posts: 7121
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Thu Jun 20, 2019 12:35 pm

Moore253 wrote:
Thu Jun 20, 2019 5:08 am
Edit the autostart file

For the standard Pi user:

Code: Select all

sudo nano /home/pi/.config/lxsession/LXDE-pi/autostart
For the root Pi user (if running the GUI with "sudo startx" for instance when running apps that access the IO pins):

Code: Select all

sudo nano /root/.config/lxsession/LXDE-pi/autostart
If the above doesn't work, then there is not a per user file so edit the global one:

Code: Select all

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
There is no reason to sudo startx not even for GPIO access. Doing so could result in a broken desktop.
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

Lewis-H
Posts: 26
Joined: Thu Oct 31, 2019 12:45 pm

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Tue Nov 12, 2019 11:57 am

Once installed, go to the Preferences option in the main desktop menu. You should find the screen saver application. Launch it and search for the option to disable it completely.
I tried this method and it worked for me. I hope this helps you!
Regards,
Lewis

hooverphonique
Posts: 12
Joined: Wed Nov 06, 2019 2:10 pm

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Fri Nov 29, 2019 1:45 pm

In Raspian 10/Buster, the only persistent thing that worked for me (besides installing xscreensaver) was editing "/etc/lightdm/lightdm.conf" and changing

Code: Select all

[Seat:*]
.
.
.
#xserver-command=X
to

Code: Select all

[Seat:*]
.
.
.
# set screensaver timeout=0 and disable dpms
xserver-command=X -s 0 -dpms
After rebooting, you can use

Code: Select all

xset -display ":0" q
to query whether your changes were applied.

eemanshahid75
Posts: 1
Joined: Mon Dec 16, 2019 10:11 pm

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Mon Dec 16, 2019 10:16 pm

klricks wrote:
Tue Feb 26, 2019 6:16 pm
jamesh wrote:
Tue Feb 26, 2019 3:26 pm
There is some official documentation here.

https://www.raspberrypi.org/documentati ... ensaver.md

If anyone finds that doesn't work, please indicate the problem by posting in this thread.
xscreensaver works but it is a 40MB install and adds a background process.

Simpler to do these commands (For GUI Desktop only):

Code: Select all

xset s off
xset -dpms
To make permanent add those 2 commands to autostart

Code: Select all

/etc/xdg/lxsession/LXDE-pi/autostart
Thanks alot for sharing this and I got my solution and my screen save got disabled in raspbian, Express HR

klricks
Posts: 7121
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Tue Dec 24, 2019 4:48 pm

Note to all:
There is now a menu option in raspi-config to disable/enable screen blanking.

Code: Select all

sudo raspi-config
Advanced menu A6.
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

MarieEsposito
Posts: 1
Joined: Fri Feb 21, 2020 7:05 am
Location: 1528 Ashmor Drive, Chisholm, Minnesota(MN)

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Thu Mar 19, 2020 7:48 am

I installed xscreensaver
  • sudo apt-get install xscreensaver
  • Once installed, go to Rpi's desktop "Menu" (left top corner)
  • Go to preference --> screensaver.
  • You will see a screen saver main menu. In the mode drop-down menu, select "disable screensaver" then close the window.
  • Reboot the Raspberry PI.
It should work now.

namfrivgame
Posts: 1
Joined: Wed Apr 08, 2020 5:14 pm
Contact: Website

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Wed Apr 08, 2020 5:30 pm

Hi
Thanks for your article I tried it and thankfully I did it

greatmetals
Posts: 3
Joined: Sun Apr 12, 2020 10:57 am

Re: STICKY: Howto: Disable Screen Saver In Raspbian

Sun Apr 12, 2020 11:00 am

Am having that similar issue

By ebai emmanuel ewangi

Return to “Beginners”