Howto: Disable Screen Saver In Raspbian


69 posts   Page 3 of 3   1, 2, 3
by Rive » Tue May 10, 2016 3:00 pm
lol

I myself have misquoted a few times... :?
DNPNWO
User avatar
Posts: 586
Joined: Sat Mar 26, 2016 5:21 pm
Location: USA
by timmoore46 » Fri May 13, 2016 12:22 pm
Huge apologies about the wrong accreditation ! its was really Rive wot dun it !*LOL*

Delighted it was all taken in good humour ! I spotted it when I read through the listing this morning !

So I realised I needed to do a bit of serious grovelling ! *LOL*

Grovel Grovel......

:o :o :o

Tim
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm
by snowwalker » Thu Jun 02, 2016 8:25 pm
Am I going to have this screen blan king problem when I use ANDROID on my PI 3 B model? :?:

I will be using it to stream and watch movies and TV show across the Web. Everything I want to watch can be watched on my Tablet so Android seem to be the best option so far. I don't like flash player because of the security risk, so I don't plan to use Linux ( Although I love it.).
Posts: 2
Joined: Thu Jun 02, 2016 3:53 pm
Location: Behind the wheel, or at my bench melting solder.
by klricks » Fri Jun 03, 2016 3:28 am
snowwalker wrote:Am I going to have this screen blan king problem when I use ANDROID on my PI 3 B model? :?:

I will be using it to stream and watch movies and TV show across the Web. Everything I want to watch can be watched on my Tablet so Android seem to be the best option so far. I don't like flash player because of the security risk, so I don't plan to use Linux ( Although I love it.).



I don't think there is any Andriod that works well enough on the RPi to be useful?
Follow the links here and you may find a forum to ask your question: https://www.raspberrypi.org/forums/view ... 73&t=71658
You don't have to worry about flash player as that is not supported in any RPI OS.
Go here for my RPi writeup. Basic config, Serial Port add-on etc:
http://blackeagle12.net/Comp/RPi/Rpi.html Click web icon on right side --->
Posts: 4422
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
by snowwalker » Fri Jun 03, 2016 3:55 pm
klricks wrote:I don't think there is any Andriod that works well enough on the RPi to be useful?
Follow the links here and you may find a forum to ask your question: https://www.raspberrypi.org/forums/view ... 73&t=71658
You don't have to worry about flash player as that is not supported in any RPI OS.


Well I guess that solves my problem.. if no OS on the PI supports it then Linux it is...
Posts: 2
Joined: Thu Jun 02, 2016 3:53 pm
Location: Behind the wheel, or at my bench melting solder.
by topcompanies » Fri Sep 02, 2016 9:31 am
Thanks jwzumwalt for solution. I am also facing this problem.
Posts: 1
Joined: Fri Sep 02, 2016 9:25 am
by keessap » Tue Oct 11, 2016 8:29 pm
To Disable the Screen Saver I have found out that it is very easy now in Rasbain-Jessie. CLI commands are not necessary anymore. You can set it in the LXSession configuration in Preferences. If you can't find the entry, you can add it with the Main Menu Editor.
Go to Preferences, LXsession configuration,
Choose: Autostart
Add a new command under Manual Autotarted Applications: @set s off -dpms
Your screen will go out again.https://www.raspberrypi.org/forums/post ... HT80B53UD#
Posts: 1
Joined: Wed Jan 09, 2013 9:23 pm
by EMJB » Wed Nov 16, 2016 1:01 pm
Was hoping that adding:
Code: Select all
@set s off -dpms

to "/home/pi/.config/lxsession/LXDE-pi/autostart" would work, but no such luck. Is this the wrong place or the wrong command, or both?

EMJB
Posts: 91
Joined: Wed Jun 12, 2013 8:29 am
by nl3prc » Wed Nov 16, 2016 3:37 pm
mmm

You should be in /root/.config/lxsession/LXDE-pi
User avatar
Posts: 152
Joined: Sun Jul 24, 2016 12:39 pm
Location: Den Helder the netherlands
by EMJB » Thu Nov 17, 2016 8:25 am
@nl3prc

Thanks, but I don't seem to have any file like that. When I try looking for similar files:

Code: Select all
 ~ $ sudo ls /root/.config/lxsession/LXDE-pi
ls: cannot access /root/.config/lxsession/LXDE-pi: No such file or directory
~ $ sudo ls /root/.config
ls: cannot access /root/.config: No such file or directory


Also a command to autostart an application works when put in "/home/pi/.config/lxsession/LXDE-pi/autostart".

I'm confused!

EMJB
Posts: 91
Joined: Wed Jun 12, 2013 8:29 am
by nl3prc » Thu Nov 17, 2016 9:14 am
my autostart looks like below
@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0
User avatar
Posts: 152
Joined: Sun Jul 24, 2016 12:39 pm
Location: Den Helder the netherlands
by Bosse_B » Thu Nov 17, 2016 11:24 am
I think that if noone has logged on as root on the specific Pi then there will be no files inside /root/.
I do not have any (/root is completely empty) on any of my RPi:s.
So fixing things in root's home dir might not be the proper thing to do.
Bo Berglund
Sweden
Posts: 563
Joined: Thu Jan 30, 2014 9:53 am
by RaTTuS » Thu Nov 17, 2016 11:59 am
you never want to run x as root anyway
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe
User avatar
Posts: 9182
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
by EMJB » Mon Nov 21, 2016 9:02 am
nl3prc wrote:my autostart looks like below
@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0


Thanks nl3prc - I copied the last 4 lines into my autostart folder which seems to have done the trick.

EMJB
Posts: 91
Joined: Wed Jun 12, 2013 8:29 am
by Lomax » Fri Dec 16, 2016 2:49 pm
This is driving me nuts. Despite setting BLANK_TIME=0 and POWERDOWN_TIME=0 in /etc/kbd/config the screen still switches off after a few minutes. I am not running LXDE, or even X, so those instructions are unlikely to help. Considering how many people are struggling with this behaviour, may I suggest the Raspbian team change the default to not turn off the screen? Modern LCDs are all LED backlit anyway so there should be little need to "save" the screen - if you want to turn it off, press the power button! ;)
Posts: 95
Joined: Wed May 20, 2015 9:43 pm
by RaTTuS » Fri Dec 16, 2016 3:24 pm
there are ways to to do it via systemd but meh!
add
consoleblank=0
to the end of /boot/config.txt
IIRC
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe
User avatar
Posts: 9182
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
by bkjaya1952 » Sat Dec 17, 2016 1:48 pm
klricks wrote:The easiest way to disable screen blanking in the Raspbian GUI is to install xscreensaver then configure it to disabled.
Code: Select all
sudo apt-get update
sudo apt-get install xscreensaver


In the [Display Mode] tab, set like this - Mode: [Disable Screen Saver]

Thank you :)
Posts: 8
Joined: Thu Nov 24, 2016 11:46 am
Location: Sri Lanka
by Lomax » Fri Jan 06, 2017 10:42 pm
RaTTuS wrote:there are ways to to do it via systemd but meh!
add
consoleblank=0
to the end of /boot/config.txt
IIRC


Thanks, but I'm still seeing blanking - looks like DPMS off. I have set
Code: Select all
BLANK_TIME=0
POWERDOWN_TIME=0
in /etc/kbd/config, and
Code: Select all
consoleblank=0
in /boot/config.txt. I've got a Python/Kivy app running in public and really need the screen to remain on for as long as the Pi itself is on. Any other ideas?
Posts: 95
Joined: Wed May 20, 2015 9:43 pm
by AlecGalloway » Thu Mar 16, 2017 10:20 pm
I have installed xscreensaver and edited lightdm.conf with xserver-command=X -s 0 -dpms, but the screensaver is still on. Is there something that I'm missing?
Posts: 1
Joined: Thu Mar 16, 2017 10:16 pm