cltz187
Posts: 2
Joined: Wed Sep 11, 2013 11:18 pm

MPEG2 not enabled

Thu Sep 12, 2013 12:23 am

I am having trouble getting the MPEG2 license enabled on my device..

I read the instructions on how to apply the license key to the config.txt so I am pretty sure I did everything correctly..

This is what I have done so far..

1:) I ssh'd into the Pi and entered: cat /proc/cpuinfo and copied the serial number
2:) Paid for the MPEG2 license and pasted in the serial number of my device.
3:) Received the email with the license key
4:) Pulled the flash card and opened the config.txt in notepad and pasted in the license into the file at the end of the file. I inserted an underscore between the license and the last value in the file.
5:)Inserted the card into the Pi and booted the device. I was prompted that the file had changed and confirmed to update the config.txt file then rebooted.
6:) I ssh'd into the Pi and typed in vcgencmd codec_enabled MPG2 to check that it was enabled and it said disabled.. Also there is no video when I play a DVD file.

I checked the config.txt file in the boot folder and the license is in there..

I also entered in the license number in the Raspbmc GUI and rebooted but it still didn't work..

I suspect that perhaps license may not match my device serial number but I copy and pasted everything and also double checked my confirmation emails and everything matches up..

Help!

Chris

itimpi
Posts: 1084
Joined: Sun Sep 25, 2011 11:44 am
Location: Potters Bar, United Kingdom
Contact: Website

Re: MPEG2 not enabled

Thu Sep 12, 2013 6:47 am

I am wondering if you have got the format of the entry in config.txt correct? You might try posting that here to see if we can spot something wrong (there is no security issue as the license is tied to a particular processor).

User avatar
Hove
Posts: 1205
Joined: Sun Oct 21, 2012 6:55 pm
Location: Cotswolds, UK
Contact: Website

Re: MPEG2 not enabled

Thu Sep 12, 2013 7:03 am

Copying and pasting may actually be the cause of the problem if you are using a windows machine for pasting. Windows uses CR/LF (carriage return/line feed) to end lines, whereas unix (including Linux) uses just LF. Have you tried just editing config.txt direct from your Raspberry Pi using Leafpad, vim, or your favourite editor to add your license information?
www.pistuffing.co.uk - Raspberry Pi and other stuffing!

User avatar
RaTTuS
Posts: 10381
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: MPEG2 not enabled

Thu Sep 12, 2013 7:36 am

you should of
ssh'ed into the the RPi
and sudo nano /boot/config.txt
and added the correct line there

windows has probably nobbled the config file unless you used notepad++ on windows
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

cltz187
Posts: 2
Joined: Wed Sep 11, 2013 11:18 pm

Re: MPEG2 not enabled

Thu Sep 12, 2013 10:11 am

Well I have good news it is now working but I am not sure what I did that fixed it..

It certainly seems plausible that a CR/LF got put on the end of the line I added because I was using notepad.. I had trouble getting SmartCtl (Hard Drive Smart Reporting) working on a FreeBSD box I have.. The command would work if I typed it in but if I tried running the script I created using notepad it wouldn't work.. I ended up I think using the editor going thru an SSH session.

I probably should have gone that route but I wasn't sure if it was the config.txt located in the /boot folder I had to modify and was just trying to follow directions.

I did watch a movie on it and I must say I am really impressed, it worked great infact I think the Pi works much better than the WDLive streaming media player I have which I may sell now. I had messed around with XBMC on a PC running Ubuntu so I was a bit familiar with it I even got the XBMC remote working on my android.

Thanks for the help.
Chris

Return to “Beginners”