Has this tutorial helped you?

Yes, I have successfully setup a non-bridged AP
38%
10
No, it didn't work for me
62%
16
 
Total votes: 26
saliamis
Posts: 2
Joined: Sat Sep 07, 2013 9:08 am
Contact: Website

Access Point (AP) for TP-Link TL-WN725N V2

Sat Sep 07, 2013 10:10 am

Hi all,

I have successfully configured the TP-Link TL-WN725N V2 WiFi module (chipset RTL8188EU) as an AP (access point).
Have tried many tutorials out there, but none worked for me (hostapd failures with bad wifi driver).

This tutorial is based upon these sources (with some exceptions):
RPI-Wireless-Hotspot
Wifi-hotspot-with-edimax-nano-usb

Since I used the module to control a robot through WiFi, I didn't setup a bridge to share internet connection (hotspot).
If you want to share/access internet through the AP, then look how to make a bridged connection in the above sources.

Steps that helped me to configure a non-bridged AP:

1. Install hostapd & dhcp server

Code: Select all

apt-get install hostapd udhcpd
2. Edit /etc/udhcpd.conf, set its contents like this:

Code: Select all

start 192.168.42.2 # This is the range of IPs that the hostspot will give to client devices.
end 192.168.42.20
interface wlan0 # The device uDHCP listens on.
remaining yes
opt dns 8.8.8.8 4.4.4.4 # The DNS servers client devices will use.
opt subnet 255.255.255.0
opt router 192.168.42.1 # The Pi's IP address on wlan0 which we will set up shortly.
opt lease 864000 # 10 day DHCP lease time in seconds
3. Edit /etc/default/udhcpd, set the following line to be like this:

Code: Select all

#DHCPD_ENABLED="no"
4. Set wlan0 static IP, edit /etc/network/interfaces, contents should look like this:

Code: Select all

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp


# WiFi AP
auto wlan0
iface wlan0 inet static
  address 192.168.42.1
  netmask 255.255.255.0
post-up service udhcpd start

#allow-hotplug wlan0
#iface wlan0 inet manual
#wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
#iface default inet dhcp
5. Replace hostapd with a modified binary:

Code: Select all

wget http://www.daveconroy.com/wp3/wp-content/uploads/2013/07/hostapd.zip
unzip hostapd.zip 
mv /usr/sbin/hostapd /usr/sbin/hostapd.bak
mv hostapd /usr/sbin/hostapd
chmod 755 /usr/sbin/hostapd
Alternative link: https://www.dropbox.com/s/u4lt7k6ko4i6589/hostapd.zip
NOTE: if you want to compile the binary for yourself, then go here & download RTL8192CUS driver. Navigate inside zip to the wpa_supplicant_hostapd/wpa_supplicant_hostapd-0.8/hostapd and run: make, make install, then copy as above.

6. Edit /etc/hostapd/hostapd.conf, contents should look like (change "RPI_AP" to the desired AP name, "AP_PASSWORD" - to desired password):

Code: Select all

interface=wlan0
driver=rtl871xdrv
ssid=RPI_AP
hw_mode=g
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=AP_PASSWORD
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
macaddr_acl=0
7. Edit /etc/default/hostapd, set the line to be:

Code: Select all

DAEMON_CONF="/etc/hostapd/hostapd.conf"
8. Run hostapd:

Code: Select all

service hostapd start
9. Allow hostapd to be run everytime on boot:

Code: Select all

update-rc.d hostapd enable
10. Reboot your RPi

Code: Select all

reboot
Finished! You should now have a fully working AP (with WPA2-PSK security) that you can connect to.
I have successfully tested with my Android phone.
Last edited by saliamis on Sun Nov 17, 2013 2:36 pm, edited 1 time in total.

pckrullenbol
Posts: 7
Joined: Fri Aug 30, 2013 3:00 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Sun Sep 15, 2013 2:33 pm

Hi Saliamis,
I have a model A, without ethernet, and a brand new TP-LINK WN725N v2, with the last chipset.
I did al your steps without errors, and after rebooting I see even the new created Access Point ("RPi_AP"), but I unable to connect. Services 'udhcpd' and 'hostapd' seem to run as service. I try to connect with my iPhone, but it gives a connection error.
Do you have any idea where to start looking?

jamkirbs
Posts: 16
Joined: Wed Jun 12, 2013 4:18 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Thu Oct 17, 2013 11:54 pm

Do this chipset support mac address filtering in hostapd? thanks!

vyms
Posts: 3
Joined: Sun Nov 10, 2013 1:07 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Thu Nov 14, 2013 3:40 am

Hi,
Thanks for the tutorial. I was able to setup AP. I can see it on my laptop wifi n/w list as well as Galaxy S3. I was able to connect to AP from laptop, however Galaxy S3 could not connect. It just gets stuck saying "Obtaining IP address...".

any clue ?

saliamis
Posts: 2
Joined: Sat Sep 07, 2013 9:08 am
Contact: Website

Re: Access Point (AP) for TP-Link TL-WN725N V2

Sun Nov 17, 2013 2:38 pm

vyms wrote:Hi,
Thanks for the tutorial. I was able to setup AP. I can see it on my laptop wifi n/w list as well as Galaxy S3. I was able to connect to AP from laptop, however Galaxy S3 could not connect. It just gets stuck saying "Obtaining IP address...".

any clue ?
I have updated the /etc/network/interfaces file contents, check it out. If it still does not work, add hotplug option:

Code: Select all

allow-hotplug wlan0
auto wlan0

vyms
Posts: 3
Joined: Sun Nov 10, 2013 1:07 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Mon Nov 18, 2013 3:56 am

Thanks for suggestion. I have tried it but no luck. Looks like rtl 8188 chipset's AP capability is in testing phase (not officially released). I will try the same with Ralink rt 5370 and update results.

vyms
Posts: 3
Joined: Sun Nov 10, 2013 1:07 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Tue Nov 19, 2013 2:47 pm

Worked without a problem with Ralink rt 5370. Able to connect android phone as well as laptop.

User avatar
airlomba
Posts: 11
Joined: Wed Mar 20, 2013 11:01 am
Location: Portugal
Contact: Website

Re: Access Point (AP) for TP-Link TL-WN725N V2

Tue Dec 10, 2013 3:06 pm

Hello all,

Did not work for me...
My setup is: Raspberry Pi Model B with TP-Link TL-WN725N v2 (0bda:8179)
Running Raspbian: 3.1.23+ #608 PREEMPT Mon Dec 9 21:11:23 GMT armv61 GNU/Linux
with appropriated dongle drivers from MrEngmann.

Executing command:
$ sudo hostapd -dd /etc/hostapd/hostapd.conf

I get the following:

Code: Select all

random: Trying to read entropy from /dev/random
Configuration file: /etc/hostapd/hostapd.conf
drv->ifindex=3
l2_sock_recv==l2_sock_xmit=0x0xeb9638
BSS count 1, BSSID mask 00:00:00:00:00:00 (0 bits)
Allowed channel: mode=1 chan=1 freq=2412 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=2 freq=2417 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=3 freq=2422 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=4 freq=2427 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=5 freq=2432 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=6 freq=2437 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=7 freq=2442 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=8 freq=2447 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=9 freq=2452 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=10 freq=2457 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=11 freq=2462 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=12 freq=2467 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=13 freq=2472 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=1 freq=2412 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=2 freq=2417 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=3 freq=2422 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=4 freq=2427 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=5 freq=2432 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=6 freq=2437 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=7 freq=2442 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=8 freq=2447 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=9 freq=2452 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=10 freq=2457 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=11 freq=2462 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=36 freq=5180 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=40 freq=5200 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=44 freq=5220 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=48 freq=5240 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=52 freq=5260 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=56 freq=5280 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=60 freq=5300 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=64 freq=5320 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=100 freq=5500 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=104 freq=5520 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=108 freq=5540 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=112 freq=5560 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=116 freq=5580 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=120 freq=5600 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=124 freq=5620 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=128 freq=5640 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=132 freq=5660 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=136 freq=5680 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=140 freq=5700 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=149 freq=5745 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=153 freq=5765 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=157 freq=5785 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=161 freq=5805 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=165 freq=5825 MHz max_tx_power=0 dBm
Completing interface initialization
Mode: IEEE 802.11g  Channel: 1  Frequency: 2412 MHz
RATE[0] rate=10 flags=0x1
RATE[1] rate=20 flags=0x1
RATE[2] rate=55 flags=0x1
RATE[3] rate=110 flags=0x1
RATE[4] rate=60 flags=0x0
RATE[5] rate=90 flags=0x0
RATE[6] rate=120 flags=0x0
RATE[7] rate=180 flags=0x0
RATE[8] rate=240 flags=0x0
RATE[9] rate=360 flags=0x0
RATE[10] rate=480 flags=0x0
RATE[11] rate=540 flags=0x0
Flushing old station entries
Could not connect to kernel driver.
Deauthenticate all stations
+rtl871x_sta_deauth_ops, ff:ff:ff:ff:ff:ff is deauth, reason=2
rtl871x_set_key_ops
Failed to set encryption.
Failed to clear default encryption keys (ifname=wlan0 keyidx=0)
rtl871x_set_key_ops
Failed to set encryption.
Failed to clear default encryption keys (ifname=wlan0 keyidx=1)
rtl871x_set_key_ops
Failed to set encryption.
Failed to clear default encryption keys (ifname=wlan0 keyidx=2)
rtl871x_set_key_ops
Failed to set encryption.
Failed to clear default encryption keys (ifname=wlan0 keyidx=3)
Using interface wlan0 with hwaddr 10:fe:ed:12:1d:55 and ssid 'ADBrpi3Net'
Deriving WPA PSK based on passphrase
SSID - hexdump_ascii(len=10):
     41 44 42 72 70 69 33 4e 65 74                     ADBrpi3Net      
PSK (ASCII passphrase) - hexdump_ascii(len=11): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
rtl871x_set_wps_assoc_resp_ie
random: Got 20/20 bytes from /dev/random
Get randomness: len=32 entropy=0
GMK - hexdump(len=32): [REMOVED]
Get randomness: len=32 entropy=0
Key Counter - hexdump(len=32): [REMOVED]
WPA: group state machine entering state GTK_INIT (VLAN-ID 0)
Get randomness: len=16 entropy=0
GTK - hexdump(len=16): [REMOVED]
WPA: group state machine entering state SETKEYSDONE (VLAN-ID 0)
rtl871x_set_key_ops
Failed to set encryption.
rtl871x_set_beacon_ops
rtl871x_set_hidden_ssid_ops
Failed to set beacon head/tail or DTIM period
wlan0: Setup of interface done.
As you can see, I get a lot of Failed steps; all as ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported.

Any ideas of what could be the reason behind this behavior? Thank you.

Best regards to all,
Emmanuel.

pato89xd
Posts: 1
Joined: Mon Mar 17, 2014 2:48 am

Re: Access Point (AP) for TP-Link TL-WN725N V2

Mon Mar 17, 2014 2:51 am

Hi, im experimenting the same problem, how can i fix it?

Code: Select all

pi@raspberrypi ~ $ sudo hostapd -dd /etc/hostapd/hostapd.conf
random: Trying to read entropy from /dev/random
Configuration file: /etc/hostapd/hostapd.conf
drv->ifindex=3
l2_sock_recv==l2_sock_xmit=0x0x403638
BSS count 1, BSSID mask 00:00:00:00:00:00 (0 bits)
Allowed channel: mode=1 chan=1 freq=2412 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=2 freq=2417 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=3 freq=2422 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=4 freq=2427 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=5 freq=2432 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=6 freq=2437 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=7 freq=2442 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=8 freq=2447 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=9 freq=2452 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=10 freq=2457 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=11 freq=2462 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=12 freq=2467 MHz max_tx_power=0 dBm
Allowed channel: mode=1 chan=13 freq=2472 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=1 freq=2412 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=2 freq=2417 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=3 freq=2422 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=4 freq=2427 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=5 freq=2432 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=6 freq=2437 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=7 freq=2442 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=8 freq=2447 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=9 freq=2452 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=10 freq=2457 MHz max_tx_power=0 dBm
Allowed channel: mode=0 chan=11 freq=2462 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=36 freq=5180 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=40 freq=5200 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=44 freq=5220 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=48 freq=5240 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=52 freq=5260 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=56 freq=5280 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=60 freq=5300 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=64 freq=5320 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=100 freq=5500 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=104 freq=5520 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=108 freq=5540 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=112 freq=5560 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=116 freq=5580 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=120 freq=5600 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=124 freq=5620 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=128 freq=5640 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=132 freq=5660 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=136 freq=5680 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=140 freq=5700 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=149 freq=5745 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=153 freq=5765 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=157 freq=5785 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=161 freq=5805 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=165 freq=5825 MHz max_tx_power=0 dBm
Completing interface initialization
Mode: IEEE 802.11g  Channel: 6  Frequency: 2437 MHz
RATE[0] rate=10 flags=0x1
RATE[1] rate=20 flags=0x1
RATE[2] rate=55 flags=0x1
RATE[3] rate=110 flags=0x1
RATE[4] rate=60 flags=0x0
RATE[5] rate=90 flags=0x0
RATE[6] rate=120 flags=0x0
RATE[7] rate=180 flags=0x0
RATE[8] rate=240 flags=0x0
RATE[9] rate=360 flags=0x0
RATE[10] rate=480 flags=0x0
RATE[11] rate=540 flags=0x0
Flushing old station entries
ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported
Could not connect to kernel driver.
Deauthenticate all stations
+rtl871x_sta_deauth_ops, ff:ff:ff:ff:ff:ff is deauth, reason=2
rtl871x_set_key_ops
ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
Failed to clear default encryption keys (ifname=wlan0 keyidx=0)
rtl871x_set_key_ops
ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
Failed to clear default encryption keys (ifname=wlan0 keyidx=1)
rtl871x_set_key_ops
ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
Failed to clear default encryption keys (ifname=wlan0 keyidx=2)
rtl871x_set_key_ops
ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
Failed to clear default encryption keys (ifname=wlan0 keyidx=3)
Using interface wlan0 with hwaddr c0:4a:00:12:63:50 and ssid 'publicidad'
Deriving WPA PSK based on passphrase
SSID - hexdump_ascii(len=10):
     70 75 62 6c 69 63 69 64 61 64                     publicidad      
PSK (ASCII passphrase) - hexdump_ascii(len=8): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
rtl871x_set_wps_assoc_resp_ie
ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported
random: Got 20/20 bytes from /dev/random
Get randomness: len=32 entropy=0
GMK - hexdump(len=32): [REMOVED]
Get randomness: len=32 entropy=0
Key Counter - hexdump(len=32): [REMOVED]
WPA: group state machine entering state GTK_INIT (VLAN-ID 0)
Get randomness: len=16 entropy=0
GTK - hexdump(len=16): [REMOVED]
WPA: group state machine entering state SETKEYSDONE (VLAN-ID 0)
rtl871x_set_key_ops
ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
rtl871x_set_beacon_ops
rtl871x_set_hidden_ssid_ops
ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported
ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported
Failed to set beacon head/tail or DTIM period
wlan0: Setup of interface done.

User avatar
airlomba
Posts: 11
Joined: Wed Mar 20, 2013 11:01 am
Location: Portugal
Contact: Website

Re: Access Point (AP) for TP-Link TL-WN725N V2

Wed Apr 16, 2014 2:33 pm

Hello all,

After a while, I spent the last couple of days reading a lost of posts on this and other forums, blogs and other webpages. And after several trials I finally got my Access Point up and running!
$ sudo apt-get update
$ sudo apt-get upgrade
$ uname -a
returned: Linux ADB-rpi3 3.10.25+ #622 PREEMPT Fri Jan 3 18:41:00 GMT 2014 armv6l GNU/Linux
Installation of the appropriate TP-LINK TL-WN725N V2 drivers
$ wget https://dl.dropboxusercontent.com/u/802 ... 219.tar.gz
$ tar -zxvf 8188eu-20131219.tar.gz
$ sudo install -p -m 644 8188eu.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless
$ sudo insmod /lib/modules/$(uname -r)/kernel/drivers/net/wireless/8188eu.ko
$ sudo depmod -a
$ lsmod
returned: 8188eu 665215 0
$ sudo reboot
$ ifconfig -a
returned: wlan0 Link encap:Ethernet HWaddr 10:nn:nn:nn:1d:55
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:97 erros:0 dropped:0 averruns:0 frame:0
TX packets:0 erros:0 dropped:0 averruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0B) TX bytes: 0 (0.0 B)
Installation of the Access Point tools:
$ sudo apt-get install udhcpd hostapd
$ sudo nano /etc/udhcpd.conf
start 192.168.2.10
stop 192.168.2.20
interface wlan0
remaining yes
opt dns 8.8.8.8 4.4.4.4
opt subnet 255.255.255.0
opt router 192.168.2.1
opt lease 864000
$ sudo nano /etc/default/udhcpd
changed line DHCPD_ENABLED="no" to #DHCPD_ENABLED="no"
$ sudo nano /etc/network/interfaces
auto lo
iface lo inet loopback
iface eth0 inet dhcp
auto wlan0
iface wlan0 inet static
address 192.168.2.1
netmask 255.255.255.0
$ sudo nano /etc/hostapd/hostapd.conf
interface=wlan0
driver=rtl871xdrv
ssid=MY-SSID
hw_mode=g
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=MY-PASSWORD
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
$ sudo nano /etc/default/hostapd
changed line #DAEMON_CONF=""
to DAEMON_CONF="/etc/hostapd/hostapd.conf"
Replacing original hostapd with one that works on my Dongle
$ wget http://www.daveconroy.com/wp3/wp-conten ... ostapd.zip
$ unzip hostapd.zip
$ sudo mv /usr/sbin/hostapd /usr/sbin/hostapd.bak
$ sudo mv hostapd /usr/sbin/hostapd
$ sudo chmod 755 /usr/sbin/hostapd
Starting it all:
$ sudo service hostapd start
$ sudo service udhcpd start
Enabling hostapd and udhcpd to start at each Pi's boot:
Since the IP address mentioned in interfaces files wasn't assigned to wlan0 in every boot (bizarre), I had to come up with the following workaround. This, because without an IP assigned to wlan0, the DHCP deamon wouldn't start, thus the Pi wouldn't distribute an IP to any client willing to pair with your Pi.
$ sudo update-rc.d hostapd enable
$ sudo nano /etc/rc.local
sudo ifconfig wlan0 192.168.2.1
sudo service udhcpd start
$ sudo reboot
I hope this post can be of some help.

Best regards,
Emmanuel.

User avatar
airlomba
Posts: 11
Joined: Wed Mar 20, 2013 11:01 am
Location: Portugal
Contact: Website

Re: Access Point (AP) for TP-Link TL-WN725N V2

Thu Apr 17, 2014 10:06 am

Hello all,

I just edited my previous post with the solution to my troubles.
All is working fine now.

Best regards,
Emmanuel.

dnascimento
Posts: 3
Joined: Thu May 22, 2014 1:40 am

Re: Access Point (AP) for TP-Link TL-WN725N V2

Thu Jun 05, 2014 9:03 pm

What was the performance of RTL8188EU as access point? could you measure the throughput?

User avatar
airlomba
Posts: 11
Joined: Wed Mar 20, 2013 11:01 am
Location: Portugal
Contact: Website

Re: Access Point (AP) for TP-Link TL-WN725N V2

Thu Jun 05, 2014 9:06 pm

dnascimento wrote:What was the performance of RTL8188EU as access point? could you measure the throughput?
Hi,

I am not an expert in Network Programming. If you can point some method to measure the performance, I can measure it for you and post the results.

However, from my point of view, I have no complaint about the RTL8188EU as an access point.

Best regards,
Emmanuel.

mi_huzki
Posts: 1
Joined: Mon Aug 25, 2014 4:21 am

Re: Access Point (AP) for TP-Link TL-WN725N V2

Mon Aug 25, 2014 4:34 am

Hi, I successfully run a accesss point but whit this wide (many tanks!!!!!). Also I install minidlna in the raspberry but my smarth tv or my phone cant see any file with the wifi connexion of the pi. If I connect my phone with the wifi of the modem I see any media file of my pi. How can I do? Many thank and sorry for my english.

Thossaporn
Posts: 10
Joined: Mon Oct 06, 2014 6:21 am

Re: Access Point (AP) for TP-Link TL-WN725N V2

Tue Mar 10, 2015 8:51 am

i get error when

Code: Select all

sudo service hostapd start
[FAIL] Starting advanced IEEE 802.11 management: hostapd failed!

/etc/hostapd/hostapd.conf

Code: Select all

interface=wlan0
driver=rtl871xdrv
ssid=raspi
hw_mode=g
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=12345678
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
uname -a:
Linux raspberrypi 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux
i used raspberry pi B+ and TP-Link 725n chipset 8188eu

i installed my doggle by

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20150212.tar.gz
tar xzf 8188eu-2015yyzz.tar.gz
./install.sh
when installed complete i reboot my raspberry
when ifconfig i found wlan0
then i following first comment

Could anyone help me to fix this error ?

Thanks

Thossaporn
Posts: 10
Joined: Mon Oct 06, 2014 6:21 am

Re: Access Point (AP) for TP-Link TL-WN725N V2

Wed Mar 11, 2015 5:38 pm

Thossaporn wrote:i get error when

Code: Select all

sudo service hostapd start
[FAIL] Starting advanced IEEE 802.11 management: hostapd failed!

/etc/hostapd/hostapd.conf

Code: Select all

interface=wlan0
driver=rtl871xdrv
ssid=raspi
hw_mode=g
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=12345678
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
uname -a:
Linux raspberrypi 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux
i used raspberry pi B+ and TP-Link 725n chipset 8188eu

i installed my doggle by

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20150212.tar.gz
tar xzf 8188eu-2015yyzz.tar.gz
./install.sh
when installed complete i reboot my raspberry
when ifconfig i found wlan0
then i following first comment

Could anyone help me to fix this error ?

Thanks
in step 5 i get this link

Code: Select all

wget http://adafruit-download.s3.amazonaws.com/adafruit_hostapd_14128.zip
Now i can fix this issue .

It's work fine for me.
Thanks

Ryuki001
Posts: 2
Joined: Sat Oct 03, 2015 3:09 am

Re: Access Point (AP) for TP-Link TL-WN725N V2

Sat Oct 03, 2015 3:14 am

I followed each step in this post and I can find the wifi network now. However, it has verify issue when I connect to that network. It look like I input a wrong password. Anyone know how to solve it?

tam1111574
Posts: 2
Joined: Sun Oct 04, 2015 5:57 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Sun Oct 04, 2015 6:11 pm

Ryuki001 wrote:I followed each step in this post and I can find the wifi network now. However, it has verify issue when I connect to that network. It look like I input a wrong password. Anyone know how to solve it?
I have a error too. You can use this config for hostapd.conf

sudo nano /etc/hostapd/hostapd.conf

interface=wlan0
driver=rtl871xdrv
ssid=WLAN-NAME
channel=1
hw_mode=g

And you can connect to AP.

I don't understand when i config my hostapd

interface=wlan0
driver=rtl871xdrv
ssid=raspi
hw_mode=g
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=12345678
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP


I can't connect to my AP with my phone, laptop...v.v... Wrong password... !!!!!.... why ?......................

benxico
Posts: 2
Joined: Mon Jun 03, 2013 2:18 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Mon Oct 12, 2015 1:46 pm

Hello,

same issue with raspbian jessie :
Linux raspberrypi 4.1.7+ #817

with open wifi network, it's working.
When I wan't to set a wpa password, I can't not get authentified :-(

If some body have an idea ?

Bests regards,

Benxico

supercammello
Posts: 2
Joined: Mon Oct 19, 2015 10:30 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Mon Oct 19, 2015 10:35 pm

Hello
I have the same problem,
before all is working but with last kernel update 4.1.7+ #817
if I set a wep any device can't connect to the AP.
If I set open Access Point all is working.

How can I solve?

supercammello
Posts: 2
Joined: Mon Oct 19, 2015 10:30 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Sat Oct 24, 2015 1:28 pm

anyone can help me?

ShockGoRat
Posts: 1
Joined: Mon Oct 26, 2015 3:03 am

Re: Access Point (AP) for TP-Link TL-WN725N V2

Mon Oct 26, 2015 3:13 am

I use TP-Link TL-WN725N V2 with kernel version 3.18.11-v7+ #781 on Pi2.

This instruction is not work for me, but I found the problem came from its driver. I use driver from this http://blog.mac.boy.name/2015/04/tl-wn7 ... p-for.html and it works for me. I can connect to Pi2 either PC and my smartphone(BB Z10).

tam1111574
Posts: 2
Joined: Sun Oct 04, 2015 5:57 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Tue Oct 27, 2015 10:27 am

ShockGoRat wrote:I use TP-Link TL-WN725N V2 with kernel version 3.18.11-v7+ #781 on Pi2.

This instruction is not work for me, but I found the problem came from its driver. I use driver from this http://blog.mac.boy.name/2015/04/tl-wn7 ... p-for.html and it works for me. I can connect to Pi2 either PC and my smartphone(BB Z10).
Hi... can you set password for host..?...

renoir
Posts: 8
Joined: Thu Dec 03, 2015 7:18 pm

Re: Access Point (AP) for TP-Link TL-WN725N V2

Tue Dec 08, 2015 8:05 am

Tried this, but it seems to not work on the Pi 2 B with:

Code: Select all

Linux raspberrypi 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l GNU/Linux
The APN shows up, but you couldn't connect to it because it doesn't recognize the password.

If you remove the password it won't lease you an IP.

If anyone has solved this please share. For now this tutorial should be marked not working form this version of Raspbian.

ipablo_gomez
Posts: 1
Joined: Tue Feb 16, 2016 5:21 am

Re: Access Point (AP) for TP-Link TL-WN725N V2

Tue Feb 16, 2016 5:33 am

I have a problem, when i reboot raspberry pi don't start,
says "A start job is runnin for LSB: Raise network interfaces (time/no limit)

Return to “Beginners”

Who is online

Users browsing this forum: Jagfan, mahjongg, nunocv and 29 guests