jimmybobby
Posts: 29
Joined: Wed Feb 20, 2013 9:53 pm

Re: Setup Logmein Hamachi for SSH access behind firewalls, e

Tue Oct 27, 2015 1:48 pm

Will this work for all ports, and connections between two rpis?

working on a remotely deployed webcam solution, without access to routers at either end.

ps: sorry for bringing this thread alive again...
It's fair to say I like obsolete/old technology. :)
A Level Comp Sci Student

fruitoftheloom
Posts: 20167
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Setup Logmein Hamachi for SSH access behind firewalls, e

Tue Oct 27, 2015 1:50 pm

jimmybobby wrote:Will this work for all ports, and connections between two rpis?

working on a remotely deployed webcam solution, without access to routers at either end.

ps: sorry for bringing this thread alive again...
There is now another alternative which may of interest:

https://www.weaved.com/raspberry-pi-remote-connection
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

User avatar
MrWolf80
Posts: 18
Joined: Tue Apr 16, 2013 8:18 am
Location: Italy

Re: Setup Logmein Hamachi for SSH access behind firewalls, e

Tue Oct 27, 2015 2:52 pm

By the way, Logmein Hamachi is not free anymore. :|

caporeira
Posts: 73
Joined: Sun Aug 25, 2013 5:58 pm

Re: Setup Logmein Hamachi for SSH access behind firewalls, e

Mon Dec 14, 2015 9:04 pm

Hi,
I need yours help. I instaled hamachi, but I can't start it :(

What i'm doing wrong ?
I have Rpi2 and OSMC as system.

Code: Select all

Witam,

potrzebuje Waszej pomocy. Zainstalowałem Hamachi, ale nie mogę go odpalić :(
Pomóżcie, jak to zrobić ?

[code]
[email protected]:~$ sudo apt-get update
Ign http://ftp.debian.org jessie InRelease
Hit http://security.debian.org jessie/updates InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Hit http://ftp.debian.org jessie Release.gpg
Hit http://apt.osmc.tv jessie InRelease
Hit http://ftp.debian.org jessie Release
Hit http://security.debian.org jessie/updates/main armhf Packages
Hit http://security.debian.org jessie/updates/contrib armhf Packages
Get:1 http://ftp.debian.org jessie-updates/main armhf Packages/DiffIndex [367 B]
Hit http://security.debian.org jessie/updates/non-free armhf Packages
Hit http://ftp.debian.org jessie-updates/contrib armhf Packages
Hit http://security.debian.org jessie/updates/contrib Translation-en
Hit http://ftp.debian.org jessie-updates/non-free armhf Packages
Get:2 http://apt.osmc.tv jessie/main armhf Packages/DiffIndex [2023 B]
Hit http://security.debian.org jessie/updates/main Translation-en
Hit http://ftp.debian.org jessie-updates/contrib Translation-en
Hit http://security.debian.org jessie/updates/non-free Translation-en
Hit http://ftp.debian.org jessie-updates/main Translation-en
Hit http://ftp.debian.org jessie-updates/non-free Translation-en
Hit http://ftp.debian.org jessie/main armhf Packages
Hit http://ftp.debian.org jessie/contrib armhf Packages
Hit http://ftp.debian.org jessie/non-free armhf Packages
Hit http://ftp.debian.org jessie/contrib Translation-en
Hit http://ftp.debian.org jessie/main Translation-en
Hit http://ftp.debian.org jessie/non-free Translation-en
Ign http://apt.osmc.tv jessie/main Translation-en
Fetched 2390 B in 18s (126 B/s)
Reading package lists... Done
[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~$ sudo apt-get install lsb-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
lsb-core is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~$ sudo apt-get install lsb
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  cups-filters cups-filters-core-drivers ghostscript gsfonts libatk1.0-0
  libatk1.0-data libaudio2 libdrm2 libfontembed1 libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-common libgl1-mesa-glx libglapi-mesa libglu1-mesa libgs9
  libgs9-common libgtk2.0-0 libgtk2.0-common libice6 libijs-0.35 libjbig2dec0
  libmng1 libopenjpeg5 libpango1.0-0 libpangox-1.0-0 libpangoxft-1.0-0
  libpaper1 libpod-plainer-perl libpoppler46 libqpdf13 libqt4-network
  libqt4-opengl libqt4-sql libqt4-sql-sqlite libqt4-svg libqt4-xml libqtcore4
  libqtdbus4 libqtgui4 libsm6 libx11-xcb1 libxcb-dri2-0 libxcb-dri3-0
  libxcb-glx0 libxcb-present0 libxcb-sync1 libxcomposite1 libxcursor1
  libxdamage1 libxfixes3 libxft2 libxi6 libxinerama1 libxrandr2 libxshmfence1
  libxt6 libxtst6 libxxf86vm1 lsb-cxx lsb-desktop lsb-graphics lsb-languages
  lsb-multimedia lsb-printing poppler-data poppler-utils qtcore4-l10n
  shared-mime-info x11-common xdg-utils
Suggested packages:
  foomatic-db-compressed-ppds foomatic-db ghostscript-x nas librsvg2-common
  gvfs libqt4-dev qt4-qtconfig fonts-japanese-mincho fonts-ipafont-mincho
  fonts-japanese-gothic fonts-ipafont-gothic fonts-arphic-ukai
  fonts-arphic-uming fonts-nanum gvfs-bin
Recommended packages:
  colord libgl1-mesa-dri fonts-droid hicolor-icon-theme libgtk2.0-bin
  libpaper-utils qpdf libqt3-mt libfile-mimeinfo-perl libnet-dbus-perl
  libx11-protocol-perl x11-utils x11-xserver-utils
The following NEW packages will be installed:
  cups-filters cups-filters-core-drivers ghostscript gsfonts libatk1.0-0
  libatk1.0-data libaudio2 libdrm2 libfontembed1 libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-common libgl1-mesa-glx libglapi-mesa libglu1-mesa libgs9
  libgs9-common libgtk2.0-0 libgtk2.0-common libice6 libijs-0.35 libjbig2dec0
  libmng1 libopenjpeg5 libpango1.0-0 libpangox-1.0-0 libpangoxft-1.0-0
  libpaper1 libpod-plainer-perl libpoppler46 libqpdf13 libqt4-network
  libqt4-opengl libqt4-sql libqt4-sql-sqlite libqt4-svg libqt4-xml libqtcore4
  libqtdbus4 libqtgui4 libsm6 libx11-xcb1 libxcb-dri2-0 libxcb-dri3-0
  libxcb-glx0 libxcb-present0 libxcb-sync1 libxcomposite1 libxcursor1
  libxdamage1 libxfixes3 libxft2 libxi6 libxinerama1 libxrandr2 libxshmfence1
  libxt6 libxtst6 libxxf86vm1 lsb lsb-cxx lsb-desktop lsb-graphics
  lsb-languages lsb-multimedia lsb-printing poppler-data poppler-utils
  qtcore4-l10n shared-mime-info x11-common xdg-utils
0 upgraded, 71 newly installed, 0 to remove and 0 not upgraded.
Need to get 27.0 MB of archives.
After this operation, 94.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.debian.org/debian/ jessie/main libatk1.0-data all 2.14.0-1 [181                                                       kB]
Get:2 http://security.debian.org/ jessie/updates/main libfontembed1 armhf 1.0.61                                                      -5+deb8u2 [70.9 kB]
Get:3 http://security.debian.org/ jessie/updates/main libgdk-pixbuf2.0-common al                                                      l 2.31.1-2+deb8u3 [294 kB]
Get:4 http://ftp.debian.org/debian/ jessie/main libatk1.0-0 armhf 2.14.0-1 [84.9                                                       kB]
Get:5 http://ftp.debian.org/debian/ jessie/main x11-common all 1:7.7+7 [287 kB]
Get:6 http://security.debian.org/ jessie/updates/main libgdk-pixbuf2.0-0 armhf 2                                                      .31.1-2+deb8u3 [149 kB]
Get:7 http://security.debian.org/ jessie/updates/main cups-filters-core-drivers                                                       armhf 1.0.61-5+deb8u2 [130 kB]
Get:8 http://ftp.debian.org/debian/ jessie/main libice6 armhf 2:1.0.9-1+b1 [52.5                                                       kB]
Get:9 http://security.debian.org/ jessie/updates/main cups-filters armhf 1.0.61-                                                      5+deb8u2 [483 kB]
Get:10 http://ftp.debian.org/debian/ jessie/main libsm6 armhf 2:1.2.2-1+b1 [31.8                                                       kB]
Get:11 http://ftp.debian.org/debian/ jessie/main libxt6 armhf 1:1.1.4-1+b1 [157                                                       kB]
Get:12 http://ftp.debian.org/debian/ jessie/main libaudio2 armhf 1.9.4-3 [73.8 k                                                      B]
Get:13 http://ftp.debian.org/debian/ jessie/main libdrm2 armhf 2.4.58-2 [27.6 kB                                                      ]
Get:14 http://ftp.debian.org/debian/ jessie/main libglapi-mesa armhf 10.3.2-1+de                                                      b8u1 [64.0 kB]
Get:15 http://ftp.debian.org/debian/ jessie/main libx11-xcb1 armhf 2:1.6.2-3 [16                                                      3 kB]
Get:16 http://ftp.debian.org/debian/ jessie/main libxcb-dri2-0 armhf 1.10-3+b1 [                                                      12.7 kB]
Get:17 http://ftp.debian.org/debian/ jessie/main libxcb-dri3-0 armhf 1.10-3+b1 [                                                      11.0 kB]
Get:18 http://ftp.debian.org/debian/ jessie/main libxcb-glx0 armhf 1.10-3+b1 [25                                                      .8 kB]
Get:19 http://ftp.debian.org/debian/ jessie/main libxcb-present0 armhf 1.10-3+b1                                                       [11.1 kB]
Get:20 http://ftp.debian.org/debian/ jessie/main libxcb-sync1 armhf 1.10-3+b1 [1                                                      3.9 kB]
Get:21 http://ftp.debian.org/debian/ jessie/main libxfixes3 armhf 1:5.0.1-2+b2 [                                                      20.1 kB]
Get:22 http://ftp.debian.org/debian/ jessie/main libxdamage1 armhf 1:1.1.4-2+b1                                                       [14.2 kB]
Get:23 http://ftp.debian.org/debian/ jessie/main libxshmfence1 armhf 1.1-4 [6578                                                       B]
Get:24 http://ftp.debian.org/debian/ jessie/main libxxf86vm1 armhf 1:1.1.3-1+b1                                                       [19.0 kB]
Get:25 http://ftp.debian.org/debian/ jessie/main libgl1-mesa-glx armhf 10.3.2-1+                                                      deb8u1 [169 kB]
Get:26 http://ftp.debian.org/debian/ jessie/main libglu1-mesa armhf 9.0.0-2 [129                                                       kB]
Get:27 http://ftp.debian.org/debian/ jessie/main libgtk2.0-common all 2.24.25-3                                                       [3123 kB]
Get:28 http://ftp.debian.org/debian/ jessie/main libxcomposite1 armhf 1:0.4.4-1                                                       [16.8 kB]
Get:29 http://ftp.debian.org/debian/ jessie/main libxcursor1 armhf 1:1.1.14-1+b1                                                       [32.0 kB]
Get:30 http://ftp.debian.org/debian/ jessie/main libxi6 armhf 2:1.7.4-1+b2 [75.8                                                       kB]
Get:31 http://ftp.debian.org/debian/ jessie/main libxinerama1 armhf 2:1.1.3-1+b1                                                       [16.6 kB]
Get:32 http://ftp.debian.org/debian/ jessie/main libxrandr2 armhf 2:1.4.2-1+b1 [                                                      33.1 kB]
Get:33 http://ftp.debian.org/debian/ jessie/main shared-mime-info armhf 1.3-1 [6                                                      43 kB]
Get:34 http://ftp.debian.org/debian/ jessie/main libgtk2.0-0 armhf 2.24.25-3 [20                                                      55 kB]
Get:35 http://ftp.debian.org/debian/ jessie/main libijs-0.35 armhf 0.35-10 [18.3                                                       kB]
Get:36 http://ftp.debian.org/debian/ jessie/main libmng1 armhf 1.0.10+dfsg-3.1+b                                                      3 [165 kB]
Get:37 http://ftp.debian.org/debian/ jessie/main libxft2 armhf 2.3.2-1 [48.4 kB]
Get:38 http://ftp.debian.org/debian/ jessie/main libpangoxft-1.0-0 armhf 1.36.8-                                                      3 [193 kB]
Get:39 http://ftp.debian.org/debian/ jessie/main libpaper1 armhf 1.1.24+nmu4 [21                                                      .4 kB]
Get:40 http://ftp.debian.org/debian/ jessie/main libopenjpeg5 armhf 1:1.5.2-3 [9                                                      5.2 kB]
Get:41 http://ftp.debian.org/debian/ jessie/main libpoppler46 armhf 0.26.5-2 [11                                                      09 kB]
Get:42 http://ftp.debian.org/debian/ jessie/main libqpdf13 armhf 5.1.2-2 [295 kB                                                      ]
Get:43 http://ftp.debian.org/debian/ jessie/main qtcore4-l10n all 4:4.8.6+git64-                                                      g5dc8b2b+dfsg-3+deb8u1 [654 kB]
Get:44 http://ftp.debian.org/debian/ jessie/main libqtcore4 armhf 4:4.8.6+git64-                                                      g5dc8b2b+dfsg-3+deb8u1 [1416 kB]
Get:45 http://ftp.debian.org/debian/ jessie/main libqt4-xml armhf 4:4.8.6+git64-                                                      g5dc8b2b+dfsg-3+deb8u1 [124 kB]
Get:46 http://ftp.debian.org/debian/ jessie/main libqtdbus4 armhf 4:4.8.6+git64-                                                      g5dc8b2b+dfsg-3+deb8u1 [195 kB]
Get:47 http://ftp.debian.org/debian/ jessie/main libqt4-network armhf 4:4.8.6+gi                                                      t64-g5dc8b2b+dfsg-3+deb8u1 [522 kB]
Get:48 http://ftp.debian.org/debian/ jessie/main libqtgui4 armhf 4:4.8.6+git64-g                                                      5dc8b2b+dfsg-3+deb8u1 [3629 kB]
Get:49 http://ftp.debian.org/debian/ jessie/main libqt4-opengl armhf 4:4.8.6+git                                                      64-g5dc8b2b+dfsg-3+deb8u1 [300 kB]
Get:50 http://ftp.debian.org/debian/ jessie/main libqt4-sql armhf 4:4.8.6+git64-                                                      g5dc8b2b+dfsg-3+deb8u1 [125 kB]
Get:51 http://ftp.debian.org/debian/ jessie/main libqt4-sql-sqlite armhf 4:4.8.6                                                      +git64-g5dc8b2b+dfsg-3+deb8u1 [60.0 kB]
Get:52 http://ftp.debian.org/debian/ jessie/main libqt4-svg armhf 4:4.8.6+git64-                                                      g5dc8b2b+dfsg-3+deb8u1 [155 kB]
Get:53 http://ftp.debian.org/debian/ jessie/main libxtst6 armhf 2:1.2.2-1+b1 [25                                                      .6 kB]
Get:54 http://ftp.debian.org/debian/ jessie/main poppler-data all 0.4.7-1 [1491                                                       kB]
Get:55 http://ftp.debian.org/debian/ jessie/main libpangox-1.0-0 armhf 0.0.2-5 [                                                      38.3 kB]
Get:56 http://ftp.debian.org/debian/ jessie/main poppler-utils armhf 0.26.5-2 [1                                                      24 kB]
Get:57 http://ftp.debian.org/debian/ jessie/main libjbig2dec0 armhf 0.11+2012012                                                      5-1 [43.9 kB]
Get:58 http://ftp.debian.org/debian/ jessie/main libgs9-common all 9.06~dfsg-2+d                                                      eb8u1 [1979 kB]
Get:59 http://ftp.debian.org/debian/ jessie/main libgs9 armhf 9.06~dfsg-2+deb8u1                                                       [1656 kB]
Get:60 http://ftp.debian.org/debian/ jessie/main gsfonts all 1:8.11+urwcyr1.0.7~                                                      pre44-4.2 [3364 kB]
Get:61 http://ftp.debian.org/debian/ jessie/main ghostscript armhf 9.06~dfsg-2+d                                                      eb8u1 [83.2 kB]
Get:62 http://ftp.debian.org/debian/ jessie/main libpod-plainer-perl all 1.04-1                                                       [6424 B]
Get:63 http://ftp.debian.org/debian/ jessie/main xdg-utils all 1.1.0~rc1+git2011                                                      1210-7.4 [65.0 kB]
Get:64 http://ftp.debian.org/debian/ jessie/main libpango1.0-0 armhf 1.36.8-3 [1                                                      83 kB]
Get:65 http://ftp.debian.org/debian/ jessie/main lsb-graphics armhf 4.1+Debian13                                                      +nmu1 [20.0 kB]
Get:66 http://ftp.debian.org/debian/ jessie/main lsb-cxx armhf 4.1+Debian13+nmu1                                                       [20.0 kB]
Get:67 http://ftp.debian.org/debian/ jessie/main lsb-multimedia armhf 4.1+Debian                                                      13+nmu1 [20.0 kB]
Get:68 http://ftp.debian.org/debian/ jessie/main lsb-desktop armhf 4.1+Debian13+                                                      nmu1 [21.1 kB]
Get:69 http://ftp.debian.org/debian/ jessie/main lsb-printing armhf 4.1+Debian13                                                      +nmu1 [20.0 kB]
Get:70 http://ftp.debian.org/debian/ jessie/main lsb-languages armhf 4.1+Debian1                                                      3+nmu1 [20.0 kB]
Get:71 http://ftp.debian.org/debian/ jessie/main lsb all 4.1+Debian13+nmu1 [20.0                                                       kB]
Fetched 27.0 MB in 5min 38s (79.7 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously unselected package libatk1.0-data.
(Reading database ... 35686 files and directories currently installed.)
Preparing to unpack .../libatk1.0-data_2.14.0-1_all.deb ...
Unpacking libatk1.0-data (2.14.0-1) ...
Selecting previously unselected package libatk1.0-0:armhf.
Preparing to unpack .../libatk1.0-0_2.14.0-1_armhf.deb ...
Unpacking libatk1.0-0:armhf (2.14.0-1) ...
Selecting previously unselected package x11-common.
Preparing to unpack .../x11-common_1%3a7.7+7_all.deb ...
Unpacking x11-common (1:7.7+7) ...
Selecting previously unselected package libice6:armhf.
Preparing to unpack .../libice6_2%3a1.0.9-1+b1_armhf.deb ...
Unpacking libice6:armhf (2:1.0.9-1+b1) ...
Selecting previously unselected package libsm6:armhf.
Preparing to unpack .../libsm6_2%3a1.2.2-1+b1_armhf.deb ...
Unpacking libsm6:armhf (2:1.2.2-1+b1) ...
Selecting previously unselected package libxt6:armhf.
Preparing to unpack .../libxt6_1%3a1.1.4-1+b1_armhf.deb ...
Unpacking libxt6:armhf (1:1.1.4-1+b1) ...
Selecting previously unselected package libaudio2:armhf.
Preparing to unpack .../libaudio2_1.9.4-3_armhf.deb ...
Unpacking libaudio2:armhf (1.9.4-3) ...
Selecting previously unselected package libdrm2:armhf.
Preparing to unpack .../libdrm2_2.4.58-2_armhf.deb ...
Unpacking libdrm2:armhf (2.4.58-2) ...
Selecting previously unselected package libfontembed1:armhf.
Preparing to unpack .../libfontembed1_1.0.61-5+deb8u2_armhf.deb ...
Unpacking libfontembed1:armhf (1.0.61-5+deb8u2) ...
Selecting previously unselected package libgdk-pixbuf2.0-common.
Preparing to unpack .../libgdk-pixbuf2.0-common_2.31.1-2+deb8u3_all.deb ...
Unpacking libgdk-pixbuf2.0-common (2.31.1-2+deb8u3) ...
Selecting previously unselected package libgdk-pixbuf2.0-0:armhf.
Preparing to unpack .../libgdk-pixbuf2.0-0_2.31.1-2+deb8u3_armhf.deb ...
Unpacking libgdk-pixbuf2.0-0:armhf (2.31.1-2+deb8u3) ...
Selecting previously unselected package libglapi-mesa:armhf.
Preparing to unpack .../libglapi-mesa_10.3.2-1+deb8u1_armhf.deb ...
Unpacking libglapi-mesa:armhf (10.3.2-1+deb8u1) ...
Selecting previously unselected package libx11-xcb1:armhf.
Preparing to unpack .../libx11-xcb1_2%3a1.6.2-3_armhf.deb ...
Unpacking libx11-xcb1:armhf (2:1.6.2-3) ...
Selecting previously unselected package libxcb-dri2-0:armhf.
Preparing to unpack .../libxcb-dri2-0_1.10-3+b1_armhf.deb ...
Unpacking libxcb-dri2-0:armhf (1.10-3+b1) ...
Selecting previously unselected package libxcb-dri3-0:armhf.
Preparing to unpack .../libxcb-dri3-0_1.10-3+b1_armhf.deb ...
Unpacking libxcb-dri3-0:armhf (1.10-3+b1) ...
Selecting previously unselected package libxcb-glx0:armhf.
Preparing to unpack .../libxcb-glx0_1.10-3+b1_armhf.deb ...
Unpacking libxcb-glx0:armhf (1.10-3+b1) ...
Selecting previously unselected package libxcb-present0:armhf.
Preparing to unpack .../libxcb-present0_1.10-3+b1_armhf.deb ...
Unpacking libxcb-present0:armhf (1.10-3+b1) ...
Selecting previously unselected package libxcb-sync1:armhf.
Preparing to unpack .../libxcb-sync1_1.10-3+b1_armhf.deb ...
Unpacking libxcb-sync1:armhf (1.10-3+b1) ...
Selecting previously unselected package libxfixes3:armhf.
Preparing to unpack .../libxfixes3_1%3a5.0.1-2+b2_armhf.deb ...
Unpacking libxfixes3:armhf (1:5.0.1-2+b2) ...
Selecting previously unselected package libxdamage1:armhf.
Preparing to unpack .../libxdamage1_1%3a1.1.4-2+b1_armhf.deb ...
Unpacking libxdamage1:armhf (1:1.1.4-2+b1) ...
Selecting previously unselected package libxshmfence1:armhf.
Preparing to unpack .../libxshmfence1_1.1-4_armhf.deb ...
Unpacking libxshmfence1:armhf (1.1-4) ...
Selecting previously unselected package libxxf86vm1:armhf.
Preparing to unpack .../libxxf86vm1_1%3a1.1.3-1+b1_armhf.deb ...
Unpacking libxxf86vm1:armhf (1:1.1.3-1+b1) ...
Selecting previously unselected package libgl1-mesa-glx:armhf.
Preparing to unpack .../libgl1-mesa-glx_10.3.2-1+deb8u1_armhf.deb ...
Unpacking libgl1-mesa-glx:armhf (10.3.2-1+deb8u1) ...
Selecting previously unselected package libglu1-mesa:armhf.
Preparing to unpack .../libglu1-mesa_9.0.0-2_armhf.deb ...
Unpacking libglu1-mesa:armhf (9.0.0-2) ...
Selecting previously unselected package libgtk2.0-common.
Preparing to unpack .../libgtk2.0-common_2.24.25-3_all.deb ...
Unpacking libgtk2.0-common (2.24.25-3) ...
Selecting previously unselected package libxcomposite1:armhf.
Preparing to unpack .../libxcomposite1_1%3a0.4.4-1_armhf.deb ...
Unpacking libxcomposite1:armhf (1:0.4.4-1) ...
Selecting previously unselected package libxcursor1:armhf.
Preparing to unpack .../libxcursor1_1%3a1.1.14-1+b1_armhf.deb ...
Unpacking libxcursor1:armhf (1:1.1.14-1+b1) ...
Selecting previously unselected package libxi6:armhf.
Preparing to unpack .../libxi6_2%3a1.7.4-1+b2_armhf.deb ...
Unpacking libxi6:armhf (2:1.7.4-1+b2) ...
Selecting previously unselected package libxinerama1:armhf.
Preparing to unpack .../libxinerama1_2%3a1.1.3-1+b1_armhf.deb ...
Unpacking libxinerama1:armhf (2:1.1.3-1+b1) ...
Selecting previously unselected package libxrandr2:armhf.
Preparing to unpack .../libxrandr2_2%3a1.4.2-1+b1_armhf.deb ...
Unpacking libxrandr2:armhf (2:1.4.2-1+b1) ...
Selecting previously unselected package shared-mime-info.
Preparing to unpack .../shared-mime-info_1.3-1_armhf.deb ...
Unpacking shared-mime-info (1.3-1) ...
Selecting previously unselected package libgtk2.0-0:armhf.
Preparing to unpack .../libgtk2.0-0_2.24.25-3_armhf.deb ...
Unpacking libgtk2.0-0:armhf (2.24.25-3) ...
Selecting previously unselected package libijs-0.35:armhf.
Preparing to unpack .../libijs-0.35_0.35-10_armhf.deb ...
Unpacking libijs-0.35:armhf (0.35-10) ...
Selecting previously unselected package libmng1:armhf.
Preparing to unpack .../libmng1_1.0.10+dfsg-3.1+b3_armhf.deb ...
Unpacking libmng1:armhf (1.0.10+dfsg-3.1+b3) ...
Selecting previously unselected package libxft2:armhf.
Preparing to unpack .../libxft2_2.3.2-1_armhf.deb ...
Unpacking libxft2:armhf (2.3.2-1) ...
Selecting previously unselected package libpangoxft-1.0-0:armhf.
Preparing to unpack .../libpangoxft-1.0-0_1.36.8-3_armhf.deb ...
Unpacking libpangoxft-1.0-0:armhf (1.36.8-3) ...
Selecting previously unselected package libpaper1:armhf.
Preparing to unpack .../libpaper1_1.1.24+nmu4_armhf.deb ...
Unpacking libpaper1:armhf (1.1.24+nmu4) ...
Selecting previously unselected package libopenjpeg5:armhf.
Preparing to unpack .../libopenjpeg5_1%3a1.5.2-3_armhf.deb ...
Unpacking libopenjpeg5:armhf (1:1.5.2-3) ...
Selecting previously unselected package libpoppler46:armhf.
Preparing to unpack .../libpoppler46_0.26.5-2_armhf.deb ...
Unpacking libpoppler46:armhf (0.26.5-2) ...
Selecting previously unselected package libqpdf13:armhf.
Preparing to unpack .../libqpdf13_5.1.2-2_armhf.deb ...
Unpacking libqpdf13:armhf (5.1.2-2) ...
Selecting previously unselected package qtcore4-l10n.
Preparing to unpack .../qtcore4-l10n_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_all.                                                      deb ...
Unpacking qtcore4-l10n (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqtcore4:armhf.
Preparing to unpack .../libqtcore4_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_armhf.                                                      deb ...
Unpacking libqtcore4:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqt4-xml:armhf.
Preparing to unpack .../libqt4-xml_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_armhf.                                                      deb ...
Unpacking libqt4-xml:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqtdbus4:armhf.
Preparing to unpack .../libqtdbus4_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_armhf.                                                      deb ...
Unpacking libqtdbus4:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqt4-network:armhf.
Preparing to unpack .../libqt4-network_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_ar                                                      mhf.deb ...
Unpacking libqt4-network:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqtgui4:armhf.
Preparing to unpack .../libqtgui4_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_armhf.d                                                      eb ...
Unpacking libqtgui4:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqt4-opengl:armhf.
Preparing to unpack .../libqt4-opengl_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_arm                                                      hf.deb ...
Unpacking libqt4-opengl:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqt4-sql:armhf.
Preparing to unpack .../libqt4-sql_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_armhf.                                                      deb ...
Unpacking libqt4-sql:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqt4-sql-sqlite:armhf.
Preparing to unpack .../libqt4-sql-sqlite_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1                                                      _armhf.deb ...
Unpacking libqt4-sql-sqlite:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqt4-svg:armhf.
Preparing to unpack .../libqt4-svg_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_armhf.                                                      deb ...
Unpacking libqt4-svg:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libxtst6:armhf.
Preparing to unpack .../libxtst6_2%3a1.2.2-1+b1_armhf.deb ...
Unpacking libxtst6:armhf (2:1.2.2-1+b1) ...
Selecting previously unselected package poppler-data.
Preparing to unpack .../poppler-data_0.4.7-1_all.deb ...
Unpacking poppler-data (0.4.7-1) ...
Selecting previously unselected package libpangox-1.0-0:armhf.
Preparing to unpack .../libpangox-1.0-0_0.0.2-5_armhf.deb ...
Unpacking libpangox-1.0-0:armhf (0.0.2-5) ...
Selecting previously unselected package poppler-utils.
Preparing to unpack .../poppler-utils_0.26.5-2_armhf.deb ...
Unpacking poppler-utils (0.26.5-2) ...
Selecting previously unselected package cups-filters-core-drivers.
Preparing to unpack .../cups-filters-core-drivers_1.0.61-5+deb8u2_armhf.deb ...
Unpacking cups-filters-core-drivers (1.0.61-5+deb8u2) ...
Selecting previously unselected package libjbig2dec0.
Preparing to unpack .../libjbig2dec0_0.11+20120125-1_armhf.deb ...
Unpacking libjbig2dec0 (0.11+20120125-1) ...
Selecting previously unselected package libgs9-common.
Preparing to unpack .../libgs9-common_9.06~dfsg-2+deb8u1_all.deb ...
Unpacking libgs9-common (9.06~dfsg-2+deb8u1) ...
Selecting previously unselected package libgs9.
Preparing to unpack .../libgs9_9.06~dfsg-2+deb8u1_armhf.deb ...
Unpacking libgs9 (9.06~dfsg-2+deb8u1) ...
Selecting previously unselected package gsfonts.
Preparing to unpack .../gsfonts_1%3a8.11+urwcyr1.0.7~pre44-4.2_all.deb ...
Unpacking gsfonts (1:8.11+urwcyr1.0.7~pre44-4.2) ...
Selecting previously unselected package ghostscript.
Preparing to unpack .../ghostscript_9.06~dfsg-2+deb8u1_armhf.deb ...
Unpacking ghostscript (9.06~dfsg-2+deb8u1) ...
Selecting previously unselected package cups-filters.
Preparing to unpack .../cups-filters_1.0.61-5+deb8u2_armhf.deb ...
Unpacking cups-filters (1.0.61-5+deb8u2) ...
Selecting previously unselected package libpod-plainer-perl.
Preparing to unpack .../libpod-plainer-perl_1.04-1_all.deb ...
Unpacking libpod-plainer-perl (1.04-1) ...
Selecting previously unselected package xdg-utils.
Preparing to unpack .../xdg-utils_1.1.0~rc1+git20111210-7.4_all.deb ...
Unpacking xdg-utils (1.1.0~rc1+git20111210-7.4) ...
Selecting previously unselected package libpango1.0-0:armhf.
Preparing to unpack .../libpango1.0-0_1.36.8-3_armhf.deb ...
Unpacking libpango1.0-0:armhf (1.36.8-3) ...
Selecting previously unselected package lsb-graphics.
Preparing to unpack .../lsb-graphics_4.1+Debian13+nmu1_armhf.deb ...
Unpacking lsb-graphics (4.1+Debian13+nmu1) ...
Selecting previously unselected package lsb-cxx.
Preparing to unpack .../lsb-cxx_4.1+Debian13+nmu1_armhf.deb ...
Unpacking lsb-cxx (4.1+Debian13+nmu1) ...
Selecting previously unselected package lsb-multimedia.
Preparing to unpack .../lsb-multimedia_4.1+Debian13+nmu1_armhf.deb ...
Unpacking lsb-multimedia (4.1+Debian13+nmu1) ...
Selecting previously unselected package lsb-desktop.
Preparing to unpack .../lsb-desktop_4.1+Debian13+nmu1_armhf.deb ...
Unpacking lsb-desktop (4.1+Debian13+nmu1) ...
Selecting previously unselected package lsb-printing.
Preparing to unpack .../lsb-printing_4.1+Debian13+nmu1_armhf.deb ...
Unpacking lsb-printing (4.1+Debian13+nmu1) ...
Selecting previously unselected package lsb-languages.
Preparing to unpack .../lsb-languages_4.1+Debian13+nmu1_armhf.deb ...
Unpacking lsb-languages (4.1+Debian13+nmu1) ...
Selecting previously unselected package lsb.
Preparing to unpack .../lsb_4.1+Debian13+nmu1_all.deb ...
Unpacking lsb (4.1+Debian13+nmu1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for systemd (215-17+deb8u2) ...
Processing triggers for fontconfig (2.11.0-6.3) ...
Setting up libatk1.0-data (2.14.0-1) ...
Setting up libatk1.0-0:armhf (2.14.0-1) ...
Setting up x11-common (1:7.7+7) ...
update-rc.d: warning: start and stop actions are no longer supported; falling ba                                                      ck to defaults
Setting up libice6:armhf (2:1.0.9-1+b1) ...
Setting up libsm6:armhf (2:1.2.2-1+b1) ...
Setting up libxt6:armhf (1:1.1.4-1+b1) ...
Setting up libaudio2:armhf (1.9.4-3) ...
Setting up libdrm2:armhf (2.4.58-2) ...
Setting up libfontembed1:armhf (1.0.61-5+deb8u2) ...
Setting up libgdk-pixbuf2.0-common (2.31.1-2+deb8u3) ...
Setting up libgdk-pixbuf2.0-0:armhf (2.31.1-2+deb8u3) ...
Setting up libglapi-mesa:armhf (10.3.2-1+deb8u1) ...
Setting up libx11-xcb1:armhf (2:1.6.2-3) ...
Setting up libxcb-dri2-0:armhf (1.10-3+b1) ...
Setting up libxcb-dri3-0:armhf (1.10-3+b1) ...
Setting up libxcb-glx0:armhf (1.10-3+b1) ...
Setting up libxcb-present0:armhf (1.10-3+b1) ...
Setting up libxcb-sync1:armhf (1.10-3+b1) ...
Setting up libxfixes3:armhf (1:5.0.1-2+b2) ...
Setting up libxdamage1:armhf (1:1.1.4-2+b1) ...
Setting up libxshmfence1:armhf (1.1-4) ...
Setting up libxxf86vm1:armhf (1:1.1.3-1+b1) ...
Setting up libgl1-mesa-glx:armhf (10.3.2-1+deb8u1) ...
Setting up libglu1-mesa:armhf (9.0.0-2) ...
Setting up libgtk2.0-common (2.24.25-3) ...
Setting up libxcomposite1:armhf (1:0.4.4-1) ...
Setting up libxcursor1:armhf (1:1.1.14-1+b1) ...
Setting up libxi6:armhf (2:1.7.4-1+b2) ...
Setting up libxinerama1:armhf (2:1.1.3-1+b1) ...
Setting up libxrandr2:armhf (2:1.4.2-1+b1) ...
Setting up shared-mime-info (1.3-1) ...
Setting up libgtk2.0-0:armhf (2.24.25-3) ...
Setting up libijs-0.35:armhf (0.35-10) ...
Setting up libmng1:armhf (1.0.10+dfsg-3.1+b3) ...
Setting up libxft2:armhf (2.3.2-1) ...
Setting up libpangoxft-1.0-0:armhf (1.36.8-3) ...
Setting up libpaper1:armhf (1.1.24+nmu4) ...

Creating config file /etc/papersize with new version
Setting up libopenjpeg5:armhf (1:1.5.2-3) ...
Setting up libpoppler46:armhf (0.26.5-2) ...
Setting up libqpdf13:armhf (5.1.2-2) ...
Setting up qtcore4-l10n (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqtcore4:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqt4-xml:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqtdbus4:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqt4-network:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqtgui4:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqt4-opengl:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqt4-sql:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqt4-sql-sqlite:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqt4-svg:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libxtst6:armhf (2:1.2.2-1+b1) ...
Setting up poppler-data (0.4.7-1) ...
Setting up libpangox-1.0-0:armhf (0.0.2-5) ...
Setting up poppler-utils (0.26.5-2) ...
Setting up cups-filters-core-drivers (1.0.61-5+deb8u2) ...
Setting up libjbig2dec0 (0.11+20120125-1) ...
Setting up libgs9-common (9.06~dfsg-2+deb8u1) ...
Setting up libgs9 (9.06~dfsg-2+deb8u1) ...
Setting up gsfonts (1:8.11+urwcyr1.0.7~pre44-4.2) ...
Setting up ghostscript (9.06~dfsg-2+deb8u1) ...
Setting up cups-filters (1.0.61-5+deb8u2) ...
Setting up libpod-plainer-perl (1.04-1) ...
Setting up xdg-utils (1.1.0~rc1+git20111210-7.4) ...
Setting up libpango1.0-0:armhf (1.36.8-3) ...
Setting up lsb-graphics (4.1+Debian13+nmu1) ...
Setting up lsb-cxx (4.1+Debian13+nmu1) ...
Setting up lsb-multimedia (4.1+Debian13+nmu1) ...
Setting up lsb-desktop (4.1+Debian13+nmu1) ...
Setting up lsb-printing (4.1+Debian13+nmu1) ...
Setting up lsb-languages (4.1+Debian13+nmu1) ...
Setting up lsb (4.1+Debian13+nmu1) ...
Processing triggers for libc-bin (2.19-18+deb8u1) ...
Processing triggers for systemd (215-17+deb8u2) ...
[email protected]:~$ wget https://secure.logmein.com/labs/logmein-hamachi_2.1.0.139-1_ar                                                      mhf.deb
converted 'https://secure.logmein.com/labs/logmein-hamachi_2.1.0.139-1_armhf.deb                                                      ' (ANSI_X3.4-1968) -> 'https://secure.logmein.com/labs/logmein-hamachi_2.1.0.139                                                      -1_armhf.deb' (UTF-8)
--2015-12-14 21:56:29--  https://secure.logmein.com/labs/logmein-hamachi_2.1.0.1                                                      39-1_armhf.deb
Resolving secure.logmein.com (secure.logmein.com)... 77.242.192.193
Connecting to secure.logmein.com (secure.logmein.com)|77.242.192.193|:443... con                                                      nected.
HTTP request sent, awaiting response... 200 OK
Length: 1480310 (1.4M) [application/x-debian-package]
Saving to: 'logmein-hamachi_2.1.0.139-1_armhf.deb'

logmein-hamachi_2.1 100%[=====================>]   1.41M   104KB/s   in 14s

2015-12-14 21:56:43 (105 KB/s) - 'logmein-hamachi_2.1.0.139-1_armhf.deb' saved [                                                      1480310/1480310]

[email protected]:~$  sudo dpkg -i logmein-hamachi_2.1.0.139-1_armhf.deb
(Reading database ... 37983 files and directories currently installed.)
Preparing to unpack logmein-hamachi_2.1.0.139-1_armhf.deb ...
[ ok ] Stopping logmein-hamachi (via systemctl): logmein-hamachi.service.
Traceback (most recent call last):
  File "/usr/lib/lsb/remove_initd", line 18, in <module>
    headers = initdutils.scan_initfile(initfile)
  File "/usr/lib/lsb/initdutils.py", line 79, in scan_initfile
    inheaders = RFC822Parser(strob=headerlines)
  File "/usr/lib/lsb/initdutils.py", line 24, in __init__
    fileob = StringIO(strob)
TypeError: initial_value must be unicode or None, not str
Unpacking logmein-hamachi (2.1.0.139-1) over (2.1.0.139-1) ...
Setting up logmein-hamachi (2.1.0.139-1) ...
mknod: '/dev/net/tun': File exists
Traceback (most recent call last):
  File "/usr/lib/lsb/install_initd", line 46, in <module>
    headers = initdutils.scan_initfile(initfile)
  File "/usr/lib/lsb/initdutils.py", line 79, in scan_initfile
    inheaders = RFC822Parser(strob=headerlines)
  File "/usr/lib/lsb/initdutils.py", line 24, in __init__
    fileob = StringIO(strob)
TypeError: initial_value must be unicode or None, not str
[ ok ] Starting logmein-hamachi (via systemctl): logmein-hamachi.service.
Processing triggers for systemd (215-17+deb8u2) ...
[email protected]:~$ sudo hamachi login
sudo: unable to execute /usr/bin/hamachi: No such file or directory
[email protected]:~$ /etc/init.d/logmein-hamachi start
[....] Starting logmein-hamachi (via systemctl): logmein-hamachi.serviceFailed to start logmein-hamachi.service: Access den           ied
 failed!
[email protected]:~$ hamachi login
-bash: /usr/bin/hamachi: No such file or directory
[email protected]:~$
[/code]

fruitoftheloom
Posts: 20167
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Setup Logmein Hamachi for SSH access behind firewalls, e

Mon Dec 14, 2015 10:19 pm

caporeira wrote:Hi,
I need yours help. I instaled hamachi, but I can't start it :(

What i'm doing wrong ?
I have Rpi2 and OSMC as system.
OSMC does not use Raspbian as a base distribution and therefore the instructions in this thread may well be different, hence your issues :?:

OSMC has a Forum for their Operating System https://discourse.osmc.tv
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

SeelenWolf
Posts: 1
Joined: Tue Jun 07, 2016 3:27 pm

Re: Setup Logmein Hamachi for SSH access behind firewalls, e

Tue Jun 07, 2016 3:35 pm

I installed Hamachi, but whenever I try to do

Code: Select all

hamachi login
it tells me hamachi has to be started first with

Code: Select all

/etc/init.d/logmein-hamachi start
If I type that command I get following error:

Code: Select all

[....] Starting logmein-hamachi (via systemctl): logmein-hamachi.serviceFailed to start logmein-hamachi.service: Access denied
 failed!
I don't know what to do about this, any solutions?

User avatar
IgorGanapolsky
Posts: 33
Joined: Sun Apr 10, 2016 8:32 pm

Re: Setup Logmein Hamachi for SSH access behind firewalls, e

Sun Aug 07, 2016 10:37 pm

Blunderbuss wrote:*Disclaimer* I only just figured out how to do this, but it seems handy so I"m sharing the method. If  you don"t understand anything, post and I"ll attempt to clarify.

If you don"t pay for a static IP address, or find yourself behind firewalls that you can"t control, this method will allow you to access SSH on your Raspberry Pi by installing client-side software to connect to a logmein hamachi network.

First, create a logmein.com account if you haven"t already, and from there, create a network (on the left).

Next, download the logmein hamachi client software for your remote machine (laptop, work machine, what have you) and connect that to your hamachi network.

Then, download the beta logmein hamachi .deb file. This is done via the command line easily enough with:

$ sudo wget https://secure.logmein.com/labs/logmein ... _armel.deb

you may need to add a flag at the end of that line to disregard authentication, just check the terminal for anything it"s telling you to do and do it, such that you can download the file.

Install logmein-hamachi by running:

$ sudo dpkg -i logmein-hamachi_2.1.0.18-1_armel.deb

All interaction with this software is now done by running commands of the form:

$ sudo hamachi XX

Try running: "$ sudo hamachi -h" to see a list of the commands available to you.

Here"s what you want to run:

$ sudo hamachi login

$ sudo hamachi attach <INSERT YOUR LOGMEIN.COM EMAIL HERE>

$ sudo hamachi set-nick "pick something creative….perhaps RPI?"

At this point, take a break to go back to your logmein.com web account, which should now show that a raspberrypi device is attempting to access it (assuming you set it up that way, i.e. the default way). Grant it permission and while you"re there, write down the network ID for your newly created hamachi network. It should be something like 123-456-789.

Back on the RPi, run:

$ sudo hamachi do-join <the ID that you just wrote down>

You will then likely need to head back to that other machine and approve the request. Now when you launch your remote machines logmein hamachi software, you will see that the raspberrypi has been associated with an IP address that begins with a 5. Before you can SSH into it, go back to the pi one last time and run:

$ sudo /etc/int.d/ssh start

That will start the ssh server service, and allow you to control the RPi terminal remotely.

Back on your host machine, open up your favorite SSH program (putty on the PC, terminal on the mac) and run ssh <a href="mailto:[email protected]@<insert the IP that the raspberrypi is showing in your hamachi software> NOTE: the user pi is for the latest debian release, so adjust accordingly.

Type in your password and voila! You can access the SSH server of your RPi from behind any firewall, provided that you install logmeins hamachi software from the machine you want to use to access the RPi.
Unfortunately Logmein is not a free service anymore. Not sure how many folks with Raspberry Pi are willing to pay for it.

trnt
Posts: 36
Joined: Fri Oct 20, 2017 10:56 am

Re: Setup Logmein Hamachi for SSH access behind firewalls, e

Sat Dec 09, 2017 8:38 am

tomhannen wrote:
Mon May 14, 2012 8:40 pm
Hmm.. I can't install hamachi. I get the following error:

Code: Select all

 logmein-hamachi depends on lsb-core (>= 3.0); however:
  Package lsb-core is not installed.
So I googled around a bit, and tried installing:

Code: Select all

sudo apt-get install lsb-core
sudo apt-get -f install lsb-core
but it didn't work :

Code: Select all

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
[email protected]:~$ sudo dpkg --install logmein-hamachi_2.1.0.18-1_armel.deb 
(Reading database ... 46703 files and directories currently installed.)
Preparing to replace logmein-hamachi 2.1.0.18-1 (using logmein-hamachi_2.1.0.18-1_armel.deb) ...
Unpacking replacement logmein-hamachi ...
dpkg: dependency problems prevent configuration of logmein-hamachi:
 logmein-hamachi depends on lsb-core (>= 3.0); however:
  Package lsb-core is not installed.
dpkg: error processing logmein-hamachi (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 logmein-hamachi
[email protected]:~$ sudo apt-get -f install lsb-core
Similar Tutorial:

https://www.jgomez.net/install-hamachi- ... -raspbian/

Return to “Beginners”