cyborg5
Posts: 3
Joined: Tue Apr 30, 2013 6:16 pm

lxsession not working

Tue Apr 30, 2013 6:31 pm

I have been using the Adafruit "Occidentalis v0.2" distribution on my Raspberry Pi however I wanted to learn more about it plain-vanilla system so I got another SD card and I successfully loaded the most recent 2013-02-09-wheezy-raspbian image. Using keyboard and mouse I got through the configuration and setup my wireless successfully. I can connect using to the Raspberry Pi from my Windows 7 PC using ssh via MobaXterm. I get a login prompt and I can login successfully. All of that's working the way it used to under the Adafruit version. My problem is lxsession isn't working the same. Under Adafruit I can simply type "lxsession" and it would launch a graphic window on my PC. However when I type that same command under the plain-vanilla wheezy raspbian I get the message

Code: Select all

connect /tmp/.X11-unix/X0: No such file or directory
If I type in "startx" it starts the graphical desktop on the TV I have connected via the RCA plug. I want the graphical interface to show up on my PC like it did under Adafruit.

My guess is that that other distribution has some sort of alias that lets you type lxsession on the RPi side to start up the X session but I have no idea what should be in that command or how to create an alias. I'm a complete novice at Linux. I tried some Google searches and they all talk about how to autostart lxsession or how to get lxsession to autostart something else. I don't care about any of that right now. I just want to get lxsession running.

cyborg5
Posts: 3
Joined: Tue Apr 30, 2013 6:16 pm

Re: lxsession not working

Tue Apr 30, 2013 10:45 pm

Sorry to bother everyone. I didn't have my X session window open on MobaXterm on the Windows PC. It opens automatically when I start Xterm but I usually close it while I'm using the command line. It used to be on the other distribution when I would do "lxsession" it would automatically reopen. Anyway as long as I keep the window open on my end I have no problem going to lxsession after all. I do get warning messages that I don't know if at all are important.

Code: Select all

Obt-Message: Xinerama extension is not present on the server
Do I need to worry about this message? What does it mean?

Return to “Beginners”