Page 1 of 1

Removing wallpaper

Posted: Sat Mar 09, 2013 12:43 pm
by ianphil397
I want to remove the desktop background and just have a blank screen, the Desktop Preferences menu lets me pick a new wall paper but doesn't allow me remove one.

How can I do this?


Re: Removing wallpaper

Posted: Sat Mar 09, 2013 3:14 pm
by malakai
I have just tried this but the setting is here

Code: Select all

sudo nano /home/pi/.config/pcmanfm/LXDE/pcmanfm.conf
I tested this over ssh and it seemed to work.

Comment out this line

Code: Select all


This option might do it but not sure the settings seem to be (color|stretch|fit|center|tile) the default value is 3 so I think that is fit not sure if a 0 or 1 would enable color.

Code: Select all


Re: Removing wallpaper

Posted: Sat Mar 09, 2013 10:49 pm
by samuelt619
Right-click your desktop and select "Desktop Preferences"

From there, you'll see which background you already have selected.

Select your desired color under "Background colour:"

Then, directly underneath it, you'll see "Wallpaper mode:"

Click the drop down box, then select "Fill with background colour only"

Ta-Da! :D

Re: Removing wallpaper

Posted: Fri Apr 24, 2015 4:00 pm
by OttovanZanten
Sorry to bring up such an old topic, but that setting has removed.
And the setting in the .conf file isn't there anymore either :(

(Yes I did go to LXDE-pi instead of LXDE and I did find the .conf file, but the specified line isn't in there.)

So does anybody know how to do it in the current Raspbian build?

(Also does somebody know what the last line in the .conf file is supposed to be? Accidentally deleted it)
(Nvm, deleting it and rebooting worked.)

Re: Removing wallpaper

Posted: Fri Apr 24, 2015 4:45 pm
by JimmyN
It's still there, but not showing up because it's using the Window Manager menu. Here's how to get it back.

Open LXTerminal and type in

Code: Select all

pcmanfm --desktop-pref
A menu box will pop up. Click on the 'Advanced' tab and remove the check from "Show menus provided by window managers......". Close that and right click on the desktop and your 'Desktop Preferences' will be back.

Re: Removing wallpaper

Posted: Mon Apr 27, 2015 2:47 pm
by OttovanZanten
Appreciate the reply but that's not what I meant.

The settings mentioned in earlier posts (the setting in the .conf file and the ' Fill with Background Color Only' setting)
don't exist in the current build of Raspbian.

I was able to get to the background settings without having to uncheck that box. Because the box you mentioned is unchecked by default. So that wasn't the problem.
The problem was finding that specific setting that lets me delete that Raspberry background and just use a plain black background.

So does anybody know if that setting still exist? Or are we forced to have a Raspberry Logo? I assume not as that seems a bit un-Linux :P

Re: Removing wallpaper

Posted: Mon Apr 27, 2015 3:05 pm
by JimmyN
It works for me, I just tried it again and I'm running "Linux rpi 3.18.7+ #755"

Open Desktop Preferences
Click on the "Appearance" tab
Click the dropdown menu for "wallpaper mode:".
Select "Fill with background color only".
The raspberry instantly disappears.

Re: Removing wallpaper

Posted: Mon Apr 27, 2015 3:40 pm
by beta-tester
you also can try to uninstall the raspberry pi artwork to get rid of the raspberry pi logo on the desktop:

Code: Select all

sudo apt-get -y --auto-remove purge raspberrypi-artwork

Re: Removing wallpaper

Posted: Mon Apr 27, 2015 5:04 pm
by OttovanZanten
I've checked that same Wallpaper mode dropdown menu at least 5 times before and it wasn't there.

But in the meantime I've reinstalled Raspbian twice and now the option is there. Everything was being buggy as hell and I guess that was just one more bug.

Thanks guys!