xio15
Posts: 30
Joined: Fri Aug 21, 2020 4:52 pm

RealVNC can't handle special characters in Raspbian passwords

Wed Aug 26, 2020 1:42 am

In case it helps others, RealVNC doesn't like special characters in Raspbian passwords. It complains that the user ID or password is wrong. After several hours of scratching my head, I removed any special characters from the password and it just worked. It doesn't inspire confidence in the security standards I must say.

User avatar
DougieLawson
Posts: 40138
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: RealVNC can't handle special characters in Raspbian passwords

Wed Aug 26, 2020 7:56 pm

So you should report your problem to the RealVNC folks at: https://help.realvnc.com/hc/en-us
Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

xio15
Posts: 30
Joined: Fri Aug 21, 2020 4:52 pm

Re: RealVNC can't handle special characters in Raspbian passwords

Wed Aug 26, 2020 11:54 pm

I just reported the problem but I will be even more shocked if they don't know about it. At least the report here may save someone a few hours of head-scratching.

pfletch101
Posts: 630
Joined: Sat Feb 24, 2018 4:09 am
Location: Buffalo, NY, USA

Re: RealVNC can't handle special characters in Raspbian passwords

Sat Aug 29, 2020 10:37 pm

xio15 wrote:
Wed Aug 26, 2020 1:42 am
In case it helps others, RealVNC doesn't like special characters in Raspbian passwords. It complains that the user ID or password is wrong. After several hours of scratching my head, I removed any special characters from the password and it just worked. It doesn't inspire confidence in the security standards I must say.
I think that you are mistaken. I use RealVNC with all my (3) Pi 3Bs and have used it with my 4B4 (I am currently running the 64 bit beta on the latter, so I have switched it to TightVNC). All my passwords contain one or more special characters, and I have had no problems. Either you are using a specific special character that it doesn't like, or something else is going on.

xio15
Posts: 30
Joined: Fri Aug 21, 2020 4:52 pm

Re: RealVNC can't handle special characters in Raspbian passwords

Sun Aug 30, 2020 12:09 am

Either you are using a specific special character that it doesn't like, or something else is going on.
On further investigation I agree it must be a specific special character. I changed the password again to include different special characters, and it worked. I didn't go as far as to try to find which characters caused the problem earlier. What I know is that after hours of trying to login I replaced the password with one of equal length but without special characters and it worked immediately.

Seeking Sooth
Posts: 78
Joined: Sun Aug 23, 2020 7:03 pm

Re: RealVNC can't handle special characters in Raspbian passwords

Sun Aug 30, 2020 5:33 pm

What keyboard are you using? What were the special characters it didn't like?

:) Presumably, they're not in your password.

xio15
Posts: 30
Joined: Fri Aug 21, 2020 4:52 pm

Re: RealVNC can't handle special characters in Raspbian passwords

Sun Aug 30, 2020 6:00 pm

Seeking Sooth wrote: What keyboard are you using? What were the special characters it didn't like?
Using a UK keyboard. The characters I removed are ! and %. It must be at least one of them but I haven't double-checked.
:) Presumably, they're not in your password.
Now people know these characters are not in my password and they can optimise their scripts. :)

pfletch101
Posts: 630
Joined: Sat Feb 24, 2018 4:09 am
Location: Buffalo, NY, USA

Re: RealVNC can't handle special characters in Raspbian passwords

Sun Aug 30, 2020 7:15 pm

xio15 wrote:
Sun Aug 30, 2020 6:00 pm
Seeking Sooth wrote: What keyboard are you using? What were the special characters it didn't like?
Using a UK keyboard. The characters I removed are ! and %. It must be at least one of them but I haven't double-checked.
:) Presumably, they're not in your password.
Now people know these characters are not in my password and they can optimise their scripts. :)
Then there is something else going on. I have used both of these characters (separately or in the same password) in at least one current and/or previous password with RealVNC without problems

Return to “Beginners”