tobi89
Posts: 2
Joined: Mon Jul 06, 2020 8:49 pm

Older gimp on rpi4

Mon Jul 06, 2020 9:05 pm

Hello.
Is there some easy way to istall older version of gimp (2.8.22) on new raspbian on raspberry pi?

I have some some scripts for automatic image manipulation, but they don't work with the 2.10 which is in the depository.
I tried to compile it from the source, but didn't managed to do it (never done it before though).

PS: Sorry if posted in the wrong section, didn't find any better suited.

User avatar
B.Goode
Posts: 10356
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Older gimp on rpi4

Tue Jul 07, 2020 12:15 pm

Welcome to the Raspberry Pi forums.
tobi89 wrote:
Mon Jul 06, 2020 9:05 pm
Hello.
Is there some easy way to istall older version of gimp (2.8.22) on new raspbian on raspberry pi?

I have some some scripts for automatic image manipulation, but they don't work with the 2.10 which is in the depository.
I tried to compile it from the source, but didn't managed to do it (never done it before though).

PS: Sorry if posted in the wrong section, didn't find any better suited.

I can't answer your question directly. If you have trouble building this package from its source code perhaps the Mailing List for GIMP itself would be a more appropriate source for advice? https://www.gimp.org/mail_lists.html

As an alternative approach, have you considered updating the scripts to be compatible with the current supported version of GIMP, in preference to making yourself dependent on a version of a package that has been superceded by its developers? Again, the dedicated mailing list might be better informed on this subject.

User avatar
scruss
Posts: 3237
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: Older gimp on rpi4

Tue Jul 07, 2020 12:42 pm

B.Goode wrote:
Tue Jul 07, 2020 12:15 pm
As an alternative approach, have you considered updating the scripts to be compatible with the current supported version of GIMP …
The internal changes from 2.8 to 2.10 were huge. Most scripts would need to be entirely rewritten. A lot of the old scripts I used to rely on have gone away completely. So this isn't a small matter of maintenance.

The good thing about build an older version on a newer Raspberry Pi 4 is that the capabilities will be about matched: the code won't be painfully slow, and the build process might be manageable.
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.
Pronouns: he/him

User avatar
B.Goode
Posts: 10356
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Older gimp on rpi4

Tue Jul 07, 2020 12:47 pm

scruss wrote:
Tue Jul 07, 2020 12:42 pm
B.Goode wrote:
Tue Jul 07, 2020 12:15 pm
As an alternative approach, have you considered updating the scripts to be compatible with the current supported version of GIMP …
The internal changes from 2.8 to 2.10 were huge. Most scripts would need to be entirely rewritten. A lot of the old scripts I used to rely on have gone away completely. So this isn't a small matter of maintenance.

The good thing about build an older version on a newer Raspberry Pi 4 is that the capabilities will be about matched: the code won't be painfully slow, and the build process might be manageable.


Happy to hear an alternative view supported by experience. Still leaves the substantive question of how to get the old version onto the RPi.

tobi89
Posts: 2
Joined: Mon Jul 06, 2020 8:49 pm

Re: Older gimp on rpi4

Wed Jul 15, 2020 10:13 pm

Hi,
after some unsuccessful tries with compiling older gimp I've decided to install older distro instead. It wasn't as easy as I thought it would be. Older raspbians didn't work, so I tried Ubuntu mate 18.04 for pi, which should be supported, but that also didn't run on my pi 4. So I ended up with installing server version of ubuntu 18.04, than adding xubuntu desktop on it. But it is finally working! Gimp 2.8 is running on my pi 4 :-)

Return to “Beginners”