Page 1 of 1

Problem with USB Hub on a Pi Zero

Posted: Sat Mar 14, 2020 11:54 am
by DeeZii
Hello everyone

I recently bought a USB hub for my Pi Zero and the Pi Zero restart each time when I plug a keyboard or a mouse. And it didn’t recognize it and today I’m asking you if someone had this problem with this hub and most important have the solution to get it working.

I bought it on Amazon. There is the link to the product.

https://www.amazon.fr/gp/product/B07TBK ... UTF8&psc=1

So, let me know if someone had this problem or if I need an other HUB that is compatible with the Pi !

PS : Sorry for my English ! 😉

Re: Problem with USB Hub on a Pi Zero

Posted: Sat Mar 14, 2020 1:14 pm
by PhatFil
its a known issue.. viewtopic.php?t=189921

as for the hub to use to avoid the problem? No Offence intended.. You will probably have the best results using a branded hub that conforms to standards rather than a cheaper unbranded option

Re: Problem with USB Hub on a Pi Zero

Posted: Sat Mar 14, 2020 3:57 pm
by DeeZii
Thanks for the answer I will try if it dose not work I will buy a branded one

Re: Problem with USB Hub on a Pi Zero

Posted: Sat Mar 14, 2020 4:26 pm
by ejolson
DeeZii wrote: ↑
Sat Mar 14, 2020 3:57 pm
Thanks for the answer I will try if it dose not work I will buy a branded one
Is the recommended solution a powered hub or a better supply for the Zero?

Re: Problem with USB Hub on a Pi Zero

Posted: Sat Mar 14, 2020 4:37 pm
by alphanumeric
I'm currently using this very similar hub with My Pi Zero's with no issues. No reboots when pluging and unpluging USB devices from the Hub. Plugging the Hub in after the Pi boots up will likely make it reboot though. I just make sure its plugged in before powering up.
https://shop.pimoroni.com/products/thre ... -connector

Re: Problem with USB Hub on a Pi Zero

Posted: Sun Mar 15, 2020 10:04 am
by DeeZii
alphanumeric wrote: ↑
Sat Mar 14, 2020 4:37 pm
I'm currently using this very similar hub with My Pi Zero's with no issues. No reboots when pluging and unpluging USB devices from the Hub. Plugging the Hub in after the Pi boots up will likely make it reboot though. I just make sure its plugged in before powering up.
https://shop.pimoroni.com/products/thre ... -connector
Well I will order this one then to try, if it will not work I will have to keep using my wireless keyboard and mouse in one ! x)

Re: Problem with USB Hub on a Pi Zero

Posted: Sun Mar 15, 2020 9:44 pm
by Imperf3kt
ejolson wrote: ↑
Sat Mar 14, 2020 4:26 pm
DeeZii wrote: ↑
Sat Mar 14, 2020 3:57 pm
Thanks for the answer I will try if it dose not work I will buy a branded one
Is the recommended solution a powered hub or a better supply for the Zero?
The recommended solution is to not hot plug usb devices on a Pi Zero (or A model)

Plug in everything you need, before you boot.