User avatar
JoseKreif
Posts: 7
Joined: Sun Feb 09, 2020 6:36 pm
Contact: Website

Permission Denied - Deleting Files From Attached Phone

Fri Feb 14, 2020 12:47 am

I've attached my smartphone, and browsing in the mounted directory for it. I'm trying to delete files from the Downloads on the phone through the Pi terminal. I've tried sudo, but get permission denied.

The files are owned by pi:pi, and have a permission of 600. I've tried to add X to see if that would allow me to delete, but I can't do that either.

I was going to assume it was a permission problem with the phone, but if I plug this into a Windows PC, I'd be able to Delete/Add all I wanted with no admin/root.

The Pi has mounted this folder in /run/user/1000/gvfs/

/run owned by root:root with drwxr-xr-x
/run/user own by root:root with drwxr-xr-x
/run/user/1000 owned by pi:pi with drwx------
/run/user/1000/gvfs/ owned by pi:pi with dr-x------

I cannot add w to gvfs. Permission denied.

I'm assuming gvfs is the problem. Using lsusb, I can see my phone at Bus 001 Device 008. However, I cannot mount it. (I'm not very knowledgeable with removable media on Linux)

Code: Select all

[email protected]:~ $ sudo mount /dev/bus/usb/001/008 /mnt/phone
mount: /mnt/phone: /dev/bus/usb/001/008 is not a block device.
Any advice?

Return to “Beginners”