mayburyds
Posts: 17
Joined: Wed Sep 05, 2012 7:06 pm

Disable CEC

Thu Dec 20, 2012 2:34 pm

Hi,

How can I turn off CEC in Wheezy?

Thanks.

efflandt
Posts: 359
Joined: Mon Dec 03, 2012 2:47 am
Location: Elgin, IL USA

Re: Disable CEC

Fri Dec 21, 2012 9:40 am

http://elinux.org/RPiconfig

Add hdmi_ignore_cec=1 to /boot/config.txt

I thought CEC doesn't do anything anyway unless running something like XBMC. But I have both a Pi and Ubuntu Linux on my desktop PC connected to my HDTV, so the Pi does not actually turn my TV on/off. And the only time my Pi pays any attention to my TV remote is when running Raspbmc.

mayburyds
Posts: 17
Joined: Wed Sep 05, 2012 7:06 pm

Re: Disable CEC

Fri Dec 21, 2012 9:53 am

Hi,

Thanks for the reply.

I have tried that command in the config file but it didn't make any difference. I'll give it another go in case I made a mistake.

If I boot my RPI it will turn the TV (Samsung) on.

The reason I want to turn CEC off is that the RPI is connected to my AV amp and when I turn that on with the RPI active it will switch to the RPI output regardless of what else is running through the amp.

It's no major problem just thought if there was an easy way of turning it off CEC I'd give it ago.

Cheers.

User avatar
RaTTuS
Posts: 10601
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Disable CEC

Fri Dec 21, 2012 10:10 am

leave the RPi powered up - ;-p
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

mayburyds
Posts: 17
Joined: Wed Sep 05, 2012 7:06 pm

Re: Disable CEC

Fri Dec 21, 2012 2:49 pm

Hi,

Just retried the hdmi_ignore_cec=1 command in config.txt and that has done the trick! Must have made a mistake previously.

Thanks efflandt.

Cheers.

Return to “Beginners”