User avatar
RDK
Posts: 303
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

No wifi connection with Raspbian-Buster on PiV4

Wed Jan 22, 2020 2:21 pm

Can I assume that a Pi V4 with BUSTER (Sept 2019) will not connect to a router running WEP "security"?

I just checked with an older install of Buster (fully undated) on a PiV3 and WEP does work for that unit. Does that make a difference or are there extra steps for WEP on a PiV4? The wpa_supplicant.conf files are the same on both units....

Is there any work around? I'm at a location where they are not using something more secure and they do not want to change....RDK

User avatar
DougieLawson
Posts: 38853
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: No wifi connection with Raspbian-Buster on PiV4

Wed Jan 22, 2020 9:58 pm

Get them to disable security completely - turn it into an open network, because that's functionally equivalent to a network with WEP.

You can encourage wpa_supplicant to connect to WEP, but you can't do that with the taskbar widget.

https://www.raspberrypi.org/forums/view ... hp?t=88644
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

User avatar
RDK
Posts: 303
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

Re: No wifi connection with Raspbian-Buster on PiV4

Wed Jan 22, 2020 11:57 pm

Thanks Dougie, but it still does not connect. Here is my wpa_supplicant.conf, which is what was recommended in your link.

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
        ssid="Rosetown"
        key_mgmt=NONE
        wep_key0=911A0F4BC6
        web_tx_keyidx=0
}
At the risk of repeating myself, could this have something to do with the PiV4's?....RDK

User avatar
DougieLawson
Posts: 38853
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: No wifi connection with Raspbian-Buster on PiV4

Thu Jan 23, 2020 8:51 am

The WiFi software stuff should be identical.

I can't test this for three reasons
1. I don't have a RPi4B
2. I won't have a router/AP with WEP because my network security matters to me
3. Today, I've got no internets due to a BT/Openreach/Plusnet fault (so I'm currently tethered to my mobile phone)
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

User avatar
RDK
Posts: 303
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

Re: No wifi connection with Raspbian-Buster on PiV4

Mon Jan 27, 2020 10:08 pm

I'm not having a lot of luck with Buster on PiV4B and WiFi!!!

I just tried to connect to a "good" WPA secure router with my Pi V4B Buster configuration. Running

Code: Select all

 raspi-config 
for WiFi I get the following error message:
Could not communicate with wpa_supplicant
and then to exit

Code: Select all

raspi-config
I also get this one:
There was an error running option N2 Wi-fi
I just rebuilt a PiV3B+ with Buster and had no problems connecting. Any ideas?....RDK

ps....wired connections work just fine.

MrEngman
Posts: 4022
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: No wifi connection with Raspbian-Buster on PiV4

Mon Jan 27, 2020 10:34 pm

RDK wrote:
Wed Jan 22, 2020 11:57 pm
Thanks Dougie, but it still does not connect. Here is my wpa_supplicant.conf, which is what was recommended in your link.

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
        ssid="Rosetown"
        key_mgmt=NONE
        wep_key0=911A0F4BC6
        web_tx_keyidx=0
}
At the risk of repeating myself, could this have something to do with the PiV4's?....RDK
Is this a typo or what is actually in your file web_tx_keyidx=0. It should be

Code: Select all

        wep_tx_keyidx=0

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

User avatar
RDK
Posts: 303
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

Re: No wifi connection with Raspbian-Buster on PiV4

Mon Jan 27, 2020 10:47 pm

Good eyes!! TYPO in file. I will fix it and try again. Thanks....RDK

Regarding my last post (different Pi V4) about
Could not communicate with wpa_supplicant
. I did an apt update and upgrade and rebooted several times and now noticed that wifi is connecting. Go figure....RDK

User avatar
RDK
Posts: 303
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

Re: No wifi connection with Raspbian-Buster on PiV4

Mon Jan 27, 2020 11:44 pm

Correcting my spelling did t he trick. Thanks....RDK

Return to “Beginners”