Ynursttow
Posts: 1
Joined: Tue Aug 27, 2019 3:56 am
Location: Clifton, NJ
Contact: Website

Problems running Kodi Leia on Raspberry Pi 2 (LE 9.0.2)

Tue Aug 27, 2019 6:34 am

Kodi Leia runs poorly compared to Krypton on my Raspberry Pi 2. Specifically it appears to run sluggishly when playing live TV using nextPVR. I've encountered the following problems with LE 9.0.2 (Kodi Leia 18.2):

The initial problem I encountered was the screen going black when changing channels. I resolved this issue by getting rid of all overclocking code in my config.txt file.
The next problem I encountered was the video skipping frames in order to maintain sync. I partially resolved this issue, but not to my satisfaction, by turning off de-interlacing under video settings.
Another problem I encountered was the audio being out of sync with the video. This problem is intermittent and I have not found a permanent solution to the issue.
When changing channels, the screen will freeze or go black for a good 8 seconds while the audio is playing and then suddenly jump to the video syncing with the audio.
Finally I my system would crash whenever I attempted to perform time shifting. This turned out to be an issue with a setting in the nextPVR add-on.
I've used two different methodologies to create my system files:

(1) Clean install of LE version 9.02 using LE USB-SD Creator. After an initial setup, I restored from a backup created by the current version of LE 8.2.5.

(2) Clean install of LE version 8.2.5 using LE USB-SD Creator. After an initial setup, I restored from a backup created by my current version of LE 8.2.5. After verifying that everything was working properly, I upgraded the system to LE version 9.0.2.

Note: Both systems are licensed to use the Pi's hardware MPEG2 decoder.

Has anyone else experienced similar problems running Leia on a Raspberry Pi 2 or higher?

LTolledo
Posts: 1944
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: Problems running Kodi Leia on Raspberry Pi 2 (LE 9.0.2)

Tue Aug 27, 2019 12:00 pm

though am not using PVR, if its a consolation to you:

I have Kodi Leia 18.2 running on a Raspberry Pi Model B (c) 2012

booting Raspbian Stretch with Desktop from 8GB SD card (yes its SD card, not microSD card), installed via NOOBS
overclocked to maximum available
GPU set at 192MB
hifiberry DAC as audio
system is autobooting to Kodi
Media accessed from NAS

no problem on video playback (plays as well as when am using RPi3B)

have another setup using RPiZeroW, again autoboot to Kodi Leia 18.2
audio via HDMI
again no problems with this setup as well
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

Return to “Beginners”