WillWam
Posts: 11
Joined: Fri May 17, 2019 9:18 pm

Raspbian Buster - No Java Support?

Sat Jun 29, 2019 10:49 pm

I'm trying to install Java 8 on the new Raspbian Buster (Lite). Having no luck, I get an error when I run the following command:

sudo apt-get install oracle-java8-jdk

The error is:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package oracle-java8-jdk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

So is Buster not ready for Java? Has Java not included Buster as a good-to-use distro? Or am I doing it all wrong? Many thanks.

User avatar
HawaiianPi
Posts: 4879
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Raspbian Buster - No Java Support?

Sat Jun 29, 2019 11:56 pm

Try apt search openjdk, and pick a version to install.

If you want Oracle Java you'll probably have to install it manually.

For Oracle Java 8 you could try the webupd8team PPA.
See this post: https://www.raspberrypi.org/forums/view ... 0#p1400092
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

Andyroo

Re: Raspbian Buster - No Java Support?

Sun Jun 30, 2019 12:02 am

The release notes say
Oracle Java 7 and 8 replaced with OpenJDK 11
Taken from http://downloads.raspberrypi.org/raspbi ... _notes.txt

fruitoftheloom
Posts: 21088
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Raspbian Buster - No Java Support?

Sun Jun 30, 2019 7:15 am

WillWam wrote:
Sat Jun 29, 2019 10:49 pm
I'm trying to install Java 8 on the new Raspbian Buster (Lite). Having no luck, I get an error when I run the following command:

sudo apt-get install oracle-java8-jdk

The error is:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package oracle-java8-jdk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

So is Buster not ready for Java? Has Java not included Buster as a good-to-use distro? Or am I doing it all wrong? Many thanks.

i am running a fully updated fresh standalone Raspbian Buster ( neither use NoobS crapware )

Code: Select all

sudo apt update
sudo apt full-upgrade
sudo reboot

OpenJDK 11 is the default, but OpenJDK 10, 9 & 8 are in repositories:

opendk-10-jdk openjdk-10-jre

opendk-9-jdk openjdk-9-jre

opendk-8-jdk openjdk-8-jre
Last edited by fruitoftheloom on Sat Jul 06, 2019 8:40 am, edited 1 time in total.
Retired disgracefully.....
This at present is my daily "computer" https://www.asus.com/us/Chrome-Devices/Chromebit-CS10/

User avatar
Gavinmc42
Posts: 4064
Joined: Wed Aug 28, 2013 3:31 am

Re: Raspbian Buster - No Java Support?

Sun Jun 30, 2019 7:20 am

Will be interesting to see how Processing works on a Pi4 now.
Is the Pi4 fast enough to run Netbeans?

I found Java with JavaFX borderline on 3's.
So many old things might just work well now on 4's
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

Return to “Beginners”