User avatar
pi-anazazi
Posts: 526
Joined: Fri Feb 13, 2015 9:22 pm
Location: EU

Raspbian (latest) - tigerVNC not working?

Mon Jun 24, 2019 3:38 pm

Hi!

I started installing latest Raspbian (Buster with GUI) on a raspi 2. Removed the VNC coming with the image, rebooted and installed TigerVNC from the "install and remove software" tool in the GUI.

I can start the VNCserver:

Code: Select all

vncserver -localhost no 
Cleaning stale pidfile '/home/pi/.vnc/raspberrypi:1.pid'!

New 'raspberrypi:1 (pi)' desktop at :1 on machine raspberrypi

Starting applications specified in /home/pi/.vnc/xstartup
Log file is /home/pi/.vnc/raspberrypi:1.log

Use xtigervncviewer -SecurityTypes VncAuth,TLSVnc -passwd /home/pi/.vnc/passwd raspberrypi:1 to connect to the VNC server.

but when I do on client:

Code: Select all

vncviewer -SecurityTypes VncAuth,TLSVnc -passwd /home/pi/.vnc/passwd IP_raspi:1
I get on the client "opening password file failed":

Code: Select all

TigerVNC Viewer 64-bit v1.9.80
Copyright (C) 1999-2019 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.

Mon Jun 24 17:33:47 2019
 DecodeManager: Detected 6 CPU core(s)
 DecodeManager: Creating 4 decoder thread(s)
 CConn:       Connected to host 10.0.0.5 port 5901
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 CConnection: Choosing security type VeNCrypt(19)
 CVeNCrypt:   Choosing security type VncAuth (2)
[b] CConn:       Opening password file failed[/b]
The server says in the log:

Code: Select all

...
Mon Jun 24 17:33:47 2019
 Connections: accepted: IP_client::36308
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VeNCrypt(19)
 SVeNCrypt:   Client requests security type VncAuth (2)
terminate called after throwing an instance of 'rdr::EndOfStream'
terminate called recursively
(EE) 
(EE) Backtrace:
(EE) 
(EE) 
Fatal server error:
(EE) Caught signal 6 (Aborted). Server aborting
(EE) 
syswrite() on closed filehandle WH at /usr/bin/vncserver line 912.
I only found this here:

https://github.com/TigerVNC/tigervnc/issues/800

...which gives me little hope.

Has anybody managed to get TigerVNC up and running on raspbian? :-)
Kind regards

anazazi

User avatar
pi-anazazi
Posts: 526
Joined: Fri Feb 13, 2015 9:22 pm
Location: EU

Re: Raspbian (latest) - tigerVNC not working?

Mon Jun 24, 2019 5:46 pm

PS: I tried the built-in tightVNC server, but that requires tightVNC viewer and is not compatible to tigerVNC I have installed on all my machines. :-(

So: Any way to get tigerVNC server to work on raspbian?
Kind regards

anazazi

User avatar
pi-anazazi
Posts: 526
Joined: Fri Feb 13, 2015 9:22 pm
Location: EU

Re: Raspbian (latest) - tigerVNC not working?

Fri Jun 28, 2019 2:03 pm

Really? Nobody running TigerVNC?
Kind regards

anazazi

mattmiller
Posts: 2099
Joined: Thu Feb 05, 2015 11:25 pm

Re: Raspbian (latest) - tigerVNC not working?

Fri Jun 28, 2019 2:26 pm

Nope -we all all use the standard RealVNC server that comes as standard

acavalin
Posts: 1
Joined: Mon Aug 12, 2019 11:34 am

Re: Raspbian (latest) - tigerVNC not working?

Mon Aug 12, 2019 11:47 am

Hello I found that this is a problem related to libunwind8 and the function _Unwind_RaiseException that overrides the one supplied in libgcc_s.so.1.
See https://bugs.debian.org/cgi-bin/bugrepo ... =932499#47

It works if you run the server like this:

Code: Select all

LD_PRELOAD=/lib/.../libgcc_s.so.1 Xtigervnc ...
but this is only a hack... the bug is fixed in tigervnc/1.9.0+dfsg-1 but in raspbian we only have tigervnc/1.9.0+dfsg-3.

Does someone knows how to tell the raspbian devs about this problem and bugfix?

fruitoftheloom
Posts: 20469
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Raspbian (latest) - tigerVNC not working?

Mon Aug 12, 2019 1:35 pm

acavalin wrote:
Mon Aug 12, 2019 11:47 am
Hello I found that this is a problem related to libunwind8 and the function _Unwind_RaiseException that overrides the one supplied in libgcc_s.so.1.
See https://bugs.debian.org/cgi-bin/bugrepo ... =932499#47

It works if you run the server like this:

Code: Select all

LD_PRELOAD=/lib/.../libgcc_s.so.1 Xtigervnc ...
but this is only a hack... the bug is fixed in tigervnc/1.9.0+dfsg-1 but in raspbian we only have tigervnc/1.9.0+dfsg-3.

Does someone knows how to tell the raspbian devs about this problem and bugfix?

The package is provided by Debian, you need to contact the package maintainers:

https://packages.debian.org/stable/source/tigervnc
Retired disgracefully.....

Return to “Beginners”