Page 1 of 1

Raspberry Pi 3B + no wifi

Posted: Fri Feb 08, 2019 4:23 pm
by xl97
I have no wifi icon in my menu bar

I currently have a 3.5 HDMI screen and a wireless keyboard connected..

I tried to add an entry to:

sudo nano /etc/wpa_suplpicant/wpa_supplicant.config file..

rebooted.. and still no wifi.

I set my 'locale' settings..

Then went to Raspi-Config settings.. >> Network Options >> WIfi


I just get the same errors over and over:

"Could not communicate with wpa_supplicant"

"There was an error running N2 WI-FI"



What does that mean? and why I am getting these errors? I'm just trying to connect to wifi.. should be simple?

I have no LAN to physically connect to.. so I was hoping to connect to wifi network.. then SSH in..

Actually I dont have any Bluetooth or WIFI icons in my 'task bar/menu bar'???

Re: Raspberry Pi 3B + no wifi

Posted: Fri Feb 08, 2019 4:52 pm
by B.Goode
Some potentially relevant questions:

What Operating System is running on your RPi3B+?

How are you powering your RPI3B+?

What information about your hardware is returned by the commands:

Code: Select all

cat /proc/device-tree/model ; echo
cat /proc/cpuinfo

Have you noted the regulatory requirement to set a valid locale or WiFi country code? Yes.



Also, note that the location and name of the WiFi configuration is

Code: Select all

 /etc/wpa_supplicant/wpa_supplicant.conf


Raspberry Pi Foundation documentation here:
https://www.raspberrypi.org/documentati ... ess-cli.md

Re: Raspberry Pi 3B + no wifi

Posted: Fri Feb 08, 2019 6:09 pm
by xl97
Thanks..

I'll see what I can answer right now.

* OS: Latest version of Raspbian (Stretch?) as of last week (Nov 12018 version if I recall?)

* Powering from Wal-wart (+5v / 2.5A)

* cat /proc/device-tree/model ; echo = Raspberry Pi 3 Model B Rev 1.2

* cat /proc/cpuinfo = too long to list... I am working off a 3.5 HDMI screen currently at work.. and no way to copy/paste the whol e'wall' of text that was returned.. what specifically are you looking for?

I'm not clear what the link here is supposed to help me fix here?
https://www.raspberrypi.org/documentati ... ess-cli.md

I have attempted to add settings to the /etc/wpa_supplicant/wpa_supplicant/config file

Hasnt changed anything.

Still no wifi access or icon
Still cant set the username/password using the GUI (raspi-config via desktop).. still get the same errors as noted above.

I am at work.. so not network cable (LAN) connection..
I am trying to connect to the (guest) wifi here at work.. so I can finally SSH in using something else besides the RPi & #.5 HDMI display..


If I go back to the wpa_supplicant file:

sudo nano /etc/wpa_supplicant/wpa_supplicant.config

I -do- see my entry that I added previously.

Re: Raspberry Pi 3B + no wifi

Posted: Fri Feb 08, 2019 6:19 pm
by B.Goode
It seems you do not have an RPi 3B+. (Although that is not relevant to getting your WiFi connection activated.)


The reference to the Raspberry Pi documentation was to emphasise that the name of the file you are editting is incorrect.

Re: Raspberry Pi 3B + no wifi

Posted: Fri Feb 08, 2019 6:38 pm
by xl97
Ahh.. I see.. you must be referencing the title..

Its Rapsberry Pi 3B + no wifi.

Not Raspberry Pi 3B+ (no space).


And I actually manualy typed the command in the first post..

sudo nano /etc/wpa_suplpicant/wpa_supplicant.config

is actually what was used:

sudo nano /etc/wpa_supplicant/wpa_supplicant.config

If thats what you are referring to?

It was typed in correctly in the terminal when the entry was added.

and it correct: (sudo nano /etc/wpa_supplicant/wpa_supplicant.config)

when checking to see if the entry is still there..

-------

These errors seems a bit more pertinent:

"Could not communicate with wpa_supplicant"

"There was an error running N2 WI-FI"

Not sure why those errors are happening?

Why cant it communicate with the wpa_supplicant file?

This error was present even before I tried to MANUALLY edit using: sudo nano


Is there a different place the file is located in Stretch from Jessie/Pixel?

Re: Raspberry Pi 3B + no wifi

Posted: Fri Feb 08, 2019 6:54 pm
by B.Goode
It was typed in correct in the terminal when the entry was added.

and it correct: (sudo nano /etc/wpa_supplicant/wpa_supplicant.config)

But the Raspberry Pi documentation already cited specifies -

Code: Select all

 /etc/wpa_supplicant/wpa_supplicant.conf
To the best of my knowledge that documentation is correct for use with the current Raspbian Stretch Operating System.

Re: Raspberry Pi 3B + no wifi

Posted: Fri Feb 08, 2019 7:02 pm
by xl97
DOH!...

I was glazing over the file extension.. and was focusing on the path stuff..

I see now:

config vs conf


I have added it to the correct file now (rebooted) and still no wifi? :(

** How can I delete the /config file I created??

Also.. if adding that info directly to the file works.. why isnt adding it through the desktop/gui working?

Why getting those errors? Why no wifi icon in tray? (or bluetooth for that matter?)

Re: Raspberry Pi 3B + no wifi

Posted: Fri Feb 08, 2019 7:33 pm
by B.Goode
I have nothing further to suggest.

These forums have no mechanism for 'allocating' cases to volunteers, but this is to make it clear that I am withdrawing from this discussion in the hope that you will find help from someone else.

Re: Raspberry Pi 3B + no wifi

Posted: Fri Feb 08, 2019 7:56 pm
by xl97
umm..ok.

Well thanks anyways!

I wasnt under the impression that posts were allocated to anyone.. Its a public forum to seek help. People hang out here and provide help because they are interested, or this area is their hobby (some job perhaps)..

So for anyone else...

Still no clear why getting those errors for 'communicating with the wpa_supplicant file'?

My gut says that is why no wifi.. (but nothing on why no BlueTooth icons either?) regardless if I enter entries into the files.. if it can read it or communicate with it... doesnt matter WHAT data is in the file.

LAN works fine..

WLAN = no luck.

Re: Raspberry Pi 3B + no wifi

Posted: Mon Mar 04, 2019 2:44 pm
by Taxicletter
I have the same problem here.

RPi 3, Raspian Lite. I HAD wifi working, but suddenly only ethernet OR USB-wifi dongle work. NOT the internal wifi. I get the errors you mention when I use raspi-config.

I tested if I still have the Wifi-hardware and that is recognised. I also have the correct network in the config files.

Did you find a solution?

EDIT: I tried adding this

Code: Select all

ctrl_interface=/run/wpa_supplicant
update_config=1
to etc/wpa_supplicant/wpa_supplicant.conf, because I read somewhere that was a solutions, but that didn't work.
(https://raspberrypi.stackexchange.com/q ... t-wlan0-re)

I also removed the already added networks there, which didn't help.
I removed the conf file and rebooted, also didn't help.

In https://github.com/RPi-Distro/raspi-con ... spi-config, I found that option N2 has something to do with the passphrase:

Code: Select all

      N2\ *) do_wifi_ssid_passphrase ;;

Re: Raspberry Pi 3B + no wifi

Posted: Tue Mar 05, 2019 3:24 am
by xl97
I just started over and used Etcher to re-image the SD card..

from there.. I followed my normal steps.. and things have been as expected.

Re: Raspberry Pi 3B + no wifi

Posted: Tue Mar 05, 2019 11:03 am
by Taxicletter
Thanks.

I did the same: re-install everything. I have the same problem, but I found the problem. I installed Pibox (http://p-node.org) and configured some things (in /etc/hostapd/hostapd.conf, /etc/default/hostapd, /etc/dnsmasq.conf and /etc/rc.local).
I think that is the reason for my error.

I'm waiting for reaction of the people who made that page to know what to do about it.