gabriel.rosseel
Posts: 128
Joined: Fri May 05, 2017 8:21 am

Update VNC Server

Fri Aug 17, 2018 7:45 am

When I contact my Raspberry PI trought my VNC Viewer on my Windows workstation I see in VNC Server - Information Center: "VNC Connect 6.3.1 is available"
I also run Webmin on my Windows workstation and Webmin says "All installed packages are up to date"
I seem to remember that there was a few years ago a simular topic on this forum but I can't find it anymore.
Can anyone help me how I can update my raspberry so I run the latest VNC server version 6.3.1?
Is it normal that Webmin doesn't see there is an update of VNC Connect avaiable?
As OS i run Jessie (Debian Linux 9.4).
Thanks in in advance, gabriël

fruitoftheloom
Posts: 17259
Joined: Tue Mar 25, 2014 12:40 pm

Re: Update VNC Server

Fri Aug 17, 2018 8:09 am

gabriel.rosseel wrote:
Fri Aug 17, 2018 7:45 am
?
As OS i run Jessie (Debian Linux 9.4).
Confused as Raspbian Jessie is 8.x and Raspbian Stretch is 9.x....
Adieu

DirkS
Posts: 8827
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Update VNC Server

Fri Aug 17, 2018 8:21 am

gabriel.rosseel wrote:
Fri Aug 17, 2018 7:45 am
Is it normal that Webmin doesn't see there is an update of VNC Connect avaiable?
Does webmin know if there are updates in the repository?
The information in the VNC dialog comes from the RealVNC website, not from the repository from where you install packages.

Which version is installed? Check in the RealVNC GUI dialog or use 'apt-cache policy realvnc-vnc-server' from the command line?
Current version is 6.3.1.36657

It could be that vnc is just a bit 'confused': see https://www.raspberrypi.org/forums/view ... c#p1352719

gabriel.rosseel
Posts: 128
Joined: Fri May 05, 2017 8:21 am

Re: Update VNC Server

Fri Aug 17, 2018 9:05 am

my mistake: my os is stretch, not jessie
the command apt-cache policy realvnc-vnc-server says I am running version 6.2.0.29523

fruitoftheloom
Posts: 17259
Joined: Tue Mar 25, 2014 12:40 pm

Re: Update VNC Server

Fri Aug 17, 2018 9:09 am

gabriel.rosseel wrote:
Fri Aug 17, 2018 9:05 am
my mistake: my os is stretch, not jessie
the command apt-cache policy realvnc-vnc-server says I am running version 6.2.0.29523

Not up to date Raspbian Stretch ?

Code: Select all

sudo apt update
sudo apt full-upgrade
Adieu

gabriel.rosseel
Posts: 128
Joined: Fri May 05, 2017 8:21 am

Re: Update VNC Server

Fri Aug 17, 2018 10:54 am

I executed the 2 commands bur VNC Connect wasn't updated

DirkS
Posts: 8827
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Update VNC Server

Fri Aug 17, 2018 11:18 am

gabriel.rosseel wrote:
Fri Aug 17, 2018 10:54 am
I executed the 2 commands bur VNC Connect wasn't updated
Do you see any error messages?
Please post full output of both commands

gabriel.rosseel
Posts: 128
Joined: Fri May 05, 2017 8:21 am

Re: Update VNC Server

Fri Aug 17, 2018 1:00 pm

sudo apt update
Hit:1 http://archive.raspberrypi.org/debian jessie InRelease
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Ign:3 http://download.webmin.com/download/repository sarge InRelease
Hit:4 http://download.webmin.com/download/repository sarge Release
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
W: Target Packages (contrib/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:5
W: Target Packages (contrib/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:5
W: Target Translations (contrib/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:5
W: Target Translations (contrib/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:5
W: Target Packages (contrib/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:5
W: Target Packages (contrib/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:5
W: Target Translations (contrib/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:5
W: Target Translations (contrib/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:5

sudo apt full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

DirkS
Posts: 8827
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Update VNC Server

Fri Aug 17, 2018 1:11 pm

Did you upgrade from Jessie to Stretch?
You forgot to change the reference to Jessie in /etc/apt/sources.list.d/raspi.list, so the upgrade was probably not complete.

Edit that and run the commands that @FotL listed a few posts further up.
Don't be surprised if your desktop and other GUI elements start to look different...
You may also need to install a few packages that were new in Stretch.

gabriel.rosseel
Posts: 128
Joined: Fri May 05, 2017 8:21 am

Re: Update VNC Server

Fri Aug 17, 2018 2:18 pm

I changed the references from jessie to strech in the file /etc/apt/sources.list.d/raspi.list as you suggested.
forgive me but I can't find te ref to @FotL (still a beginner).
Is it all right if a execute the commands "sudo apt-get update " and "sudo apt full upgrade" ?
in the meanwhile I will make an image of my SD-card.

fruitoftheloom
Posts: 17259
Joined: Tue Mar 25, 2014 12:40 pm

Re: Update VNC Server

Fri Aug 17, 2018 3:07 pm

gabriel.rosseel wrote:
Fri Aug 17, 2018 2:18 pm
I changed the references from jessie to strech in the file /etc/apt/sources.list.d/raspi.list as you suggested.
forgive me but I can't find te ref to @FotL (still a beginner).
Is it all right if a execute the commands "sudo apt-get update " and "sudo apt full upgrade" ?
in the meanwhile I will make an image of my SD-card.

FotL (fruit of the loom) is reference my post above..... ie

Code: Select all

sudo apt update
sudo apt full-upgrade
Adieu

gabriel.rosseel
Posts: 128
Joined: Fri May 05, 2017 8:21 am

Re: Update VNC Server

Fri Aug 17, 2018 4:10 pm

it works !!
I executed the 2 commands, rebooted and everyhing is now updated.
Thank you very much for all the help.
gabriël

Return to “Beginners”

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 45 guests