Page 1 of 1

No connectivity to internet

Posted: Wed Aug 15, 2018 7:52 am
by davidtja
My RPI has been up and running for some time without a problem. It has now suddenly lost connection to the internet. I had a similar problem some time ago and found the DNS had changed. I have reedited the DNS to the new one but still cannot get a connection. I can connect to it remotely and it can see the Hub. Any help greatly appreciated.

Re: No connectivity to internet

Posted: Thu Aug 16, 2018 6:54 am
by DougieLawson
Start by rebooting your router.

Re: No connectivity to internet

Posted: Thu Aug 16, 2018 12:44 pm
by davidtja
Yes I tried that first of all.

Re: No connectivity to internet

Posted: Thu Aug 16, 2018 12:48 pm
by DougieLawson
Undo your changes to /etc/network/interfaces and /etc/dhcpcd.conf. Then reboot your RPi.

Re: No connectivity to internet

Posted: Thu Aug 16, 2018 12:51 pm
by n67
A key question is:

What does the OP mean by "lost connection to the internet"?

What are the symptoms?

Re: No connectivity to internet

Posted: Thu Aug 16, 2018 4:38 pm
by davidtja
DougieLawson wrote:
Thu Aug 16, 2018 12:48 pm
Undo your changes to /etc/network/interfaces and /etc/dhcpcd.conf. Then reboot your RPi.
When you say undo changes do you mean leave it blank or put it back to what it was previously?

Re: No connectivity to internet

Posted: Thu Aug 16, 2018 5:37 pm
by DirkS
davidtja wrote:
Thu Aug 16, 2018 4:38 pm
DougieLawson wrote:
Thu Aug 16, 2018 12:48 pm
Undo your changes to /etc/network/interfaces and /etc/dhcpcd.conf. Then reboot your RPi.
When you say undo changes do you mean leave it blank or put it back to what it was previously?
Undo changes means to put it back in its original state.

Re: No connectivity to internet

Posted: Fri Aug 17, 2018 1:04 pm
by davidtja
Thanks for all help - it now seems to work, though I changed nothing. Very strange. Appreciate all advice.