Sheepdog
Posts: 16
Joined: Sun Aug 21, 2016 7:44 pm

3 B Wifi- WEP- would not connect- SOLVED- I think.

Sun Aug 05, 2018 9:19 pm

Not a question... a report of "how to", I hope. Maybe spare the next person. Inspire the programmers.

HOURS spent by me, new to Pi, old to computers today.
Wonderful experiences initially... then tried to connect my Pi 3 B, ver 1.2 to my Wi-Fi.

(Yes, did sudo apt update, upgrade... about 1pm New York time, 5 Aug 2018)

And unplugged wired connection and rebooted BEFORE trying, again, to connect to my Wi-Fi.

I'm pretty sure the Wi-Fi is using WEP security. (Yes, stone age... I know. I have some old devices that won't connect otherwise.)

I used the ordinary GUI "connect to Wi-Fi", and after filling in the "Pre-shared key" box, clicked "OK", dialog went away (no messages), and my screen just looked at me. Red X's on the icon for the network connection.

Tried lots and lots and lots of things.

Here's what worked...

1) used sudo nano /etc/wpa_supplicant/wpa_supplicant.conf to take the system-created double quotes OFF of the characters following wep_key0=
2) (save the new .conf file, on top of old one)
3) reboot
4) Just wait... less than 15 seconds. Hurrah! Network icon becomes a signal strength indicator!

DANGER- try to change the Wi-Fi you are connected to? The system will put the double quotes back, and you have to do it all over again. Sigh. (I wonder if just deleting the wep_key0= line would be as easy... but after the HOURS to get this far, and write up, I haven't the energy to try it! Or, perhaps some value other than "NONE" on the key_mgmt line... but putting WEP made things WORSE... from memory: Made system say "no Wi-Fi i/f found"!)

LEAVE the double quotes around the SSID spec.

Sigh. Aren't computers fun? At least I had the encouraging positive experience before hitting the near brick wall!

User avatar
DougieLawson
Posts: 38553
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: 3 B Wifi- WEP- would not connect- SOLVED- I think.

Tue Aug 07, 2018 5:05 pm

The much simpler solution is to forget that WEP ever existed and switch your network to WPA or WPA2 which, at least, give a partial semblence of security. Unlike WEP which is functionally equivalent to an open network.

Leave an old router/AP running for the WEP devices (with a strong firewall between them and your other devices) or wire the old stuff to your network.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

Return to “Beginners”