dsyleixa123
Posts: 423
Joined: Mon Jun 11, 2018 11:22 am

Stretch, numlockx: where is the file /etc/kbd/config ?

Sat Jun 30, 2018 1:51 pm

hello,
for Stretch, numlockx: where is the file /etc/kbd/config ?
As there is no such a file, I can't un-comment the line
LEDS=+num

dgordon42
Posts: 764
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Stretch, numlockx: where is the file /etc/kbd/config ?

Mon Jul 09, 2018 8:53 pm

The file '/etc/kbd/config' does not exist by default in Stretch, as you have found out.
I'm guessing that you want NumLock on at boot up to the CLI.
I managed it by writing a bash script that runs at boot, based on this stackexchange question

As for 'numlockx', simply installing it with 'apt-get' sets NumLock to on if I boot into the GUI.

Hope this helps,
Dave.

dsyleixa123
Posts: 423
Joined: Mon Jun 11, 2018 11:22 am

Re: Stretch, numlockx: where is the file /etc/kbd/config ?

Tue Jul 10, 2018 6:57 am

thank you,
actually the numlock works after installing numlockx and a reboot now with the numlockx NumOn setting, but I think the LED thing in /etc/kbd/config is just about a status LED on the keyboard itself which was admittedly a minor issue.
I just created this config file anew by sudo leafpad in that /etc/kbd/ dir with just that new mentioned entry, and now even the LED lights on correctly according to the Num key status.

Return to “Beginners”