Oriondelta
Posts: 2
Joined: Sun Jun 10, 2018 5:39 pm

Pi zero with camera - video play back not working

Tue Jun 12, 2018 8:32 pm

I have a raspberry pi camera rev 1.3 connected to a Pi zero. I have read and followed the camera documentation for the codes to take photos and videos and have down loaded VLC player. Photos and video taken are fine. However, have been unable to play back video made.

Can any body give me some pointers, where to go, what to read, who to ask or better solve this puzzle? I have connected the Pi to a monitor and have also tried via VNC - both giving the same result - the image (flicker) then nothing.

DirkS
Posts: 7819
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Pi zero with camera - video play back not working

Wed Jun 13, 2018 9:27 am

Oriondelta wrote:
Tue Jun 12, 2018 8:32 pm
I have read and followed the camera documentation for the codes to take photos and videos
Which documentation? Please post a link.
What software do you use to capture photos / videos?
and have down loaded VLC player.
Why?
Photos and video taken are fine. However, have been unable to play back video made.
How do you know the video is fine when you cannot play it?

Oriondelta
Posts: 2
Joined: Sun Jun 10, 2018 5:39 pm

Re: Pi zero with camera - video play back not working

Wed Jun 13, 2018 9:29 pm

Thanks for replying. The link below is from Picamera. I have literally typed in the code into Python 3.5.3 from reading section 3.9.

https://picamera.readthedocs.io/en/rele ... -to-a-file

I assume a video has been created accordingly by looking at its file properties. For a 300sec, a file size was generated with 29.2MiB and that when I open with VLC, it does produce the couple of frames but no more after that.

As to your question why download VLC, I have also tried omxplayer "insert filename" in the cmd command line but get no display. Instead I get - "Video codec omx-h264 width 640 height 480 profile 100 fps 25.000000 Subtitle count:0, state:off, index:1, delay:0 V:PortSettingChanged: 640x480@25.00 interlace:0 deinterlace:0 anaglyph:0 par:1. have a nice day ;)"

DirkS
Posts: 7819
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Pi zero with camera - video play back not working

Thu Jun 14, 2018 1:00 am

Did you try to play the raw output of picamera or did you convert it after capture?
Most players cannot play raw h264 files. See e.g. https://www.raspberrypi.org/documentati ... aspivid.md for adding an mp4 container using MP4Box

BTW: omxplayer should be able to play the h264 file.
Did you try to play it with a monitor attached? You can't view omxplayer output over VNC (well, you actually can with RealVNC and some experimental settings activated)

Return to “Beginners”

Who is online

Users browsing this forum: LTolledo and 47 guests