Jayce
Posts: 67
Joined: Sun Jan 29, 2017 5:53 am

VNC Server Icon not showing in the task bar

Thu Mar 15, 2018 7:20 am

After installing the VNC Server & Viewer, the VNC Server Icon should always be on the task bar but it doesn't. Any idea? VNC is enabled.

User avatar
KLL
Posts: 1453
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
Contact: Website

Re: VNC Server Icon not showing in the task bar

Thu Mar 15, 2018 9:47 am

-a- if you have full RASPBIAN installed
you only need to enable VNC by
sudo raspi-config

( and i not think that by a manual installation you would damage something unless you use REMOVE ... )

-b- if you have a RASPBIAN LITE with manual desktop and VNC installation tell us.

-c- there has been some events that the VNC server icon was missing ( or even the header menu line )
but a update / upgrade of that older system worked.
i not used the new 2018-03-13 version until now, did you?

-d- the header icon show following tooltip ( mouse over): "VNC Server - Service Mode"

Jayce
Posts: 67
Joined: Sun Jan 29, 2017 5:53 am

Re: VNC Server Icon not showing in the task bar

Thu Mar 15, 2018 1:19 pm

KLL wrote:
Thu Mar 15, 2018 9:47 am
-a- if you have full RASPBIAN installed
you only need to enable VNC by
sudo raspi-config

( and i not think that by a manual installation you would damage something unless you use REMOVE ... )
I have the full Raspbian Stretch 11-29-2017 version. I did try installing the VNC server & viewer through the terminal then enabling the VNC through the Configuration window from the preferences menu and via terminal "raspi-config"

I have tried the following :

1.) sudo systemctl enable vncserver-x11-serviced.service

- Code from vnc website for making the VNC server start at every boot.

2.) Basic troubleshooting via sudo update, upgrade and even dist-upgrade.

3.) Disabling / Enabling the VNC from the config menu.

I wonder if SSH has something to do with it?

What comes to mind now is to try installing tightvncserver, I don't know if that will work or try to re-download or re-install the OS but I fear that maybe a waste of time.

klricks
Posts: 5899
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: VNC Server Icon not showing in the task bar

Thu Mar 15, 2018 1:29 pm

RealVNC is already installed in Raspbian.
There is no need to install anything more.
When VNC is enabled by GUI or sudo raspi-config then RealVNC will autostart on boot so no need to do anything more.

Use the appropriate client RealVNC viewer from here: https://www.realvnc.com/en/connect/download/viewer/
Unless specified otherwise my response is based on the latest and fully updated Raspbian Stretch w/ Desktop OS.

Jayce
Posts: 67
Joined: Sun Jan 29, 2017 5:53 am

Re: VNC Server Icon not showing in the task bar

Thu Mar 15, 2018 1:31 pm

klricks wrote:
Thu Mar 15, 2018 1:29 pm
RealVNC is already installed in Raspbian.
There is no need to install anything more.
When VNC is enabled by GUI or sudo raspi-config then RealVNC will autostart on boot so no need to do anything more.

Use the appropriate client RealVNC viewer from here: https://www.realvnc.com/en/connect/download/viewer/
I am using my phone for the receiving side. Remote access works, the only problem is the VNC Server Icon not showing in the task bar. :(

Jayce
Posts: 67
Joined: Sun Jan 29, 2017 5:53 am

Re: VNC Server Icon not showing in the task bar

Thu Mar 15, 2018 2:24 pm

I re-installed the Raspbian OS on the SD card. And before doing anything or installing anything, I enabled the VNC on the interface section and the system tray icon popped up. :) I don't know what caused the problem last time though.

Anyways, thank you again for the time. I do really appreciate the replies and suggestions. Keep up the good work. :)

Return to “Beginners”