serekzolty
Posts: 6
Joined: Mon Jan 22, 2018 6:54 pm

Trouble booting from SSD

Mon Jan 22, 2018 6:58 pm

Hi there!
I am trying to boot from SSD connected via USB adapter. The SSD is visible in noobs which is starting from my SD Card. Then when i choose it, the install goes fine and the os seems to be installed on an ssd. The only problem is it won't boot.
I have changed the "bit" thing but it didn't seem to help.

I Have Raspberry PI 3B with 16 GB Card and 120 GB SSD. Can anyone help me, please ? I am trying to use raspbian :)

User avatar
KLL
Posts: 1453
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
Contact: Website

Re: Trouble booting from SSD

Tue Jan 23, 2018 5:09 am

what NOOBS installs on a external drive is not a bootable image!
pls try to BURN a RASPBIAN image on the SSD drive.
( windows / download 2017-11-29-raspbian-stretch.zip / use etcher or win32diskimager / )


and recheck the OTP (USB boot enable ) is set.

serekzolty
Posts: 6
Joined: Mon Jan 22, 2018 6:54 pm

Re: Trouble booting from SSD

Tue Jan 23, 2018 9:27 pm

Hello!
I have managed to install raspbian on my SSD using noobs started from sdcard, and the system is starting from SSD, but it will only power up if the card is present. As soon as I take out the card, the PI won't power up (tried 2 different sata to usb adapters).
The OTP is set properly i just checked that .
I'm sure the system is running on SSD, because first of all i did benchmark and the speeds are really high and second of all..if i disconnect the drive the system crashes.
Could it be the SATA to USB adater problem ? If so, can anyone recommend working one ?

k-pi
Posts: 637
Joined: Sun Feb 12, 2017 1:46 pm
Location: Upper Hale, Surrey, UK.

Re: Trouble booting from SSD

Wed Jan 24, 2018 10:53 am

I've used a USB2 2.5" external disk with two cables on mine, but not got around to running a 2.5" USB3/SSD with a single cable, yet.

It could be a lack of power, as a USB3 draws 900ma, as against USB2 which only uses 500ma.

drgeoff
Posts: 8629
Joined: Wed Jan 25, 2012 6:39 pm

Re: Trouble booting from SSD

Wed Jan 24, 2018 12:07 pm

k-pi wrote:
Wed Jan 24, 2018 10:53 am
a USB3 draws 900ma, as against USB2 which only uses 500ma.
You are somewhat confused. Specs say that a USB host port should be able to provide 900 mA whereas the corresponding figure for a USB2 one is 500 mA.

1. Those are the minimum figures. Actual host ports may be able to provide more. For example if using only one (USB2) host port on a RPi3 it is possible to draw 1000 mA or more if the PSU is strong enough.

2. Those figures concern what hosts provide. They do not mean that a USB3 device draws 900 mA or a USB2 device draws 500 mA.

drgeoff
Posts: 8629
Joined: Wed Jan 25, 2012 6:39 pm

Re: Trouble booting from SSD

Wed Jan 24, 2018 12:09 pm

serekzolty wrote:
Tue Jan 23, 2018 9:27 pm
Hello!
I have managed to install raspbian on my SSD using noobs started from sdcard,
Re-read and act on what KLL already told you.

serekzolty
Posts: 6
Joined: Mon Jan 22, 2018 6:54 pm

Re: Trouble booting from SSD

Wed Jan 24, 2018 3:52 pm

Ok I get it now... but still I flashed newest raspbian using Eckert on my SSD drive and it doesn't boot. Any ideas ?


serekzolty
Posts: 6
Joined: Mon Jan 22, 2018 6:54 pm

Re: Trouble booting from SSD

Wed Jan 24, 2018 5:20 pm

Hello guys...
I just bought a new SATA to USB adapter and....it works like a charm ! :)
I've got some other issues now so I'm gonna start a new topic. This one can be closed. Thank you everyone for your help, especially drgeoff and KLL.

Return to “Beginners”